Bug 195203 - anaconda has trouble finding kickstart file
anaconda has trouble finding kickstart file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 10:40 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 12:28:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-06-14 10:40:54 EDT
Description of problem:
I am seeing this on an ia64 system booted via elilo however I would not expect
this to be arch specific.

I used to be able to specify on the boot command line:
  append="ks=nfs:10.12.11.1:/export

where 10.12.11.1 is my NFS server

and anaconda would find the kickstart file named 10.12.11.11-kickstart
(10.12.11.11 is the ip of the system being installed)

however, starting with today's build it does not find the kickstart file unless
I specify the full path including the file i.e.

   ks=nfs:10.12.11.1:/export/10.12.11.11-kickstart

I have verified that the system being installed is getting the correct ip info
from dhcp but it appears it may be looking for another file name.


Version-Release number of selected component (if applicable):
rawhide-20060614
anaconda-11.1.0.33-1

How reproducible:
100% 

Steps to Reproduce:
1. place kickstart file on nfs server as <ip>-kickstart
2. boot with ks=nfs:<nfs ip>:<path to kickstart>
3. note that it does an interactive install vs. a kickstart install
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-06-19 20:32:23 EDT
We're probably not getting everything back with libdhcp that we were with pump.
Comment 2 David Cantrell 2006-08-01 17:41:59 EDT
This functionality is handled by the getHostandPath() function in kickstart.c,
which didn't change with the move to libdhcp.

The way we determine if we needed to use the default kickstart filename of
IPADDRESS-kickstart was to look for either (a) a null filespec or (b) a slash at
the end of the filespec.  If either of those conditions are met, we build the
IPADDRESS-kickstart filename.

Try adding a slash to the end of ks=nfs:10.12.11.1:/export

But, that said, I think there was a problem in nfsinstall.c that was causing the
wrong IP address to be used to build that filename.  This has been fixed in rawhide.
Comment 3 Doug Chapman 2006-08-01 17:54:22 EDT
Dave,

Still not working.  I must have missed the last / in the cut+paste when i did
the original BZ.  I did have a / at the end.  I verified this is still not
working as of rawhide-20060801
Comment 4 David Cantrell 2006-08-02 11:28:41 EDT
Eh?  I'm not seeing it fail.  Both with a hostname or IP address given for the
NFS server.

Can you attach /tmp/anaconda.log from the system it's failing on?
Comment 5 David Cantrell 2006-08-02 11:30:11 EDT
Also, can you boot with loglevel=debug to get the /tmp/anaconda.log file?  I
need to see full debug messages.

Thanks.
Comment 6 David Cantrell 2006-08-02 11:44:09 EDT
Wait, I just noticed the dates in these posts.  The fix for this problem was
included in last night's anaconda build, so it will be in the rawhide-20060802
tree, which is what I was using.

Give it a try with the 20060802 tree.
Comment 7 Doug Chapman 2006-08-02 12:28:13 EDT
David,

thanks, this does work with the 0802 tree.  Closing it now.

Note You need to log in before you can comment on or make changes to this bug.