Bug 195208 - Missing dependency causes undefined symbol gdk_screen_get_font_options
Missing dependency causes undefined symbol gdk_screen_get_font_options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 11:08 EDT by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.3-7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-28 04:37:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2006-06-14 11:08:10 EDT
With openoffice.org-core-2.0.3-5.3 and older versions of some other packages:

/usr/lib/openoffice.org2.0/program/soffice.bin: symbol lookup error:
/usr/lib/openoffice.org2.0/program/libpsp680li.so: undefined symbol:
gdk_screen_get_font_options

I upgraded cairo, cairo-devel, glib2, glib2-devel, gtk2, gtk2-engines, pango,
redhat-artwork, gtk+, and gtk+-devel to make this go away.  I suspect that gtk2
was the problem, although I'm not certain.
Comment 1 Caolan McNamara 2006-06-26 05:20:48 EDT
Hmm...

> objdump -T /usr/lib/libgdk-x11-2.0.so.0.903.1 | grep gdk_screen_get_font_options
041c82e0 g    DF .text  00000071  Base        gdk_screen_get_font_options
> rpm -qf /usr/lib/libgdk-x11-2.0.so.0.903.1
gtk2-2.9.4-1
> rpm -qf /usr/lib/openoffice.org2.0/program/libpsp680li.so
openoffice.org-core-2.0.3-6.1
> rpm -qR openoffice.org-core-2.0.3-6.1|grep gdk-x11
libgdk-x11-2.0.so.0

The magic rpm lib depend stuff should have worked all this out for us, and it
does seem to show the right chain of dependancies for me above. Perhaps we can
write this off to some random foo in mirroring or the rpm depend lib generation.
Comment 2 Jonathan Kamens 2006-06-27 05:49:22 EDT
The problem is that there's an earlier version of libgdk-x11-2.0.so.0 which 
doesn't have gdk_screen_get_font_options.  I.e., the maintainers of gtk2 added 
a symbol to the library without changing the shared library versioning to 
account for the change.  Admittedly, that's a no-no that the gtk2 maintainers 
shouldn't have done, but it seems to me that the openoffice.org RPMs should 
cope with it.

I previously had gtk2-2.8.12-7 installed.
Comment 3 Caolan McNamara 2006-06-27 07:25:33 EDT
It still doesn't sound like an OOo problem to me, but I'll bump the PreReq to 2.9.3
Comment 4 Caolan McNamara 2006-06-28 04:37:25 EDT
rpm -qpR openoffice.org-core-2.0.3-7.1.i386.rpm | grep gtk2
gtk2 >= 2.9.4

Note You need to log in before you can comment on or make changes to this bug.