Bug 1952293 - OKD 4.7 unable to access Project Topology View
Summary: OKD 4.7 unable to access Project Topology View
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.7
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: 4.7.z
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
Harsh Mishra
URL:
Whiteboard:
: 1954719 1957231 (view as bug list)
Depends On: 1949810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-22 01:34 UTC by OpenShift BugZilla Robot
Modified: 2021-06-10 09:18 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when the user navigated to the *Topology* view, an error occurred if there were no templates on the `openshift` namespace. If this error occurred, a blank page would display. This issue has been fixed by handling the edge case with respect to the templates not being present in the `openshift` namespace. The user can now navigate to the *Topology* view and it loads as expected.
Clone Of:
Environment:
Last Closed: 2021-05-19 15:16:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8736 0 None closed [release-4.7] Bug 1952293: adds check for templates 2021-05-18 11:49:39 UTC
Red Hat Knowledge Base (Solution) 6024901 0 None None None 2021-05-07 17:30:27 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:16:49 UTC

Description OpenShift BugZilla Robot 2021-04-22 01:34:56 UTC
+++ This bug was initially created as a clone of Bug #1949810 +++

Created attachment 1772076 [details]
After developer login or clicking on topology view

Describe the bug

Developers unable to see the topology view of openshift project, Insted of that it is showing white blank page.

Version

4.7.0-0.okd-2021-03-07-090821

How reproducible

Switch to Developer console ---> click on topology
Expected - Topology view of the project
Results - White Blank Page

URL Path looks like - https://console-url/topology/ns/project-name?view=graph

--- Additional comment from jakumar@redhat.com on 2021-04-19 14:18:38 UTC ---

(In reply to Midhun K from comment #0)
> Created attachment 1772076 [details]
> After developer login or clicking on topology view
> 
> Describe the bug
> 
> Developers unable to see the topology view of openshift project, Insted of
> that it is showing white blank page.
> 
> Version
> 
> 4.7.0-0.okd-2021-03-07-090821
> 
> How reproducible
> 
> Switch to Developer console ---> click on topology
> Expected - Topology view of the project
> Results - White Blank Page
> 
> URL Path looks like - https://console-url/topology/ns/project-name?view=graph

Hi Midhun, 

we tried to verify it on 4.7.0-0.okd-2021-03-28-152009/ 4.7.0-0.okd-2021-04-11-124433 and we couldn't reproduce it.

https://github.com/openshift/console/issues/8499#issuecomment-822218105

Above where new cluster, no operator were installed on it.
Looks like we need, some more information to reproduce it

- What was the user role?
- Was there any Operator installed?

--- Additional comment from cvogt@redhat.com on 2021-04-21 16:18:16 UTC ---

The issue was found. See discussion here: https://github.com/openshift/console/issues/8499#issuecomment-823625064

If the OpenShift samples operator is not installed, there will be no Templates in the openshift namespace. This results in an error when loading topology.

The fix for the issue is identified in the referenced github issue

Comment 2 Gajanan More 2021-04-29 10:37:06 UTC
I have validated the bugzilla on:
Build: 4.7.0-0.nightly-2021-04-29-024100
Browser: Google Chrome Version 89
Marking this as verified

Comment 4 cvogt 2021-05-03 16:23:19 UTC
Creating a template in the `openshift` namespace would be a workaround until the next 4.7.z release contains the fix and the customer is able to upgrade.

Comment 5 Alexander Stafeyev 2021-05-05 09:51:42 UTC
(In reply to Gajanan More from comment #2)
> I have validated the bugzilla on:
> Build: 4.7.0-0.nightly-2021-04-29-024100
> Browser: Google Chrome Version 89
> Marking this as verified

When will this fix be available in errata pls ? 
Thanks

Comment 6 cvogt 2021-05-05 21:43:20 UTC
Unsure if the fix made it to 4.7.9. If not it should be available in 4.7.10.

I suggest the customer apply the workaround of creating a Template in the `openshift` namespace.

Comment 8 Debsmita Santra 2021-05-10 14:27:17 UTC
*** Bug 1957231 has been marked as a duplicate of this bug. ***

Comment 9 Siddharth Sharma 2021-05-10 17:59:23 UTC
This bug will be shipped as part of next z-stream release 4.7.11 on May 19th, as 4.7.10 was dropped due to a blocker https://bugzilla.redhat.com/show_bug.cgi?id=1958518.

Comment 12 Jaivardhan Kumar 2021-05-18 11:58:53 UTC
*** Bug 1954719 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2021-05-19 15:16:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.