Bug 19525 - "Messy" symbolic links
Summary: "Messy" symbolic links
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-21 19:49 UTC by tim.landscheidt
Modified: 2007-03-27 03:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-11 03:20:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tim.landscheidt 2000-10-21 19:49:32 UTC
symlinks is disturbed by the following "messy" symbolic links in
XFree86-4.0.1-1.i386.rpm and XFree86-xfs-4.0.1-1.i386.rpm:

/usr/X11R6/lib/X11/xinit -> ../../../.././etc/X11/xinit
/usr/X11R6/lib/X11/xsm -> ../../../.././etc/X11/xsm
/usr/X11R6/lib/X11/fs -> ../../../.././etc/X11/fs

The "/./" is the culprit.

Comment 1 Daniel Roesen 2000-10-24 10:45:29 UTC
although it's not nice, it should have no bad side effects at all.

Comment 2 Tim Landscheidt 2000-12-11 03:20:00 UTC
That's why I chose "Severity: Enhancement" which is not printed under
"Additional Information" BTW (a bug in Bugzilla?) :-).

Comment 3 Mike A. Harris 2001-02-19 13:57:37 UTC
Considering the pros and cons of using absolute vs. relative symlinks,
we have come to the conclusion that there is no solution that will please
everyone in every case.  Since it cannot be both ways, we are leaving it
the way it is, which we consider the least of 2 evils.


Note You need to log in before you can comment on or make changes to this bug.