Bug 1952518 - Instal to hard drive logo on kde spin is old one and not the new
Summary: Instal to hard drive logo on kde spin is old one and not the new
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-logos
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-22 12:59 UTC by Geraldo Simião
Modified: 2021-05-04 21:22 UTC (History)
7 users (show)

Fixed In Version: fedora-logos-34.0.3-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 02:05:47 UTC
Type: Bug


Attachments (Terms of Use)
Plasma desktop sreenshot where one can see the icon with the old logo (140.60 KB, image/png)
2021-04-22 12:59 UTC, Geraldo Simião
no flags Details
the icon is used by the liveinstal program (181.08 KB, image/png)
2021-04-23 15:40 UTC, Geraldo Simião
no flags Details
print showing where the icon with the old logo is (395.34 KB, image/png)
2021-04-27 16:34 UTC, Geraldo Simião
no flags Details
Print of the desktop and menu with the new logo on the icon. (412.46 KB, image/png)
2021-04-30 14:10 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2021-04-22 12:59:04 UTC
Created attachment 1774470 [details]
Plasma desktop sreenshot where one can see the icon with the old logo

Description of problem:
Icon on desktop at F34 kde spin (Fedora_34_RC_1.1) is the old one, not the new one. Everything else uses the new logo (anaconda, menus etc...), just that icon uses the "legacy logo".

Version-Release number of selected component (if applicable):
Fedora-KDE-Live-x86_64-34-1.1.iso

How reproducible:
always

Steps to Reproduce:
1.start live image
2.see icon on desktop


Actual results:
old "legacy" logo on icon

Expected results:
new fedora logo on icon

Additional info:
This is just a minor, cosmetic issue, but since the new logo is there and is being used on everything eles, why not use it on this icon too?

Comment 1 Tom "spot" Callaway 2021-04-22 13:38:56 UTC
If you can figure out exactly which image file is being loaded there, it would help me a great deal in figuring out how to resolve this issue.

Comment 2 Geraldo Simião 2021-04-23 15:40:21 UTC
Created attachment 1774859 [details]
the icon is used by the liveinstal program

Comment 3 Ben Cotton 2021-04-23 16:17:08 UTC
Okay, so I think I know where it's coming from. /usr/share/applications/liveinst.desktop has "Icon=org.fedoraproject.AnacondaInstaller". Several files by this name are provided by the fedora-logos package in /usr/share/icons. BUT breeze-icon-theme also provides a file /usr/share/icons/breeze/apps/48/org.fedoraproject.AnacondaInstaller.svg, which I'm guessing comes first in however the desktop file is evaluated.

Comment 4 Tom "spot" Callaway 2021-04-23 17:43:57 UTC
breeze-icon-theme should NOT have a copy of the fedora trademark logo. :)

Comment 5 Geraldo Simião 2021-04-27 16:34:41 UTC
Created attachment 1776085 [details]
print showing where the icon with the old logo is

Yeah, Ben is right, this icon is at /usr/share/icons/breeze/app/48/org.fedoraproject.AnacondaInsaller.svg

Comment 6 Fedora Update System 2021-04-29 19:20:22 UTC
FEDORA-2021-45b115b1bb has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-45b115b1bb

Comment 7 Fedora Update System 2021-04-30 01:42:55 UTC
FEDORA-2021-45b115b1bb has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-45b115b1bb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-45b115b1bb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Geraldo Simião 2021-04-30 14:10:43 UTC
Created attachment 1777821 [details]
Print of the desktop and menu with the new logo on the icon.

After the new update (breeze-icon-theme-5.81.0-3.fc34 and fedora-logos-34.0.3-1.fc34) icon changed to the new logo, great! 
Bug fixed. Hope it goes to stable soon.

Comment 9 Fedora Update System 2021-05-03 02:05:47 UTC
FEDORA-2021-45b115b1bb has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.