Bug 195259 - after doing a VNC install firstboot improperly runs in graphical mode
after doing a VNC install firstboot improperly runs in graphical mode
Status: CLOSED DUPLICATE of bug 173168
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 12:35 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 12:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-06-14 12:35:39 EDT
Description of problem:
This was seen on HP Integrity ia64.

Not sure if this is an anaconda or firstboot issue but my guess is anaconda is
what tells firstbot how to run.

I did a VNC install.  When the system booted up it started the X server and ran
firstboot in graphical mode.  This defeats the advantage vnc gives for not
needing to be physically at the system.  In this case the system does have a
video card however there is not keyboard or montitor so it is essentially headless.

Note that this stops the boot until firstboot terminates so you never get a
login prompt on the console.

If I do a text install it properly runs firstboot in text mode.  In RHEL3/4 a
vnc install would also cause firstboot to be run in text mode.

Note, VNC installs have been broken (for my hardware at least) for quite some
time.  This is the first I have been successful in getting a VNC install to work
so I don't know when this change first happend.

Version-Release number of selected component (if applicable):
rawhide-20060614
anaconda-11.1.0.33-1
firstboot-1.4.11-1

How reproducible:
100%

Steps to Reproduce:
1. do a vnc install
2. reboot and see if firstbot tries to start the X server
3.
  
Actual results:
firstboot runs in graphical mode

Expected results:
firstboot should run in text mode or firstboot could run on a vnc server (which
would be a nice feature).

Additional info:
Comment 1 Chris Lumens 2006-06-27 12:43:00 EDT
We plan on having VNC installs set up VNC for post-installation eventually,
which would fix your problem about not being able to see what's going on.  If
you want finer grained control over vnc and firstboot during installation, you
can always use kickstart.

*** This bug has been marked as a duplicate of 173168 ***

Note You need to log in before you can comment on or make changes to this bug.