Bug 195266 - DOSBox 0.65 freezes on kernel 2.6.16-1.2133_FC5 (but worked since kernel 2054 at least)
DOSBox 0.65 freezes on kernel 2.6.16-1.2133_FC5 (but worked since kernel 2054...
Status: CLOSED DUPLICATE of bug 194597
Product: Fedora
Classification: Fedora
Component: dosbox (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 12:48 EDT by Byron Smith
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 10:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (7.84 KB, application/x-gzip)
2006-06-14 12:48 EDT, Byron Smith
no flags Details
/var/log/messages (141.91 KB, application/x-gzip)
2006-06-14 12:49 EDT, Byron Smith
no flags Details

  None (edit)
Description Byron Smith 2006-06-14 12:48:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. DOSBox
  
Actual results:
X Windows hangs for 2-3 minutes, then comes back. DOSBox remains frozen (empty
black box) and must be killed. Errors are dumped to dmesg and messages.

Expected results:
DOSBox should run as normal

Additional info:
------------[ cut here ]------------
kernel BUG at include/linux/list.h:58!
invalid opcode: 0000 [#1]
last sysfs file: /block/sdb/sdb1/stat
Modules linked in: vfat fat autofs4 hidp rfcomm l2cap bluetooth sunrpc
ip_conntrack_netbios_ns ipt_REJECT xt_state ip_conntrack nfnetlink xt_tcpudp
iptable_filter ip_tables x_tables dm_mirror dm_mod video button battery ac
sd_mod sg ipv6 lp parport_pc parport nvram usb_storage scsi_mod uhci_hcd
ehci_hcd e100 mii snd_ca0106 snd_rawmidi snd_ac97_codec snd_seq_dummy
snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss
snd_pcm snd_timer snd soundcore snd_ac97_bus snd_page_alloc i2c_i801 i2c_core
ext3 jbd
CPU:    0
EIP:    0060:[<f89661fa>]    Not tainted VLI
EFLAGS: 00210096   (2.6.16-1.2133_FC5 #1) 
EIP is at snd_seq_delete_all_ports+0x74/0x17d [snd_seq]
eax: 00000044   ebx: f4b91448   ecx: e99b2f48   edx: f8967433
esi: f4b91448   edi: f6664d80   ebp: f6664e08   esp: e99b2f44
ds: 007b   es: 007b   ss: 0068
Process dosbox (pid: 9024, threadinfo=e99b2000 task=f515c550)
Stack: <0>f8967433 f4b91448 f6664e08 f6664e10 00200246 f6664e1c f6664d80 f709e64c 
       f6664d80 00000000 f4cbdcc0 f708d33c f89611bc f6664d80 f896127d f6664d80 
       f89612c4 00000008 c01561cf f709e64c f7ff2d40 f4cbdcc0 00000000 f4eaec80 
Call Trace:
 [<f89611bc>] seq_free_client1+0x8/0x7e [snd_seq]     [<f896127d>]
seq_free_client+0x4b/0x80 [snd_seq]
 [<f89612c4>] snd_seq_release+0x12/0x31 [snd_seq]     [<c01561cf>] __fput+0xae/0x151
 [<c0153cf7>] filp_close+0x4e/0x54     [<c0102be9>] syscall_call+0x7/0xb
Code: 88 00 00 00 39 af 88 00 00 00 74 63 8b 9f 88 00 00 00 8b b7 8c 00 00 00 8b
43 04 39 f0 74 17 50 56 68 33 74 96 f8 e8 43 5c 7b c7 <0f> 0b 3a 00 1e 74 96 f8
83 c4 0c 8b 06 39 d8 74 17 50 53 68 e8 
Continuing in 120 seconds. 
Continuing in 119 seconds. 
Continuing in 118 seconds. 

      (and so on and so forth.........)
Continuing in 3 seconds. 
Continuing in 2 seconds. 
Continuing in 1 seconds. 

 <3>Debug: sleeping function called from invalid context at include/linux/rwsem.h:43
in_atomic():0, irqs_disabled():1
 [<c011c70b>] profile_task_exit+0x13/0x3e     [<c011dcbb>] do_exit+0x1c/0x717
 [<c010405f>] register_die_notifier+0x0/0x2f     [<c01045ae>] do_invalid_op+0x0/0x9d
 [<c010463f>] do_invalid_op+0x91/0x9d     [<f89661fa>]
snd_seq_delete_all_ports+0x74/0x17d [snd_seq]
 [<c011bcb0>] vprintk+0x16d/0x2fa     [<c01a5300>] avc_has_perm+0x3a/0x44
 [<c01036a3>] error_code+0x4f/0x54     [<f89661fa>]
snd_seq_delete_all_ports+0x74/0x17d [snd_seq]
 [<f89611bc>] seq_free_client1+0x8/0x7e [snd_seq]     [<f896127d>]
seq_free_client+0x4b/0x80 [snd_seq]
 [<f89612c4>] snd_seq_release+0x12/0x31 [snd_seq]     [<c01561cf>] __fput+0xae/0x151
 [<c0153cf7>] filp_close+0x4e/0x54     [<c0102be9>] syscall_call+0x7/0xb
Comment 1 Byron Smith 2006-06-14 12:48:53 EDT
Created attachment 130878 [details]
dmesg output
Comment 2 Byron Smith 2006-06-14 12:49:52 EDT
Created attachment 130879 [details]
/var/log/messages
Comment 3 Jan-Thomas Czornack 2006-06-20 04:04:23 EDT
Can confirm this problem. Dosbox worked well on Kernel 2122. Problem has also
been discussed and confirmed on fedoraforum.org:

http://forums.fedoraforum.org/showthread.php?t=113328&page=1&pp=15
Comment 4 Stephen Holt 2006-06-26 09:59:57 EDT
Same Problem in FC4 with any kernel after 2.6.16.2096_FC4...
 
Comment 5 Andreas Bierfert 2006-06-26 15:03:08 EDT
Thanks for reporting this... Its on top of my to do list... hope I can figure
out something asap...
Comment 6 P V 2006-06-28 15:59:36 EDT
I have the same problem on Linux 2.6.16-1.2133_FC5 #1 Tue Jun 6 00:52:14 EDT 
2006 i686 i686 i386 GNU/Linux

localhost kernel: ------------[ cut here ]------------
localhost kernel: kernel BUG at include/linux/list.h:58!
localhost kernel: invalid opcode: 0000 [#1]
localhost kernel: CPU:    0
localhost kernel: EIP is at snd_seq_delete_all_ports+0x74/0x17d [snd_seq]
localhost kernel: eax: 00000044   ebx: d6321048   ecx: f1876f48   edx: 
f836a433
localhost kernel: esi: d6321048   edi: caca8580   ebp: caca8608   esp: 
f1876f44
localhost kernel: ds: 007b   es: 007b   ss: 0068
localhost kernel: Process dosbox (pid: 32445, threadinfo=f1876000 
task=f71f8000)
localhost kernel: Stack: <0>f836a433 d6321048 caca8608 caca8610 00200246 
caca861c caca8580 f63ec930
localhost kernel:        caca8580 00000000 d57fb800 f615c72c f83641bc caca8580 
f836427d caca8580
localhost kernel:        f83642c4 00000008 c01561cf f63ec930 f76d3d40 d57fb800 
00000000 d5ffae40
localhost kernel: Call Trace:
localhost kernel:  [<f83641bc>] seq_free_client1+0x8/0x7e [snd_seq]     
[<f836427d>] seq_free_client+0x4b/0x80 [snd_seq]
localhost kernel:  [<f83642c4>] snd_seq_release+0x12/0x31 [snd_seq]     
[<c01561cf>] __fput+0xae/0x151
localhost kernel:  [<c0153cf7>] filp_close+0x4e/0x54     [<c0102be9>] 
syscall_call+0x7/0xb
localhost kernel: Code: 88 00 00 00 39 af 88 00 00 00 74 63 8b 9f 88 00 00 00 
8b b7 8c 00 00 00 8b 43 04 39 f0 74 17 50 56 68 33 a4 36 f8 e8 43 2c db c7 
<0f> 0b 3a 00 1e a4 36 f8 83 c4 0c 8b 06 39 d8 74 17 50 53 68 e8

Comment 7 Matthew Miller 2006-06-29 09:59:10 EDT
FWIW, same thing happens in rawhide with kernel 2.6.17-1.2307_FC6.
Comment 8 Matthew Miller 2006-06-29 10:16:28 EDT
It looks like RH/Fedora kernel hacker Dave Jones is working on this:

http://lkml.org/lkml/2006/6/22/505

Perhaps this should be moved to component "kernel"?

Or, actually... this is a dup.

*** This bug has been marked as a duplicate of 194597 ***
Comment 9 Matthew Miller 2006-07-03 10:09:30 EDT
FYI: this is fixed in kernel-2.6.17-1.2141_FC4 in the FC4 updates (and
presumably the corresponding FC5 and devel releases).
Comment 10 André Fettouhi 2006-07-23 09:40:54 EDT
I just tried to run dosbox 0.65 on FC5 box with the latest kernel (2157 for FC5)
and I just get a window that pops up and then nothing . Do I need to make a
configuration file first? My machine is a Dell Inspiron 8200.

Regards

André

Note You need to log in before you can comment on or make changes to this bug.