Bug 1953125 - Latest kitty upgrade breaks titlebar on Wayland
Summary: Latest kitty upgrade breaks titlebar on Wayland
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kitty
Version: 33
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-24 00:16 UTC by Daniel Bowling
Modified: 2021-04-24 01:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-24 01:30:37 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of my laptop (1.58 MB, image/png)
2021-04-24 00:16 UTC, Daniel Bowling
no flags Details
screenshot of my desktop (2.99 MB, image/png)
2021-04-24 00:17 UTC, Daniel Bowling
no flags Details

Description Daniel Bowling 2021-04-24 00:16:11 UTC
Created attachment 1774954 [details]
screenshot of my laptop

Description of problem:
After my latest `dnf update` kitty no longer has a Gnome-style titlebar and on my laptop the window also scales all weird when logged into a Wayland session, like it's very tall so it runs off the bottom of the screen and also way wider than it should be (scaling seems to be ok on my desktop but the titlebar is still messed up)

Version-Release number of selected component (if applicable):
0.20.1 (upgraded from 0.19.3)

How reproducible:
Both Wayland-compatible machines I tried

Steps to Reproduce:
1. Upgrade kitty to 0.20.1
2. Login to a Wayland session
3. Open kitty

Actual results:
kitty has a weird titlebar and weird scaling

Expected results:
kitty opens as it should with normal titlebar and the usual 80x25 size

Additional info:
Still works fine with legacy X11 session

Comment 1 Daniel Bowling 2021-04-24 00:17:44 UTC
Created attachment 1774955 [details]
screenshot of my desktop

Comment 2 Daniel Bowling 2021-04-24 01:30:37 UTC
Please disregard, it appears this is not a bug but a feature:

>They arent gone they are just not native. If you want native set linux_display_server to x11 in kitty.conf which was what it used to default to.

source: https://github.com/kovidgoyal/kitty/issues/3284

Closing but please do consider the possibility this change may be disruptive to Wayland users. I'm not sure how one addresses this; perhaps documentation and/or include a config file in the package? Godspeed!


Note You need to log in before you can comment on or make changes to this bug.