Bug 1953438 - fluidsynth-libs: incompatible upgrade from libfluidsynth.so.1 to libfluidsynth.so.2 (F32)
Summary: fluidsynth-libs: incompatible upgrade from libfluidsynth.so.1 to libfluidsynt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fluidsynth
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Christoph Karl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-26 06:31 UTC by customercare
Modified: 2021-05-25 01:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-25 01:54:34 UTC
Type: Bug


Attachments (Terms of Use)

Description customercare 2021-04-26 06:31:12 UTC
Description of problem:

Looks like, some packages have not been updated properly

 Problem 1: package scummvm-2.2.0-2.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
  - cannot install both fluidsynth-libs-2.1.8-3.fc32.x86_64 and fluidsynth-libs-1.1.11-7.fc32.x86_64
  - cannot install both fluidsynth-libs-1.1.11-7.fc32.x86_64 and fluidsynth-libs-2.1.8-3.fc32.x86_64
  - cannot install the best update candidate for package scummvm-2.2.0-2.fc32.x86_64
  - cannot install the best update candidate for package fluidsynth-libs-1.1.11-7.fc32.x86_64
 Problem 2: package calf-0.90.3-6.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
  - cannot install both fluidsynth-libs-2.1.8-3.fc32.x86_64 and fluidsynth-libs-1.1.11-7.fc32.x86_64
  - cannot install both fluidsynth-libs-1.1.11-7.fc32.x86_64 and fluidsynth-libs-2.1.8-3.fc32.x86_64
  - package fluidsynth-2.1.8-3.fc32.x86_64 requires libfluidsynth.so.2()(64bit), but none of the providers can be installed
  - package fluidsynth-2.1.8-3.fc32.x86_64 requires fluidsynth-libs(x86-64) = 2.1.8-3.fc32, but none of the providers can be installed
  - cannot install the best update candidate for package fluidsynth-1.1.11-7.fc32.x86_64
  - cannot install the best update candidate for package calf-0.90.3-6.fc32.x86_64

As pulse-effects depends on calf, i can't remove it. 

After removing scummvm, the next collision appears:

 Problem 1: package calf-0.90.3-6.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
  - cannot install both fluidsynth-libs-2.1.8-3.fc32.x86_64 and fluidsynth-libs-1.1.11-7.fc32.x86_64
  - cannot install both fluidsynth-libs-1.1.11-7.fc32.x86_64 and fluidsynth-libs-2.1.8-3.fc32.x86_64
  - cannot install the best update candidate for package fluidsynth-libs-1.1.11-7.fc32.x86_64
  - cannot install the best update candidate for package calf-0.90.3-6.fc32.x86_64
 Problem 2: package lv2-calf-plugins-0.90.3-6.fc32.x86_64 requires calf = 0.90.3-6.fc32, but none of the providers can be installed
  - package calf-0.90.3-6.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
  - cannot install both fluidsynth-libs-2.1.8-3.fc32.x86_64 and fluidsynth-libs-1.1.11-7.fc32.x86_64
  - cannot install both fluidsynth-libs-1.1.11-7.fc32.x86_64 and fluidsynth-libs-2.1.8-3.fc32.x86_64
  - package fluidsynth-2.1.8-3.fc32.x86_64 requires libfluidsynth.so.2()(64bit), but none of the providers can be installed
  - package fluidsynth-2.1.8-3.fc32.x86_64 requires fluidsynth-libs(x86-64) = 2.1.8-3.fc32, but none of the providers can be installed
  - cannot install the best update candidate for package lv2-calf-plugins-0.90.3-6.fc32.x86_64
  - cannot install the best update candidate for package fluidsynth-1.1.11-7.fc32.x86_64

Comment 1 customercare 2021-04-26 08:18:44 UTC
The F33 version of Calf solves the problem:

Workaround: sudo dnf update calf --releasever=33

Comment 2 Fedora Program Management 2021-04-29 17:08:15 UTC
This message is a reminder that Fedora 32 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 32 on 2021-05-25.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '32'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 32 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Christoph Karl 2021-05-02 16:04:55 UTC
For me it's OK to timeout this bug, due to it seems to be fixed in releasever =33 (see comment 1).

Comment 4 Carl George 🤠 2021-05-07 03:36:21 UTC
No, it's not OK.  Please review the Fedora policy for stable releases [0].  When you pushed fluidsynth-2.1.8-3.fc32 [1] you bumped the soname from libfluidsynth.so.1 to libfluidsynth.so.2.  That is not permitted in a stable release without FESCo approval.

Please open a FESCo ticket and ask for assistance on how to proceed.  Based on a quick repoquery, the following packages will need to be rebuilt.

Carla
ardour5
audacious-plugins
csound
denemo
drumstick
fluidsynth-dssi
gstreamer1-plugins-bad-free
lmms
minuet
muse
openttd
prboom-plus
qsynth
scummvm
swami
tuxguitar

[0] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#stable-releases
[1] https://bodhi.fedoraproject.org/updates/FEDORA-2021-913a761181

Comment 5 Carl George 🤠 2021-05-07 04:32:43 UTC
I've rebuilt the following packages successfully to link against the new soname.  I'll submit a bodhi update for these to get the fixed packages out to users ASAP.

audacious-plugins-3.10.1-8.fc32
Carla-2.2.0-2.fc32
csound-6.15.0-2.fc32
denemo-2.4.0-2.fc32
drumstick-1.1.3-3.fc32
gstreamer1-plugins-bad-free-1.16.2-4.fc32
minuet-20.08.3-2.fc32
openttd-1.11.2-2.fc32
prboom-plus-2.5.1.4-19.fc32
qsynth-0.9.2-2.fc32
scummvm-2.2.0-3.fc32
tuxguitar-1.5.3-3.fc32

I attempted to rebuild the following packages, but they failed.  I don't know if this is due to the soname bump or not.

ardour5-5.12.0-19.fc32 - https://koji.fedoraproject.org/koji/taskinfo?taskID=67397828
fluidsynth-dssi-1.0.0-22.fc32 - https://koji.fedoraproject.org/koji/taskinfo?taskID=67398025
lmms-1.1.3-16.fc32 - https://koji.fedoraproject.org/koji/taskinfo?taskID=67398113
muse-3.0.2-10.fc32 - https://koji.fedoraproject.org/koji/taskinfo?taskID=67398110
swami-2.0.0-22.20110806svn386.fc32 - https://koji.fedoraproject.org/koji/taskinfo?taskID=67398310

Please investigate the failed builds and mention them in your FESCo ticket.

Comment 6 Fedora Update System 2021-05-07 04:33:51 UTC
FEDORA-2021-0cf0581961 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-0cf0581961

Comment 7 Fedora Update System 2021-05-08 02:10:15 UTC
FEDORA-2021-0cf0581961 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0cf0581961`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0cf0581961

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Per Sjoholm 2021-05-10 21:57:33 UTC
What about ardour5, fluidsynth-dssi, lmms, muse, swami not built in advisory=FEDORA-2021-0cf0581961 ?

Comment 9 Fedora Update System 2021-05-13 01:22:50 UTC
FEDORA-2021-0cf0581961 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Alexander 2021-05-16 07:52:26 UTC
Problem still persists.

package mpd-1:0.22.6-1.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
package ardour5-5.12.0-17.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
package ardour5-audiobackend-jack-5.12.0-17.fc32.x86_64 requires ardour5(x86-64) = 5.12.0-17.fc32, but none of the providers can be installed

Conflicts:

 fluidsynth-libs                            x86_64                        2.1.8-3.fc32                                updates                                       222 k
 vlc-core                                   x86_64                        1:3.0.12.1-6.fc32                           rpmfusion-free-updates                        9.9 M

Broken dependencies:

 calf                                       x86_64                        0.90.3-7.fc32                               updates                                        13 M
 fluidsynth                                 x86_64                        2.1.8-3.fc32                                updates                                        23 k
 ladspa-calf-plugins                        x86_64                        0.90.3-7.fc32                               updates                                       7.6 k
 vlc

The main question is: will this problem affect dist-upgrade somehow or not.

Comment 11 Christoph Karl 2021-05-16 08:39:16 UTC
According to Guido Aulisi:
if I remeber well ardour5 is not compatible with latest fluidsynth.
Ardour5 has been obsoleted by Ardour6 in f33+.

Comment 12 Fedora Update System 2021-05-18 13:55:04 UTC
FEDORA-2021-b07c44d2b2 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b07c44d2b2

Comment 13 Fedora Update System 2021-05-19 02:38:34 UTC
FEDORA-2021-b07c44d2b2 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b07c44d2b2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b07c44d2b2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-05-20 01:27:19 UTC
FEDORA-2021-b07c44d2b2 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Carl George 🤠 2021-05-23 02:51:17 UTC
> What about ardour5, fluidsynth-dssi, lmms, muse, swami not built in advisory=FEDORA-2021-0cf0581961 ?

I specifically said those failed to build.  The others rebuilt without issue so I pushed them out first.  I've been working with Christoph to get the rest squared away.

> package mpd-1:0.22.6-1.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed

That's from rpmfusion, you'll have to ask them to rebuild it.

> package ardour5-5.12.0-17.fc32.x86_64 requires libfluidsynth.so.1()(64bit), but none of the providers can be installed
> package ardour5-audiobackend-jack-5.12.0-17.fc32.x86_64 requires ardour5(x86-64) = 5.12.0-17.fc32, but none of the providers can be installed

These are in progress.

> The main question is: will this problem affect dist-upgrade somehow or not.

Until we get the rest of the mentioned rebuilds fixed, the regular update prior to a `dnf system-upgrade` will have issues if the affected packages are installed.  I don't think it will affect the actual system-upgrade, but to be sure you can uninstall the affected packages first and reinstall them later.

Comment 16 Fedora Update System 2021-05-23 06:49:39 UTC
FEDORA-2021-d4dd20fb1a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d4dd20fb1a

Comment 17 Fedora Update System 2021-05-24 01:19:02 UTC
FEDORA-2021-d4dd20fb1a has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d4dd20fb1a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d4dd20fb1a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-05-25 01:54:34 UTC
FEDORA-2021-d4dd20fb1a has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.