Bug 1953937 - PVC create page is breaking
Summary: PVC create page is breaking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.z
Assignee: gowtham
QA Contact: Jilju Joy
URL:
Whiteboard:
Depends On: 1926154
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-27 08:49 UTC by gowtham
Modified: 2021-05-19 15:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-19 15:16:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
PVC page breaking (97.43 KB, image/png)
2021-04-27 08:49 UTC, gowtham
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8784 0 None open Bug 1953937: Fixing PVC creation page issue in 4.7(Reverting wrong commit) 2021-04-27 09:24:03 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:17:04 UTC

Description gowtham 2021-04-27 08:49:34 UTC
Created attachment 1775876 [details]
PVC page breaking

Description of problem:
Fix from 1932277 is causing a new issue of breaking the PVC creation page. When we select the storage class, the PVC creation page breaks immediately.

Version-Release number of selected component (if applicable):
OCP 4.7.z

How reproducible:
Create a new torage class with provisioner except listed under storage class creation page.

Steps to Reproduce:
1. In CLI create a new storage class with a provisioner: rook-ceph.rbd.csi.ceph.com
2. Go to: PersistentVolumeClaims -> Create PersistentVolumeClaim
3. Select newly created storage class from CLI

Actual results:
PVC page is breaking

Expected results:
UI should not break for any case

Additional info:

Comment 6 Jilju Joy 2021-05-10 10:46:09 UTC
Verified in version:
OCS 4.7.0-383.ci 
OCP 4.7.0-0.ci-2021-05-09-093836

Created a storage class with provisioner name "rook-ceph.rbd.csi.ceph.com" and selected this storage class in "Create Persistent Volume Claim" page. The page did not break or show any error. I was able to fill other fields and click on Create button.

Also tried to create PVC using custom storage classes which use the existing Cephfs and RBD provisioners.

Comment 9 errata-xmlrpc 2021-05-19 15:16:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.