Bug 195407 - Exception when trying to upgrade few packages several times
Exception when trying to upgrade few packages several times
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-06-14 22:01 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-11 18:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Exception saved to file (1.77 KB, text/plain)
2006-06-14 22:01 EDT, Jim Cornette
no flags Details
The problem with pup repeated an exception (1.77 KB, text/plain)
2006-06-15 22:58 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-06-14 22:01:26 EDT
Description of problem:
When trying to select the remaining packages that I excluded earlier, pup dumped
an exception. The exception was saved to a file that will be attached.

Version-Release number of selected component (if applicable):


How reproducible:

Check and uncheck remaining updates according to report of dep conflicts. Try
other choices. Observe crash.

Steps to Reproduce:
1. try to update with all choices
2. read error report
3. toggle off selection according to error report
4. try updating again
5. deselect packages according to error report
6. try again
7. note and save exception to file
Actual results:

Crashed pup and yum needed some information for sqlite on next run so I could
get available update information.

Expected results:

Expected conflicts since I read the rawhide report prior to the large update.
These packages were tried since I was not sure of the conflict still being there
or if it was resolved.

Additional info:

The available packages were:

Updated Packages
ImageMagick.i386                             development
eclipse-bugzilla.i386                    1:0.2.2-6              development
eclipse-cdt.i386                         1:3.1.0-0jpp_0fc.3.1.0 development
eclipse-changelog.i386                   1:2.0.4_fc-3           development
eclipse-ecj.i386                         1:3.2.0-0jpp_0fc.3.2RC development
eclipse-jdt.i386                         1:3.2.0-0jpp_0fc.3.2RC development
eclipse-platform.i386                    1:3.2.0-0jpp_0fc.3.2RC development
eclipse-rcp.i386                         1:3.2.0-0jpp_0fc.3.2RC development
libswt3-gtk2.i386                        1:3.2.0-0jpp_0fc.3.2RC development
nautilus-cd-burner.i386                  2.15.3-1               development
Comment 1 Jim Cornette 2006-06-14 22:01:26 EDT
Created attachment 130947 [details]
Exception saved to file
Comment 2 Jim Cornette 2006-06-14 22:11:24 EDT
After the slight delay when trying to run yum, the available packages were
listed as none. I take it that the cache fouled and got older mirror information
where the packages were not available.
Can pup stay at the mirror that I found with the available updates? Did pup pull
in information from mirrors with outdated information on later runs?
It makes more sense for pup to stay on the same repositories unless it was
closed. It is less likely to die on retries for dep resolution and selection
Comment 3 Jim Cornette 2006-06-15 22:58:26 EDT
Created attachment 131021 [details]
The problem with pup repeated an exception

I only tried to deselect packages once before this exception occurred.

1. Start pup
2. find deps needed 
3. deselect packages
4. try again
5. Get exception
Comment 4 Jeremy Katz 2006-06-19 16:29:51 EDT
I'm not sure there's really a way for me to currently stick with a specific
entry when dealing with mirror lists.  And doing so has downsides in that the
mirror you first get may not be fully synced and yet have the metadata.

.. not quite sure what the good answer here is other than the general "improve
our currently crappy mirror infrastructure" :-/
Comment 5 Jim Cornette 2006-06-19 22:06:36 EDT
I have not tried pup since the incident reported above. The out of sync mirrors
is a problem even when using yum in a terminal. I frequently need to run yum
clean all in order to update because of the availability and out of sync
metadata stored.

My main suggestion was to have pup stick with the same mirror when you need to
deselect packages because of dep issues. Switching mirrors with each package
selection adjustment will not work reliably with different mirrors being used
that are not listed on the package selection GUI.

If there is no practical way to cache the mirror information to ensure that the
mirror contains the package revisions intended, the random mirror selection will
remain a problem until the mirror infrastructure is improved.

Comment 6 Jeremy Katz 2006-09-11 18:15:52 EDT
There have been some improvements to the mirror infrastructure that should make
this a non-issue
Comment 7 Jim Cornette 2006-09-11 19:00:04 EDT
Thanks! Currenlty I am using one dependable mirror instead of the random mirrors
because of the previous problem. The better infrastructure should help.

Note You need to log in before you can comment on or make changes to this bug.