Bug 195410 - qt: 64bit platforms make useless -debuginfo rpms
qt: 64bit platforms make useless -debuginfo rpms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 22:50 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 11:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-06-14 22:50:34 EDT
mkspecs/linux-g++-64/qmake.conf contains
QMAKE_STRIP = strip
which makes any qt-based (which uses qmake) builds strip it's
binaries/libraries, which results in rpm's -debuginfo packages being useless (on
64bit platforms).  I'd venture to guess core's x86_64 qt-debuginfo rpm is empty
for the same reason... yep verified  (:

For some reason 
mkspecs/linux-g++/qmake.conf contains
QMAKE_STRIP = 
so platforms using that one are fine.

FIX: patch mkspecs/linux-g++-64/qmake.conf to have
QMAKE_STRIP =
Comment 1 Rex Dieter 2006-06-14 22:53:12 EDT
I had the same problem packaging qt4, though in my case, it was easier to spot
since it affected both 32 and 64 bit platforms.
Comment 2 Ngo Than 2006-06-21 11:06:26 EDT
it's now fixed in CVS. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.