Bug 1954154 - PhotoQt can't start when qt5-qtquickcontrols2 package is not installed
Summary: PhotoQt can't start when qt5-qtquickcontrols2 package is not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: photoqt
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Eischmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-27 17:13 UTC by Yaroslav Sidlovsky
Modified: 2021-05-06 00:53 UTC (History)
1 user (show)

Fixed In Version: photoqt-2.1.1-2.fc34 photoqt-2.1.1-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-29 00:31:31 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Yaroslav Sidlovsky 2021-04-27 17:13:24 UTC
Description of problem:
PhotoQt can't start when qt5-qtquickcontrols2 package is not installed.

Version-Release number of selected component (if applicable):
photoqt-2.1.1-1.fc34.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install photoqt;
2. Run `photoqt` in the console.

Actual results:
photoqt can't start because of missing dependency:
```
QQmlApplicationEngine failed to load component
qrc:/mainwindow.qml:184:5: Type PQQuickInfo unavailable
qrc:/mainwindow/PQQuickInfo.qml:173:9: Type PQMenu unavailable
qrc:/elements/PQMenu.qml:24:1: module "QtQuick.Controls" version 2.2 is not installed
```

Expected results:
PhotoQt starts without errors.

Additional info:
None.

Comment 1 Yaroslav Sidlovsky 2021-04-27 17:18:16 UTC
Pull request: https://src.fedoraproject.org/rpms/photoqt/pull-request/2.

Comment 2 Yaroslav Sidlovsky 2021-04-27 17:24:06 UTC
I doubt if photoqt still have to depend on qt5-qtquickcontrols.
According to QML sources it uses version 2 now (see files in https://github.com/luspi/photoqt/tree/master/qml).

Comment 3 Fedora Update System 2021-04-27 19:03:06 UTC
FEDORA-2021-01d9b72f98 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-01d9b72f98

Comment 4 Fedora Update System 2021-04-27 19:03:07 UTC
FEDORA-2021-2d8fb5cb1a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2d8fb5cb1a

Comment 5 Fedora Update System 2021-04-28 00:36:21 UTC
FEDORA-2021-01d9b72f98 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-01d9b72f98`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-01d9b72f98

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-04-28 01:35:05 UTC
FEDORA-2021-2d8fb5cb1a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-2d8fb5cb1a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2d8fb5cb1a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Yaroslav Sidlovsky 2021-04-28 10:57:50 UTC
Works for me. Thanks for quick fix!

Comment 8 Fedora Update System 2021-04-29 00:31:31 UTC
FEDORA-2021-2d8fb5cb1a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-05-06 00:53:18 UTC
FEDORA-2021-01d9b72f98 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.