This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 195435 - update to 0.3.1.6beta1
update to 0.3.1.6beta1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: exo (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 03:34 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 22:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the spec file for 0.3.1.6beta1 (2.67 KB, patch)
2006-06-15 03:34 EDT, Patrice Dumas
no flags Details | Diff
conditionally define pygtk symbols (2.16 KB, patch)
2006-06-21 07:46 EDT, Patrice Dumas
no flags Details | Diff

  None (edit)
Description Patrice Dumas 2006-06-15 03:34:52 EDT
Description of problem:

0.3.1.6beta1 is required for Thunar I am currently packaging. It also
seems to add a lot of functionalities. 

I have done the attached spec file patch for the new exo version.
In my opinion it should be updated in devel, and maybe in FC5, at least if
we want Thunar to land in FC5 soon.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-06-15 03:34:52 EDT
Created attachment 130957 [details]
patch for the spec file for 0.3.1.6beta1
Comment 2 Kevin Fenzi 2006-06-15 14:31:27 EDT
I am a bit learly of updaing exo to a beta1 version, shipping things
that the developers aren't even called a RC yet is kinda scary.
Take a look at all the xubuntu problem reports that pop up on the Xfce
lists (xubuntu shipped Xfce 4.4beta1 + their patches).

On the plus side, exo only has one thing that depends on it
(Terminal), and also the current exo doesn't build right under devel,
so updating exo and Terminal might be ok.

I will do some testing and see how stable new exo/Terminal seem.
Comment 3 Patrice Dumas 2006-06-17 04:19:07 EDT
devel is aimed at testing new version to see what breaks, so in my
opinion it would make sense to have Xfce 4.4beta1 to have bugs reported,
unless you and the other xfce maintainers don't have enough time 
to handle the bug reports, communicate with upstream and fix with 
patches... But the fact that there are a lot of problem reports should 
be, in my opinion a strong reason to have it in devel (we're only at test1
this leave time to fix things before FC6). 
Comment 4 Kevin Fenzi 2006-06-19 12:15:10 EDT
In reply to comment #3: 

Yeah, I would agree with you if there was a expectation/plan/schedule that 4.4
final would be released before FC6 was released. However Xfce is not on a time
based release schedule, releases are done when the developers are ready. 
I would hate to put a 4.4 beta into devel and then have FC6 released before the
final is out. That would mean we would be shipping a beta release in a release
branch of Fedora, which I wouldn't like at all. 

The next Xfce releases are likely to be 4.4beta2, then 4.4rc1, and 4.4rc2 before 
final (if they follow the same release pattern they have in the past). 

If one of the rc's comes out before FC6, I would be pretty happy to update to
it, but I don't think the betas are a good idea.

Back to the subject of this bug, I have been testing exo and Terminal updates
here for the last few days and they are looking pretty stable. I want to pound
on it a bit more, but can probibly push out an update in the next few days if no
blocker comes along. 
Comment 5 Patrice Dumas 2006-06-19 12:56:35 EDT
(In reply to comment #4)
> In reply to comment #3: 
> 

> final is out. That would mean we would be shipping a beta release in a release
> branch of Fedora, which I wouldn't like at all. 

You're perfectly right. If it isn't ready for the next release it 
would be very unpleasant. A possibility could be to have a xfce 4.4
parallel installable along 4.2, but it is likely to be a lot of work
for little gain.
Comment 6 Patrice Dumas 2006-06-21 07:44:37 EDT
A patch is required to build on devel. I believe it also 
should be taken upstream.

Patch1: conditionnaly_define_pygtk_symbols.diff


%patch1 -p1
Comment 7 Patrice Dumas 2006-06-21 07:46:52 EDT
Created attachment 131265 [details]
conditionally define pygtk symbols
Comment 8 Kevin Fenzi 2006-06-21 14:05:36 EDT
Good catch... already fixed upstream in svn: 
http://bugzilla.xfce.org/show_bug.cgi?id=1815

I am leaning toward waiting for beta2 (hopefully out this next weekend) before 
pushing this update... does that sound reasonable?
Comment 9 Patrice Dumas 2006-06-21 14:39:47 EDT
it sound definitely reasonable.
Comment 10 Kevin Fenzi 2006-07-25 16:22:11 EDT
Sorry for the delay here. 

I have made available beta2 versions of exo and Terminal for both fc5 and 
devel. You can find them at: 

http://www.scrye.com/exo-Terminal/

Can you test against those and let me know if you see any problems?
If nothing shows up I will push those out to devel at least (and possibly fc5 
as well). 
Comment 11 Patrice Dumas 2006-07-26 12:19:23 EDT
I think I use those packages from
http://www.scrye.com/xfce-4.4b1/development/RPMS/
since a few day. I haven't noticed anything wrong for exo
or Terminal.

Maybe exo and Terminal would feel even better in their 
repo with their Thunar friend currently at:
http://www.environnement.ens.fr/perso/dumas/fc-srpms/Thunar-0.3.2-0.1.beta2.src.rpm
:-)
Comment 12 Kevin Fenzi 2006-08-03 22:57:02 EDT
Sorry for the delay. 

Unless something comes up I am probibly going to push exo from beta2 out to 
devel tomorrow. It's shown no problems here in the last few weeks. Upstream has 
3 bugs filed against it, but they are all Enhancements planned for the next 
relelase. 

If exo (and Terminal which I will also likely push out tomorrow) show no issues 
for a while I will look at updating them in FC5 as well. 

As soon as exo is updated you should be able to test and submit your Thunar 
package. 

So if anyone sees any issues, let me know now. ;) 
Comment 13 Kevin Fenzi 2006-08-08 22:08:27 EDT
ok, I finally have gotten to pushing exo (and Terminal) out to devel. 
One minor issue is that I had the release wrong in my test repo, so the new 
versions in devel will not show as rpm newer than the old ones from my test 
repo. You will have to 'rpm -e exo' and install from devel to get the correct 
version. 

If all looks good for a bit I will consider pushing them out to fc5 as well. 

In any case, I will close this bug for now and if you spot any issues with the 
new exo, please file a new bug. 
Comment 14 Patrice Dumas 2006-08-10 03:56:09 EDT
A number is higher than a letter for rpm versionning, if I'm
not wrong, and the packages get updated. However the upgrade path
with the xfce44beta repo is broken, since the exo in devel appears
newer than the one in xfce44beta, with a dependency on libxfce4util.so.1
which is in devel but not in xfce44beta which has libxfce4util.so.4.
To fix that you could for example name the package 
0.3.1.8-0.2.beta2.fc6 or 0.3.1.8-0.1.xfcebeta.fc6 in xfc44beta.
Comment 15 Kevin Fenzi 2006-08-14 10:23:09 EDT
Sorry about that. The xfce44beta repo should be updated now. 

Note You need to log in before you can comment on or make changes to this bug.