Bug 1954404 - [RFE][cinderlib] Add option to copy Managed block storage disks via the UI
Summary: [RFE][cinderlib] Add option to copy Managed block storage disks via the UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.4.7
: 4.4.7.1
Assignee: shani
QA Contact: Shir Fishbain
URL:
Whiteboard:
Depends On: 1906074
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 06:15 UTC by Eyal Shenitzky
Modified: 2021-07-06 07:28 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.4.7.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:27 UTC
oVirt Team: Storage
sbonazzo: ovirt-4.4?
pm-rhel: planning_ack?
pm-rhel: devel_ack+
pm-rhel: testing_ack+


Attachments (Terms of Use)
events_log (96.88 KB, image/png)
2021-06-09 16:04 UTC, Shir Fishbain
no flags Details
engine_log & cinderlib_log (442.56 KB, application/zip)
2021-06-09 16:05 UTC, Shir Fishbain
no flags Details
there is option to choose the iscsi SD (49.98 KB, image/png)
2021-06-09 16:06 UTC, Shir Fishbain
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114615 0 master MERGED webadmin: support copying Managed block storage disks via the UI 2021-06-01 17:22:17 UTC

Description Eyal Shenitzky 2021-04-28 06:15:27 UTC
Description of problem:

Once bug 1906074 will be solved there will be an option to copy
Managed block storage disks to regular storage domain and vice versa.

It is currently supported via the REST-API only, we need to allow it using the UI as well.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create an MBS disk
2. Copy the MBS disk to a regular SD
3. Copy a regular disk to an MBS domain.

Actual results:
Can be done via REST only

Expected results:
Should be available via UI


Additional info:

Comment 2 Shir Fishbain 2021-06-09 16:04:28 UTC
Created attachment 1789613 [details]
events_log

Comment 3 Shir Fishbain 2021-06-09 16:05:06 UTC
Created attachment 1789614 [details]
engine_log & cinderlib_log

Comment 4 Shir Fishbain 2021-06-09 16:06:36 UTC
Created attachment 1789615 [details]
there is option to choose the iscsi SD

Comment 5 Benny Zlotnik 2021-06-09 16:19:01 UTC
  2021-06-09 18:03:42,874+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetHostJobsVDSCommand] (EE-ManagedScheduledExecutorService-engineScheduledThreadPool-Thread-18) [fb9dfbd7-85ae-4e24-a257-216d04b82e5f] FINISH, GetHostJobsVDSCommand, return: {f7ad3546-7382-4622-8336-97de1e58cdfb=HostJobInfo:{id='f7ad3546-7382-4622-8336-97de1e58cdfb', type='storage', description='copy_data', status='failed', progress='95', error='VDSError:{code='GeneralException', message='General Exception: ("Command ['/usr/bin/qemu-img', 'convert', '-p', '-t', 'none', '-T', 'none', '-f', 'raw', '-O', 'raw', '-n', '-W', '/dev/rbd/rhev_cinderlib/volume-cdc80415-62b8-48b6-ad4a-876be50157ac', '/rhev/data-center/mnt/blockSD/a2ded8b7-910c-4723-9d63-c01f153d75c4/images/1b37ab68-1899-49bf-a071-8ea19180e481/d1ca247f-3382-4498-b089-60ebaa4e1c34'] failed with rc=1 out=b'' err=bytearray(b'qemu-img: error while writing at byte 2055208960: No space left on device\\nqemu-img: error while writing at byte 2048917504: No space left on device\\nqemu-img: error while writing at byte 2061500416: No space left on device\\nqemu-img: error while writing at byte 2053111808: No space left on device\\nqemu-img: error while writing at byte 2046820352: No space left on device\\nqemu-img: error while writing at byte 2059403264: No space left on device\\nqemu-img: error while writing at byte 2057306112: No space left on device\\nqemu-img: error while writing at byte 2051014656: No space left on device\\n')",)'}'}}, log id: 2c36015



this is the failure, it looks like the target disk is created too small:
2021-06-09 18:44:20,350+03 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CreateVolumeVDSCommand] (EE-ManagedThreadFactory-engine-Thread-2927) [1f47ccd6-32e2-4fbc-bd7f-5508cb8d019f] START, CreateVolumeVDSCommand( CreateVolumeVDSCommandParameters:{storagePoolId='802f84b8-d376-4900-a7f9-9ad3daa62bef', ignoreFailoverLimit='false', storageDomainId='a2ded8b7-910c-4723-9d63-c01f153d75c4', imageGroupId='2c4be585-5404-4e9c-9c1f-9934d327ecff', imageSizeInBytes='10737418240', volumeFormat='RAW', newImageId='6329d56a-482f-464b-b8c0-f6bdd98d1c0f', imageType='Preallocated', newImageDescription='{"DiskAlias":"lala-1","DiskDescription":""}', imageInitialSizeInBytes='0', imageId='00000000-0000-0000-0000-000000000000', sourceImageGroupId='00000000-0000-0000-0000-000000000000', shouldAddBitmaps='false'}), log id: 7e0aac34



While the MBS disk cdc80415-62b8-48b6-ad4a-876be50157ac is 2GiB


I guess it doesn't happen only in UI?

Comment 6 Benny Zlotnik 2021-06-10 12:04:52 UTC
(In reply to Benny Zlotnik from comment #5)
>   2021-06-09 18:03:42,874+03 INFO 
> [org.ovirt.engine.core.vdsbroker.vdsbroker.GetHostJobsVDSCommand]
> (EE-ManagedScheduledExecutorService-engineScheduledThreadPool-Thread-18)
> [fb9dfbd7-85ae-4e24-a257-216d04b82e5f] FINISH, GetHostJobsVDSCommand,
> return:
> {f7ad3546-7382-4622-8336-97de1e58cdfb=HostJobInfo:{id='f7ad3546-7382-4622-
> 8336-97de1e58cdfb', type='storage', description='copy_data',
> status='failed', progress='95', error='VDSError:{code='GeneralException',
> message='General Exception: ("Command ['/usr/bin/qemu-img', 'convert', '-p',
> '-t', 'none', '-T', 'none', '-f', 'raw', '-O', 'raw', '-n', '-W',
> '/dev/rbd/rhev_cinderlib/volume-cdc80415-62b8-48b6-ad4a-876be50157ac',
> '/rhev/data-center/mnt/blockSD/a2ded8b7-910c-4723-9d63-c01f153d75c4/images/
> 1b37ab68-1899-49bf-a071-8ea19180e481/d1ca247f-3382-4498-b089-60ebaa4e1c34']
> failed with rc=1 out=b'' err=bytearray(b'qemu-img: error while writing at
> byte 2055208960: No space left on device\\nqemu-img: error while writing at
> byte 2048917504: No space left on device\\nqemu-img: error while writing at
> byte 2061500416: No space left on device\\nqemu-img: error while writing at
> byte 2053111808: No space left on device\\nqemu-img: error while writing at
> byte 2046820352: No space left on device\\nqemu-img: error while writing at
> byte 2059403264: No space left on device\\nqemu-img: error while writing at
> byte 2057306112: No space left on device\\nqemu-img: error while writing at
> byte 2051014656: No space left on device\\n')",)'}'}}, log id: 2c36015
> 
> 
> 
> this is the failure, it looks like the target disk is created too small:
> 2021-06-09 18:44:20,350+03 INFO 
> [org.ovirt.engine.core.vdsbroker.irsbroker.CreateVolumeVDSCommand]
> (EE-ManagedThreadFactory-engine-Thread-2927)
> [1f47ccd6-32e2-4fbc-bd7f-5508cb8d019f] START, CreateVolumeVDSCommand(
> CreateVolumeVDSCommandParameters:{storagePoolId='802f84b8-d376-4900-a7f9-
> 9ad3daa62bef', ignoreFailoverLimit='false',
> storageDomainId='a2ded8b7-910c-4723-9d63-c01f153d75c4',
> imageGroupId='2c4be585-5404-4e9c-9c1f-9934d327ecff',
> imageSizeInBytes='10737418240', volumeFormat='RAW',
> newImageId='6329d56a-482f-464b-b8c0-f6bdd98d1c0f', imageType='Preallocated',
> newImageDescription='{"DiskAlias":"lala-1","DiskDescription":""}',
> imageInitialSizeInBytes='0', imageId='00000000-0000-0000-0000-000000000000',
> sourceImageGroupId='00000000-0000-0000-0000-000000000000',
> shouldAddBitmaps='false'}), log id: 7e0aac34
> 
> 
> 
> While the MBS disk cdc80415-62b8-48b6-ad4a-876be50157ac is 2GiB
> 
> 
> I guess it doesn't happen only in UI?

Disregard, this is not the correct disk, the reason for failure is still unclear

Comment 8 Shir Fishbain 2021-06-16 10:55:31 UTC
Verified

After talked with Benny, we understood that the problem with "No space left on device" is not related to MBS disk moving to iscsi SD. The problem appears also with different disk flavors when making the copy operation. So for this moment, I can verify this bug. 

ovirt-engine-4.4.7.1-0.9.el8ev.noarch
vdsm-4.40.70.2-1.el8ev.x86_64

Comment 9 Sandro Bonazzola 2021-07-06 07:28:27 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.