Bug 1954465 - Bluetooth firmware load problem
Summary: Bluetooth firmware load problem
Keywords:
Status: CLOSED DUPLICATE of bug 1957598
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 34
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 08:16 UTC by René
Modified: 2021-06-16 20:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 11:01:49 UTC
Type: Bug


Attachments (Terms of Use)

Description René 2021-04-28 08:16:43 UTC
Description of problem:
Just after upgrading to Fedora 34 bluetooth stopped working. It was working perfectly on Fedora 33.

Some detailed information:
Hardware: Dell XPS 9310

Relevant dmesg output:
[    7.244249] Bluetooth: hci0: QCA Downloading qca/htnv20.bin
[    7.245460] BUG: unable to handle page fault for address: ffffb95b81510047
[    7.245463] #PF: supervisor write access in kernel mode
[    7.245465] #PF: error_code(0x0003) - permissions violation
[    7.245466] PGD 100000067 P4D 100000067 PUD 1001ce067 PMD 11c1c7067 PTE 8000000106b15161
[    7.245469] Oops: 0003 [#1] SMP NOPTI
[    7.245471] CPU: 0 PID: 205 Comm: kworker/u17:0 Tainted: G     U            5.12.0 #3
[    7.245473] Hardware name: Dell Inc. XPS 13 9310/...., BIOS 2.2.0 04/06/2021
[    7.245475] Workqueue: hci0 hci_power_on [bluetooth]
[    7.245493] RIP: 0010:qca_download_firmware+0x231/0x490 [btqca]
[    7.245496] Code: 1b 75 04 80 48 0c 01 0f b7 c1 8d 54 02 0c 41 39 d7 0f 8e 99 fe ff ff 48 63 c2 4c 01 e8 0f b7 30 0f b7 48 02 66 83 fe 11 75 d3 <80> 48 0c 80 41 83 fc 03 7e 6f 44 88 70 0d eb cd 41 0f b6 45 0e 48
[    7.245497] RSP: 0018:ffffb95b808e3c60 EFLAGS: 00010246
[    7.245499] RAX: ffffb95b8151003b RBX: 0000000000000005 RCX: 0000000000000006
[    7.245500] RDX: 0000000000000037 RSI: 0000000000000011 RDI: ffffa0d145ed3340
[    7.245501] RBP: ffffa0d1410b2000 R08: ffffa0d156626480 R09: ffffa0d145ed3340
[    7.245501] R10: 000000000010c5ad R11: 0000000000000000 R12: 0000000000000005
[    7.245502] R13: ffffb95b81510004 R14: 000000000000000e R15: 00000000000016a9
[    7.245503] FS:  0000000000000000(0000) GS:ffffa0d8af600000(0000) knlGS:0000000000000000
[    7.245505] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    7.245506] CR2: ffffb95b81510047 CR3: 00000007a8a10005 CR4: 0000000000770ef0
[    7.245507] PKRU: 55555554
[    7.245507] Call Trace:
[    7.245511]  qca_uart_setup+0x2cb/0x13e0 [btqca]
[    7.245513]  ? qca_read_soc_version+0x136/0x220 [btqca]
[    7.245516]  qca_setup+0x52e/0xb40 [hci_uart]
[    7.245523]  hci_dev_do_open+0x1d0/0x740 [bluetooth]
[    7.245533]  ? try_to_wake_up+0x1c1/0x4f0
[    7.245537]  hci_power_on+0x3f/0x200 [bluetooth]
[    7.245547]  process_one_work+0x1ec/0x380
[    7.245549]  worker_thread+0x53/0x3e0
[    7.245551]  ? process_one_work+0x380/0x380
[    7.245552]  kthread+0x11b/0x140
[    7.245559]  ? kthread_associate_blkcg+0xa0/0xa0
[    7.245561]  ret_from_fork+0x1f/0x30
[    7.245565] Modules linked in: snd_soc_skl_hda_dsp qrtr_mhi snd_soc_hdac_hdmi snd_hda_codec_hdmi snd_hda_codec_realtek x86_pkg_temp_thermal snd_hda_codec_generic intel_powerclamp qrtr snd_soc_dmic ns iTCO_wdt coretemp snd_sof_pci_intel_tgl intel_pmc_bxt ath11k_pci snd_sof_intel_hda_common iTCO_vendor_support mei_hdcp kvm_intel mhi intel_pmt_telemetry intel_rapl_msr intel_pmt_class snd_soc_hdac_hda ath11k kvm soundwire_intel qmi_helpers irqbypass soundwire_generic_allocation dell_laptop intel_cstate soundwire_cadence dell_smm_hwmon mac80211 snd_sof_intel_hda snd_sof_pci snd_sof snd_sof_xtensa_dsp snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi snd_soc_core snd_compress snd_pcm_dmaengine ac97_bus ledtrig_audio snd_hda_intel snd_intel_dspcfg snd_intel_sdw_acpi snd_hda_codec snd_hda_core snd_hwdep snd_seq snd_seq_device uvcvideo snd_pcm intel_uncore dell_wmi dell_smbios videobuf2_vmalloc pcspkr videobuf2_memops snd_timer dcdbas videobuf2_v4l2 i2c_i801 cfg80211 dell_wmi_sysman(+)
[    7.245600]  hci_uart dell_wmi_descriptor wmi_bmof videobuf2_common snd hid_sensor_als i2c_smbus videodev libarc4 soundcore btqca hid_sensor_trigger btrtl hid_sensor_iio_common industrialio_triggered_buffer mei_me mc btbcm processor_thermal_device kfifo_buf processor_thermal_rfim joydev mei processor_thermal_mbox idma64 ucsi_acpi industrialio btintel processor_thermal_rapl typec_ucsi intel_rapl_common thunderbolt bluetooth intel_pmt intel_soc_dts_iosf typec roles ecdh_generic rfkill ecc int3403_thermal int340x_thermal_zone intel_hid sparse_keymap int3400_thermal acpi_pad acpi_thermal_rel acpi_tad zram ip_tables hid_sensor_hub intel_ishtp_loader intel_ishtp_hid i915 wacom hid_multitouch rtsx_pci_sdmmc i2c_algo_bit drm_kms_helper mmc_core nvme nvme_core cec crct10dif_pclmul crc32_pclmul crc32c_intel intel_ish_ipc drm serio_raw rtsx_pci ghash_clmulni_intel intel_ishtp vmd wmi i2c_hid_acpi i2c_hid video pinctrl_tigerlake fuse
[    7.245643] CR2: ffffb95b81510047
[    7.245645] ---[ end trace 26776178dad8d512 ]---
[    7.245645] RIP: 0010:qca_download_firmware+0x231/0x490 [btqca]
[    7.245647] Code: 1b 75 04 80 48 0c 01 0f b7 c1 8d 54 02 0c 41 39 d7 0f 8e 99 fe ff ff 48 63 c2 4c 01 e8 0f b7 30 0f b7 48 02 66 83 fe 11 75 d3 <80> 48 0c 80 41 83 fc 03 7e 6f 44 88 70 0d eb cd 41 0f b6 45 0e 48
[    7.245649] RSP: 0018:ffffb95b808e3c60 EFLAGS: 00010246
[    7.245650] RAX: ffffb95b8151003b RBX: 0000000000000005 RCX: 0000000000000006
[    7.245650] RDX: 0000000000000037 RSI: 0000000000000011 RDI: ffffa0d145ed3340
[    7.245651] RBP: ffffa0d1410b2000 R08: ffffa0d156626480 R09: ffffa0d145ed3340
[    7.245652] R10: 000000000010c5ad R11: 0000000000000000 R12: 0000000000000005
[    7.245653] R13: ffffb95b81510004 R14: 000000000000000e R15: 00000000000016a9
[    7.245654] FS:  0000000000000000(0000) GS:ffffa0d8af600000(0000) knlGS:0000000000000000
[    7.245655] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    7.245655] CR2: ffffb95b81510047 CR3: 00000007a8a10005 CR4: 0000000000770ef0
[    7.245656] PKRU: 55555554

I tried stock Fedora 34 kernel and a self-compiled 5.12, on Fedora 33 both 5.11 and 5.12 kernels with similar configuration worked perfectly.

bluez is at the last Fedora 34 version

How reproducible:
Every boot is the same, then, neither KDE/Plasma nor bluetoothctl detect the bluetooth controller

Steps to Reproduce:
1. upgrade to Fedora 34
2. boot into the system and try to associate to any paired bluetooth device
3. bluetooth is not detected

Actual results:
No bluetooth working

Expected results:
Working bluetooth

Don't hesitate to contact me for further information.

Comment 1 René 2021-05-03 22:28:26 UTC
Hi again, I did some further testing. Here you have a bit more of information:
- Booting a live Fedora USB shows the same issue, bluetooth not working with the same message as before.
- Booting a live Ubuntu 21.04 USB has bluetooth properly working.

Ubuntu ships with bluez 5.56, I tried downgrading it on my Fedora but the problem persists.

Hope this helps to point to the possible issue.

Thanks in advance

Comment 2 roberto.barreda 2021-05-06 07:59:44 UTC
Same hardware and same issue here.

I've tried also to install a 5.11.x-f33 kernel but the problem persists.

I've tried to install blueman but it crashes trying to setup the interface.

$ journalctl -b | grep -iP 'blue|firm'
May 04 12:41:34 kernel: i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/tgl_dmc_ver2_08.bin (v2.8)
May 04 10:41:45 kernel: Bluetooth: Core ver 2.22
May 04 10:41:45 kernel: Bluetooth: HCI device and connection manager initialized
May 04 10:41:45 kernel: Bluetooth: HCI socket layer initialized
May 04 10:41:45 kernel: Bluetooth: L2CAP socket layer initialized
May 04 10:41:45 kernel: Bluetooth: SCO socket layer initialized
May 04 10:41:45 kernel: Bluetooth: HCI UART driver ver 2.3
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol H4 registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol BCSP registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol LL registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol ATH3K registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol Three-wire (H5) registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol Intel registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol Broadcom registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol QCA registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol AG6XX registered
May 04 10:41:45 kernel: Bluetooth: HCI UART protocol Marvell registered
May 04 10:41:45 kernel: Bluetooth: hci0: setting up ROME/QCA6390
May 04 10:41:45 kernel: Bluetooth: hci0: QCA Product ID   :0x00000010
May 04 10:41:45 kernel: Bluetooth: hci0: QCA SOC Version  :0x400a0200
May 04 10:41:45 kernel: Bluetooth: hci0: QCA ROM Version  :0x00000200
May 04 10:41:45 kernel: Bluetooth: hci0: QCA Patch Version:0x00000d2b
May 04 10:41:45 kernel: Bluetooth: hci0: QCA controller version 0x02000200
May 04 10:41:45 kernel: Bluetooth: hci0: QCA Downloading qca/htbtfw20.tlv
May 04 10:41:46 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 1:6:1-53680
May 04 10:41:46 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:17:0 Kernel ABI 3:18:0
May 04 10:41:46 kernel: Bluetooth: hci0: QCA Downloading qca/htnv20.bin
May 04 10:41:46 kernel: Workqueue: hci0 hci_power_on [bluetooth]
May 04 10:41:46 kernel: RIP: 0010:qca_download_firmware+0x231/0x490 [btqca]
May 04 10:41:46 kernel:  hci_dev_do_open+0x1d0/0x740 [bluetooth]
May 04 10:41:46 kernel:  hci_power_on+0x3f/0x200 [bluetooth]
May 04 10:41:46 kernel:  dell_wmi_sysman(+) dell_wmi_descriptor snd wmi_bmof mhi i2c_i801 i2c_smbus soundcore libarc4 joydev hid_sensor_als hci_uart hid_sensor_trigger hid_sensor_iio_common mei_me industrialio_triggered_buffer kfifo_buf btqca mei idma64 industrialio btrtl processor_thermal_device btbcm processor_thermal_rfim thunderbolt btintel processor_thermal_mbox ucsi_acpi processor_thermal_rapl intel_pmt intel_rapl_common intel_soc_dts_iosf typec_ucsi bluetooth typec ecdh_generic rfkill ecc int3403_thermal int340x_thermal_zone intel_hid sparse_keymap acpi_pad acpi_tad int3400_thermal acpi_thermal_rel zram ip_tables dm_crypt trusted hid_logitech_hidpp hid_logitech_dj hid_sensor_hub intel_ishtp_loader intel_ishtp_hid r8152 mii i915 hid_multitouch rtsx_pci_sdmmc nvme mmc_core i2c_algo_bit nvme_core drm_kms_helper crct10dif_pclmul crc32_pclmul cec crc32c_intel ghash_clmulni_intel drm serio_raw rtsx_pci intel_ish_ipc intel_ishtp wmi vmd i2c_hid_acpi i2c_hid video pinctrl_tigerlake fuse
May 04 10:41:46 kernel: RIP: 0010:qca_download_firmware+0x231/0x490 [btqca]
May 04 10:41:48 systemd[1]: Starting Bluetooth service...
May 04 10:41:48 bluetoothd[1559]: Bluetooth daemon 5.58
May 04 10:41:48 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 10:41:48 bluetoothd[1559]: Starting SDP server
May 04 10:41:48 systemd[1]: Started Bluetooth service.
May 04 10:41:48 systemd[1]: Reached target Bluetooth.
May 04 10:41:48 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
May 04 10:41:48 kernel: Bluetooth: BNEP filters: protocol multicast
May 04 10:41:48 kernel: Bluetooth: BNEP socket layer initialized
May 04 10:41:48 bluetoothd[1559]: Bluetooth management interface 1.19 initialized
May 04 10:41:49 NetworkManager[1657]: <info>  [1620117709.3025] manager[0x5561c23c2030]: monitoring kernel firmware directory '/lib/firmware'.
May 04 10:41:49 NetworkManager[1657]: <info>  [1620117709.3165] Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/1.30.4-1.fc34/libnm-device-plugin-bluetooth.so)
May 04 10:42:07 systemd[2880]: app-glib-blueman-3403.scope: Deactivated successfully.
May 04 10:42:07 blueman.desktop[3403]: blueman-applet 10.42.07 ERROR    PluginManager:91 load_plugin: Unable to load plugin module GameControllerWakelock
May 04 10:42:07 blueman.desktop[3403]: Traceback (most recent call last):
May 04 10:42:07 blueman.desktop[3403]:   File "/usr/lib/python3.9/site-packages/blueman/main/PluginManager.py", line 89, in load_plugin
May 04 10:42:07 blueman.desktop[3403]:     importlib.import_module(self.module_path.__name__ + ".%s" % plugin)
May 04 10:42:07 blueman.desktop[3403]:   File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
May 04 10:42:07 blueman.desktop[3403]:     return _bootstrap._gcd_import(name[level:], package, level)
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap_external>", line 790, in exec_module
May 04 10:42:07 blueman.desktop[3403]:   File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
May 04 10:42:07 blueman.desktop[3403]:   File "/usr/lib/python3.9/site-packages/blueman/plugins/applet/GameControllerWakelock.py", line 14, in <module>
May 04 10:42:07 blueman.desktop[3403]:     raise ImportError('This is not an X11 screen')
May 04 10:42:07 blueman.desktop[3403]: ImportError: This is not an X11 screen
May 04 10:42:07 systemd[2880]: Started Application launched by blueman-applet.
May 04 10:42:07 blueman.desktop[3403]: blueman-applet 10.42.07 WARNING  PluginManager:148 __load_plugin: Not loading DhcpClient because its conflict has higher priority
May 04 10:42:07 systemd[1]: Starting Bluetooth management mechanism...
May 04 10:42:07 systemd[2880]: Started Application launched by blueman-applet.
May 04 10:42:07 blueman-mechanism[3762]: Unable to init server: Could not connect: Connection refused
May 04 10:42:07 blueman-mechanism[3762]: Unable to init server: No se pudo conectar: Connection refused
May 04 10:42:07 blueman-mechani[3762]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 04 10:42:07 systemd[1]: Started Bluetooth management mechanism.
May 04 10:42:07 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 10:42:07 blueman.desktop[3403]: blueman-applet 10.42.07 WARNING  PluginManager:148 __load_plugin: Not loading PPPSupport because its conflict has higher priority
May 04 10:42:07 systemd[2880]: Starting Bluetooth OBEX service...
May 04 10:42:07 systemd[2880]: Started Bluetooth OBEX service.
May 04 10:42:07 blueman.desktop[3403]: blueman-applet 10.42.07 WARNING  DiscvManager:109 update_menuitems: warning: Adapter is None
May 04 10:42:08 blueman.desktop[3759]: blueman-tray version 2.1.4 starting
May 04 10:42:08 blueman.desktop[3759]: There is an instance already running
May 04 10:42:08 systemd[2880]: app-glib-blueman\x2dtray-3759.scope: Deactivated successfully.
May 04 10:42:38 systemd[1]: blueman-mechanism.service: Deactivated successfully.
May 04 10:42:38 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 10:44:35 systemd[2880]: app-glib-gnome\x2dbluetooth\x2dpanel-5349.scope: Deactivated successfully.
May 04 10:44:35 gnome-bluetooth-panel.desktop[5349]: ../src/intel/isl/isl.c:2015: FINISHME: ../src/intel/isl/isl.c:isl_surf_supports_ccs: CCS for 3D textures is disabled, but a workaround is available.
May 04 10:44:41 systemd[2880]: app-gnome-gnome\x2dbluetooth\x2dpanel-5349.scope: Deactivated successfully.
May 04 11:00:23 kernel:  processor_thermal_mbox ucsi_acpi processor_thermal_rapl intel_pmt intel_rapl_common intel_soc_dts_iosf typec_ucsi bluetooth typec ecdh_generic rfkill ecc int3403_thermal int340x_thermal_zone intel_hid sparse_keymap acpi_pad acpi_tad int3400_thermal acpi_thermal_rel zram ip_tables dm_crypt trusted hid_logitech_hidpp hid_logitech_dj hid_sensor_hub intel_ishtp_loader intel_ishtp_hid r8152 mii i915 hid_multitouch rtsx_pci_sdmmc nvme mmc_core i2c_algo_bit nvme_core drm_kms_helper crct10dif_pclmul crc32_pclmul cec crc32c_intel ghash_clmulni_intel drm serio_raw rtsx_pci intel_ish_ipc intel_ishtp wmi vmd i2c_hid_acpi i2c_hid video pinctrl_tigerlake fuse
May 04 11:11:43 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 04 14:15:43 sudo[24770]:  roberto : TTY=pts/1 ; PWD=/home/roberto ; USER=root ; COMMAND=/usr/bin/systemctl restart bluetooth.service
May 04 14:15:43 bluetoothd[1559]: Terminating
May 04 14:15:43 systemd[1]: Stopping Bluetooth service...
May 04 14:15:43 bluetoothd[1559]: Stopping SDP server
May 04 14:15:43 bluetoothd[1559]: Exit
May 04 14:15:43 systemd[1]: bluetooth.service: Deactivated successfully.
May 04 14:15:43 systemd[1]: Stopped Bluetooth service.
May 04 14:15:43 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 14:15:43 blueman.desktop[3403]: blueman-applet 14.15.43 WARNING  DiscvManager:109 update_menuitems: warning: Adapter is None
May 04 14:15:43 systemd[1]: Starting Bluetooth service...
May 04 14:15:43 bluetoothd[24775]: Bluetooth daemon 5.58
May 04 14:15:43 systemd[1]: Started Bluetooth service.
May 04 14:15:43 bluetoothd[24775]: Starting SDP server
May 04 14:15:43 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 14:15:43 bluetoothd[24775]: Bluetooth management interface 1.19 initialized
May 04 14:15:43 blueman.desktop[3403]: blueman-applet 14.15.43 WARNING  DiscvManager:109 update_menuitems: warning: Adapter is None
May 04 14:15:44 systemd[1]: Starting Bluetooth management mechanism...
May 04 14:15:44 blueman-mechanism[24783]: Unable to init server: Could not connect: Connection refused
May 04 14:15:45 blueman-mechanism[24783]: Unable to init server: No se pudo conectar: Connection refused
May 04 14:15:45 blueman-mechani[24783]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 04 14:15:45 systemd[1]: Started Bluetooth management mechanism.
May 04 14:15:45 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 14:16:15 systemd[1]: blueman-mechanism.service: Deactivated successfully.
May 04 14:16:15 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 14:42:13 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 04 15:07:25 systemd[2880]: Started Application launched by blueman-applet.
May 04 15:12:45 systemd[1]: Starting Bluetooth management mechanism...
May 04 15:12:45 blueman-mechanism[30037]: Unable to init server: Could not connect: Connection refused
May 04 15:12:45 blueman-mechanism[30037]: Unable to init server: No se pudo conectar: Connection refused
May 04 15:12:45 blueman-mechani[30037]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 04 15:12:45 systemd[1]: Started Bluetooth management mechanism.
May 04 15:12:45 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:12:54 systemd[2880]: app-glib-gnome\x2dbluetooth\x2dpanel-30050.scope: Deactivated successfully.
May 04 15:12:54 gnome-bluetooth-panel.desktop[30050]: ../src/intel/isl/isl.c:2015: FINISHME: ../src/intel/isl/isl.c:isl_surf_supports_ccs: CCS for 3D textures is disabled, but a workaround is available.
May 04 15:12:56 blueman.desktop[29359]: blueman-services version 2.1.4 starting
May 04 15:12:56 systemd[2880]: app-glib-blueman\x2dservices-29359.scope: Deactivated successfully.
May 04 15:13:00 systemd[2880]: app-gnome-gnome\x2dbluetooth\x2dpanel-30050.scope: Deactivated successfully.
May 04 15:13:15 systemd[1]: blueman-mechanism.service: Deactivated successfully.
May 04 15:13:15 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:26:40 systemd[1]: Starting Bluetooth management mechanism...
May 04 15:26:40 blueman-mechanism[31396]: Unable to init server: Could not connect: Connection refused
May 04 15:26:40 blueman-mechanism[31396]: Unable to init server: No se pudo conectar: Connection refused
May 04 15:26:40 blueman-mechani[31396]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 04 15:26:40 systemd[1]: Started Bluetooth management mechanism.
May 04 15:26:40 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:58:46 systemd[2880]: app-glib-blueman\x2dmanager-37314.scope: Deactivated successfully.
May 04 15:58:46 blueman-manager.desktop[37314]: blueman-manager 15.58.46 ERROR    Manager:118 on_dbus_name_appeared: Default adapter not found, trying first available.
May 04 15:58:46 blueman-manager.desktop[37314]: blueman-manager 15.58.46 ERROR    Manager:122 on_dbus_name_appeared: No adapter(s) found, exiting
May 04 15:58:46 blueman-manager.desktop[37314]: blueman-manager version 2.1.4 starting
May 04 15:58:46 systemd[2880]: app-gnome-blueman\x2dmanager-37314.scope: Deactivated successfully.
May 04 15:58:54 sudo[37332]:  roberto : TTY=pts/2 ; PWD=/home/roberto ; USER=root ; COMMAND=/usr/bin/systemctl restart bluetooth.service
May 04 15:58:54 bluetoothd[24775]: Terminating
May 04 15:58:54 systemd[1]: Stopping Bluetooth service...
May 04 15:58:54 bluetoothd[24775]: Stopping SDP server
May 04 15:58:54 bluetoothd[24775]: Exit
May 04 15:58:54 systemd[1]: bluetooth.service: Deactivated successfully.
May 04 15:58:54 systemd[1]: Stopped Bluetooth service.
May 04 15:58:54 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:58:54 blueman.desktop[3403]: blueman-applet 15.58.54 WARNING  DiscvManager:109 update_menuitems: warning: Adapter is None
May 04 15:58:54 systemd[1]: Starting Bluetooth service...
May 04 15:58:54 bluetoothd[37337]: Bluetooth daemon 5.58
May 04 15:58:54 systemd[1]: Started Bluetooth service.
May 04 15:58:54 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:58:54 bluetoothd[37337]: Starting SDP server
May 04 15:58:54 bluetoothd[37337]: Bluetooth management interface 1.19 initialized
May 04 15:58:54 blueman.desktop[3403]: blueman-applet 15.58.54 WARNING  DiscvManager:109 update_menuitems: warning: Adapter is None
May 04 15:58:55 systemd[1]: Starting Bluetooth management mechanism...
May 04 15:58:55 blueman-mechanism[37346]: Unable to init server: Could not connect: Connection refused
May 04 15:58:55 blueman-mechanism[37346]: Unable to init server: No se pudo conectar: Connection refused
May 04 15:58:55 blueman-mechani[37346]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 04 15:58:55 systemd[1]: Started Bluetooth management mechanism.
May 04 15:58:55 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 15:59:25 systemd[1]: blueman-mechanism.service: Deactivated successfully.
May 04 15:59:25 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 04 17:12:18 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 04 17:12:18 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 04 18:31:00 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 04 22:49:30 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 05 01:45:27 kernel: ath11k_pci 0000:71:00.0: firmware crashed: MHI_CB_SYS_ERROR
May 05 02:51:50 kernel:  processor_thermal_mbox ucsi_acpi processor_thermal_rapl intel_pmt intel_rapl_common intel_soc_dts_iosf typec_ucsi bluetooth typec ecdh_generic rfkill ecc int3403_thermal int340x_thermal_zone intel_hid sparse_keymap acpi_pad acpi_tad int3400_thermal acpi_thermal_rel zram ip_tables dm_crypt trusted hid_logitech_hidpp hid_logitech_dj hid_sensor_hub intel_ishtp_loader intel_ishtp_hid r8152 mii i915 hid_multitouch rtsx_pci_sdmmc nvme mmc_core i2c_algo_bit nvme_core drm_kms_helper crct10dif_pclmul crc32_pclmul cec crc32c_intel ghash_clmulni_intel drm serio_raw rtsx_pci intel_ish_ipc intel_ishtp wmi vmd i2c_hid_acpi i2c_hid video pinctrl_tigerlake fuse
May 05 10:06:32 systemd[1]: Starting Bluetooth management mechanism...
May 05 10:06:32 blueman-mechanism[88289]: Unable to init server: Could not connect: Connection refused
May 05 10:06:32 blueman-mechanism[88289]: Unable to init server: No se pudo conectar: Connection refused
May 05 10:06:32 blueman-mechani[88289]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 05 10:06:32 systemd[1]: Started Bluetooth management mechanism.
May 05 10:06:32 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 05 10:07:02 systemd[1]: blueman-mechanism.service: Deactivated successfully.
May 05 10:07:02 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 05 10:11:30 systemd[2880]: app-glib-gnome\x2dbluetooth\x2dpanel-88422.scope: Deactivated successfully.
May 05 10:11:30 gnome-bluetooth-panel.desktop[88422]: ../src/intel/isl/isl.c:2015: FINISHME: ../src/intel/isl/isl.c:isl_surf_supports_ccs: CCS for 3D textures is disabled, but a workaround is available.
May 05 10:11:34 systemd[2880]: app-gnome-gnome\x2dbluetooth\x2dpanel-88422.scope: Deactivated successfully.
May 05 11:40:49 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 05 13:00:55 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 05 13:49:09 blueman-tray[3755]: gtk_widget_get_scale_factor: assertion 'GTK_IS_WIDGET (widget)' failed
May 05 14:41:39 systemd[2880]: app-glib-gnome\x2dbluetooth\x2dpanel-113128.scope: Deactivated successfully.
May 05 14:41:39 gnome-bluetooth-panel.desktop[113128]: ../src/intel/isl/isl.c:2015: FINISHME: ../src/intel/isl/isl.c:isl_surf_supports_ccs: CCS for 3D textures is disabled, but a workaround is available.
May 05 14:41:46 systemd[2880]: Started Application launched by blueman-applet.
May 05 14:41:53 blueman.desktop[113184]: blueman-services version 2.1.4 starting
May 05 14:41:53 systemd[2880]: app-glib-blueman\x2dservices-113184.scope: Deactivated successfully.
May 05 14:41:55 systemd[1]: Starting Bluetooth management mechanism...
May 05 14:41:55 blueman-mechanism[113812]: Unable to init server: Could not connect: Connection refused
May 05 14:41:55 blueman-mechanism[113812]: Unable to init server: No se pudo conectar: Connection refused
May 05 14:41:55 blueman-mechani[113812]: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
May 05 14:41:55 systemd[1]: Started Bluetooth management mechanism.
May 05 14:41:55 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 05 17:23:51 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 05 17:23:51 bluetoothd[136239]: Starting SDP server
May 05 17:23:51 bluetoothd[136239]: Bluetooth management interface 1.19 initialized
May 05 17:23:56 systemd[2880]: app-glib-gnome\x2dbluetooth\x2dpanel-136267.scope: Deactivated successfully.
May 05 17:23:56 gnome-bluetooth-panel.desktop[136267]: ../src/intel/isl/isl.c:2015: FINISHME: ../src/intel/isl/isl.c:isl_surf_supports_ccs: CCS for 3D textures is disabled, but a workaround is available.
May 05 17:24:25 systemd[2880]: app-gnome-gnome\x2dbluetooth\x2dpanel-136267.scope: Deactivated successfully.
May 05 17:27:58 kernel:  snd_soc_acpi_intel_match snd_soc_acpi qrtr snd_soc_core ns ath11k_pci x86_pkg_temp_thermal snd_compress intel_powerclamp snd_pcm_dmaengine ath11k coretemp ac97_bus ledtrig_audio kvm_intel snd_hda_intel qmi_helpers snd_intel_dspcfg mac80211 snd_intel_sdw_acpi kvm snd_hda_codec snd_hda_core irqbypass intel_cstate snd_hwdep intel_uncore snd_seq snd_seq_device dell_wmi cfg80211 dell_smbios snd_pcm dcdbas snd_timer dell_wmi_sysman dell_wmi_descriptor snd wmi_bmof mhi i2c_i801 i2c_smbus soundcore libarc4 joydev hid_sensor_als hci_uart hid_sensor_trigger hid_sensor_iio_common mei_me industrialio_triggered_buffer kfifo_buf btqca mei idma64 industrialio btrtl processor_thermal_device btbcm processor_thermal_rfim thunderbolt btintel processor_thermal_mbox ucsi_acpi processor_thermal_rapl intel_pmt intel_rapl_common intel_soc_dts_iosf typec_ucsi bluetooth typec ecdh_generic rfkill ecc int3403_thermal int340x_thermal_zone intel_hid sparse_keymap acpi_pad acpi_tad int3400_thermal
May 05 18:02:33 kernel: Bluetooth: hci0: SSR or FW download time out
May 05 18:02:38 kernel: Bluetooth: hci0: SSR or FW download time out
May 05 18:03:01 kernel: Bluetooth: hci0: SSR or FW download time out
May 05 18:03:05 kernel: Bluetooth: hci0: SSR or FW download time out
May 05 20:44:16 kernel: Bluetooth: hci0: SSR or FW download time out
May 05 20:44:20 kernel: Bluetooth: hci0: SSR or FW download time out


$ lspci -nnk | grep -iA2 net
0000:71:00.0 Unassigned class [ff00]: Qualcomm QCA6390 Wireless Network Adapter [AX500-DBS (2x2)] [17cb:1101]
	Subsystem: Rivet Networks Device [1a56:a501]
	Kernel driver in use: ath11k_pci
	Kernel modules: ath11k_pci

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 0c45:6a0f Microdia Integrated_Webcam_HD
Bus 003 Device 006: ID 2f68:0082 Hoksi Technology DURGOD Taurus K320
Bus 003 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 003: ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
Bus 003 Device 002: ID 27c6:533c Shenzhen Goodix Technology Co.,Ltd. FingerPrint
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ hciconfig -a
hci0:	Type: Primary  Bus: UART
	BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
	DOWN INIT RUNNING 
	RX bytes:30 acl:0 sco:0 events:3 errors:0
	TX bytes:201094 acl:0 sco:0 commands:810 errors:0
	Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
	Packet type: DM1 DH1 HV1 
	Link policy: 
	Link mode: SLAVE ACCEPT 

$ bluetoothctl show
No default controller available

Thanks in advance

Comment 3 Gustavo 2021-05-10 12:48:31 UTC
Hi, I'm dealing with the same issue.

I've also tried uninstalling linux-firmware and all the iw drivers, downgrading them to the 2020 version, and removing that and reinstalling everything. The result is the same. In Fedora 33 I had everything working with kernel 5.12

Did you find any new progress? This is driving me crazy because it won't suspend the computer. I get an error in hci0.

I've also booted into windows and updated all the Dell drivers, and the BIOS. Same results.

I also reported the error that I'm getting every time I boot the computer in #1958925 which was marked automatically as a duplicate from https://bugzilla.redhat.com/show_bug.cgi?id=1957598

Comment 4 Christian Sutter 2021-05-15 08:57:49 UTC
From my digging, I believe this is a combination of Fedora having enabled firmware compression in 34, and the btqca driver not supporting it. Hence why it works on recent Ubuntu with the same kernel.

Good news is it’s fixed upstream: https://patchwork.kernel.org/project/bluetooth/patch/20210507122733.11250-1-cwabbott0@gmail.com/

… but it may have missed the 5.13 merge window.

Comment 5 Peter Robinson 2021-06-16 11:01:49 UTC
> I've also tried uninstalling linux-firmware and all the iw drivers,

If you have a QCA device, please report which, downgrading Intel wifi firmware will make little difference.

> I've also booted into windows and updated all the Dell drivers, and the
> BIOS. Same results.

Windows is irrelevant 

> I also reported the error that I'm getting every time I boot the computer in
> #1958925 which was marked automatically as a duplicate from
> https://bugzilla.redhat.com/show_bug.cgi?id=1957598

That is the correct bug, this is either a linux-firmware or a kernel issue, bluez is userspace and does nothing with firmware/drivers.

*** This bug has been marked as a duplicate of bug 1957598 ***

Comment 6 Gustavo 2021-06-16 12:59:36 UTC
(In reply to Peter Robinson from comment #5)
> > I've also tried uninstalling linux-firmware and all the iw drivers,
> 
> If you have a QCA device, please report which, downgrading Intel wifi
> firmware will make little difference.
lspci | grep QCA
6d:00.0 Network controller: Qualcomm QCA6390 Wireless Network Adapter [AX500-DBS (2x2)] (rev 01)
> 
> > I've also booted into windows and updated all the Dell drivers, and the
> > BIOS. Same results.
> 
> Windows is irrelevant 
I know, but honestly, I didn't know what else to try :)
> 
> > I also reported the error that I'm getting every time I boot the computer in
> > #1958925 which was marked automatically as a duplicate from
> > https://bugzilla.redhat.com/show_bug.cgi?id=1957598
> 
> That is the correct bug, this is either a linux-firmware or a kernel issue,
> bluez is userspace and does nothing with firmware/drivers.
> 
> *** This bug has been marked as a duplicate of bug 1957598 ***

Comment 7 Fedora Update System 2021-06-16 20:11:20 UTC
FEDORA-2021-3b9bfc018f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3b9bfc018f


Note You need to log in before you can comment on or make changes to this bug.