Bug 195460 - radeon driver has annoying default behavior
radeon driver has annoying default behavior
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 08:29 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-19 23:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7243 None None None Never

  None (edit)
Description Tom Horsley 2006-06-15 08:29:22 EDT
Description of problem:

Since the x86_64 fglrx driver crashes my system, I had to switch
to the radeon driver, and found the experience "interesting" :-).
I have 1 physical display connected - a flat panel LCD on the DVI
connector of my X700 PCIE radeon card.

The radeon driver apparently assumes that I have two displays,
and when it cannot query CRT2 for info on what resolution
it supports, it forces everything to use 640x480 - including
my 1920x1080 highdef LCD panel :-(.

Much scrambling about in man pages (and scrambling about earlier
to discover there actually is a man page for radeon I should look at :-),
eventually led to the MonitorLayout option and the discovery that I
could tell it the 2nd monitor was NONE.

That finally made it work, but it would sure be swell if the radeon driver
said: "Hmmmm... I have info from the main display but no info from CRT2,
maybe it would be more helpful to assume there is no CRT2 instead of assuming
I have to run both displays at 640x480."

Version-Release number of selected component (if applicable):

I'm not at the computer at the moment, but it is a fully updated FC5 x86_64
system, so whatever the latest X and driver versions are as of the date of
this bugzilla are the ones.

How reproducible:

All the time on my system, but it could obviously be something about the
specific video card fooling the driver.

Steps to Reproduce:
1. Fail to use MonitorLayout option.
2. See your beautiful 1920x1080 screen running 640x480 :-).

Possibly this is fixed in newer drivers that haven't made it to FC5 yet.
I notice that the SUSE 10.1 boot partition on this same machine doesn't
have this problem with the radeon driver it installs.
Comment 1 Mike A. Harris 2006-06-15 11:06:21 EDT
Thanks for the report.  This issue should be reported to X.Org developers
by submitting a bug report in X.Org bugzilla, located at:

http://bugs.freedesktop.org in the "xorg" component.

This problem is a general problem in the upstream "radeon" driver as shipped
with X.Org X11R7.0.  The Radeon driver's display detection logic seems to
have become rather flawed lately on many Radeon cards, and that requires
the user to manually configure their display type in the config file by
using the MonitorLayout options as you've discovered.

I have no idea what release of X SuSE 10.1 is shipping, but I would guess
that it is Xorg 6.8.2, which is what is in Fedora Core 4 if this problem
is not occuring on that OS release, as the problem is new to Xorg 7.0 and
later.

Once you have filed your bug report to the upstream driver maintainers
at X.Org, if you paste the URL here, we will track the issue in Xorg
bugzilla, and once a fix is available, we will review it for consideration
in future driver updates.

Thanks in advance.
Comment 2 Tom Horsley 2006-06-15 22:29:49 EDT
I've submitted the xorg bug with lots of log files and such attached. I'm
filling in the URL field with a pointer.
Comment 3 Mike A. Harris 2006-06-19 23:06:53 EDT
Thanks, tracking upstream now...

Note You need to log in before you can comment on or make changes to this bug.