Bug 1954610 - Default image for GCP does not support ignition V3
Summary: Default image for GCP does not support ignition V3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.7.z
Assignee: Joel Speed
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On: 1954597
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 13:04 UTC by Joel Speed
Modified: 2021-05-19 15:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The default GCP image was out of date, referencing a version from the 4.6 release which did not support newer ignition versions Consequence: New machines could not boot for born in 4.7+ clusters when using the default image Fix: Update the image to match the release version Result: New machines can boot with the default image
Clone Of: 1954597
Environment:
Last Closed: 2021-05-19 15:16:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 856 0 None open Bug 1954610: Update GCP default image to match 4.7 release 2021-04-28 13:07:09 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:17:04 UTC

Description Joel Speed 2021-04-28 13:04:22 UTC
+++ This bug was initially created as a clone of Bug #1954597 +++

Description of problem:

As part of the process of creating a new Machine on GCP, we may set some defaults.

When an image is not provided, we set a defult image for the new Machine.

The image that we are using is currently from OCP 4.6.

It supports ignition v2 but the newer installs are setting up ignition v3 stubs.

This breaks the defaulting.

Version-Release number of selected component (if applicable):


How reproducible:

100%


Steps to Reproduce:
1. Create a new GCP cluster on OCP 4.7
2. Modify the machineset to remove the image
3. Scale up

Actual results:

Machines fail to boot reporting a maximum ignition version of 2.2

Expected results:

Machine should be created without issue

Additional info:

--- Additional comment from Joel Speed on 2021-04-28 12:46:10 UTC ---

This was already merged and fixed in 4.8, need to create the appropriate bug chain to backport a fix to 4.7

Comment 1 Joel Speed 2021-04-28 13:07:52 UTC
We need to wait for the dependent bug for this to be verified, otherwise everything else is done

Comment 4 sunzhaohua 2021-05-06 04:38:47 UTC
Verified
clusterversion: 4.7.0-0.nightly-2021-05-05-092347
Steps:
1. Create a new GCP cluster on OCP 4.7
2. Modify the machineset to remove the image
3. Scale up
Machine could be created without issue.

Comment 5 Siddharth Sharma 2021-05-10 17:59:46 UTC
This bug will be shipped as part of next z-stream release 4.7.11 on May 19th, as 4.7.10 was dropped due to a blocker https://bugzilla.redhat.com/show_bug.cgi?id=1958518.

Comment 9 errata-xmlrpc 2021-05-19 15:16:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.