Bug 1954614 - [ceph-ansible] cephadm-adopt - only crash service names and container names remain in older template
Summary: [ceph-ansible] cephadm-adopt - only crash service names and container names r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 5.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 13:08 UTC by Vasishta
Modified: 2021-08-30 08:30 UTC (History)
7 users (show)

Fixed In Version: ceph-ansible-6.0.5-1.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 08:29:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 6493 0 None open [skip ci] cephadm_adopt: fix ceph-crash migration 2021-04-28 13:14:56 UTC
Red Hat Issue Tracker RHCEPH-1274 0 None None None 2021-08-30 00:21:38 UTC
Red Hat Product Errata RHBA-2021:3294 0 None None None 2021-08-30 08:30:16 UTC

Description Vasishta 2021-04-28 13:08:31 UTC
Description of problem:
If a cluster upgraded from 4.x to 5.x only crash service names and container names remain in 4.x template, all other daemon service names and container names gets changed with addition of cluster fsid

Version-Release number of selected component (if applicable):
ceph-ansible-6.0.3-1.el8cp

How reproducible:
Always (4/4)

Steps to Reproduce:
1. Configure 4.x cluster
2. Upgrade completely (rolling-update and cephadm-adopt_

Actual results:
 ceph-89964d63-c37f-41ca-899d-8867f3b03bbf@osd.0.service                                                                              loaded active running   Ceph osd.0 for 89964d63-c37f-41ca-899d-8867f3b03bbf                                                                        
  ceph-crash@vasi-1619506426170-node1-mon-mgr-osd.service                                                                              loaded active running   Ceph crash dump collector                       

Expected results:
ceph-crash service to follow all other daemons on service name and container name

Additional info:

Comment 7 errata-xmlrpc 2021-08-30 08:29:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 5.0 bug fix and enhancement), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3294


Note You need to log in before you can comment on or make changes to this bug.