Bug 195468 - Font problems in XFIG
Font problems in XFIG
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 09:02 EDT by trondo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 15:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description trondo 2006-06-15 09:02:24 EDT
Description of problem:
I ran yum update this morning, and I think some xfig package was updated. When
wanting to edit my xfig-figures i cannot make the Norwegian letters ÆØÅ work
anymore. A couple of days ago they worked fine, so I think they relate to the
update. When entering "xfig -international" in the terminal, the Norwegian
letters work for Times-Roman, but not for the other fonts. Strange symbols are
produced instead of. I recall this being a problem in XFIG looong time ago too.

Version-Release number of selected component (if applicable):
xfig 3.2, patchlevel 4 (Protocol 3.2)

How reproducible:
Start XFIG and try to enter Norwegian letters

Steps to Reproduce:
1. Start XFIG and 
2. try to enter Norwegian letters
3.
  
Actual results:
No Norwegian letters work in XFIG. By entering "xfig - international" in a
terminal, they work for Times-Roman, but produce stange symbols for the other fonts.

Expected results:
Nowegian letters enabled

Additional info:
Comment 1 Hans de Goede 2007-11-16 15:11:54 EST
Short intro, I've recently become co-maintainer of xfig and I'm working my way
through al the open xfig bugs.

I cannot reproduce this ø (the only norwegian char I can come up with) and also
things like ü ë ß all work fine, this is with a vastly newer xfig though, which
also has seen several font related fixes. So I'm going to close this as worksforme.

Please reopen this if you still have problems using xfig-3.2.5-5, which will
show up in updates-testing for F-7 and F-8 soon (within a few days usually)

To install it do:
yum --enablerepo=updates-testing update xfig

Note You need to log in before you can comment on or make changes to this bug.