Bug 195471 - Evince fails to open PostScript/PDF files without file-type suffixes
Evince fails to open PostScript/PDF files without file-type suffixes
Status: CLOSED DUPLICATE of bug 193582
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Depends On:
  Show dependency treegraph
Reported: 2006-06-15 09:13 EDT by Mark A J Ashdown
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-29 17:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark A J Ashdown 2006-06-15 09:13:45 EDT
Description of problem:

Evince does not open PostScript or PDF files if they do not have a .ps or .pdf
suffix. In particular, such files downloaded from the web cannot be opened
automatically (some websites, for example, arxiv.org, distribute PS and PDF
files with no suffix).

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Remove file-type suffix from name of PS/PDF file
2. Attempt to open file with evince.
Actual results:

For PostScript files, an error box pops up containing:

Unable to open document 
Unhandled MIME type: 'text/plain'

A similar thing happens for PDF files, except the supposed MIME type is

Expected results:

File should be opened as normal.

Additional info:

The obvious work-around is to change the file name by hand. This is particularly
annoying if the file is being downloaded from a website; you have to save it to
disk, change the name and then start evince manually.
Comment 1 James Ralston 2006-06-18 23:04:03 EDT
Agreed.  Not only do I get bitten by this bug all the time, I generally have to
resort to removing the mozplugger package to actually get firefox to prompt me
to save the document to a file.

(Hopefully evince's amazing brittleness will improve over time.  When it
actually works, it's superb.)
Comment 2 Kristian Høgsberg 2006-06-29 17:04:37 EDT

*** This bug has been marked as a duplicate of 193582 ***

Note You need to log in before you can comment on or make changes to this bug.