Bug 1954742 - KeepassXC should always use xWayland under Wayland
Summary: KeepassXC should always use xWayland under Wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: keepassxc
Version: 34
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-28 17:43 UTC by Alexandre Fernandez
Modified: 2021-05-07 01:02 UTC (History)
8 users (show)

Fixed In Version: keepassxc-2.6.4-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-07 01:02:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Alexandre Fernandez 2021-04-28 17:43:46 UTC
Description of problem:
When opening KeepassXC on Fedora Workstation with GNOME Wayland session, KeepassXC is missing icons and fails to close with the application launcher. However, when launching KeepassXC with the command line arguments -platform xcb, the application works as expected.


Version-Release number of selected component (if applicable):


How reproducible:
Always. This has been an issue for me since Fedora 32.

Steps to Reproduce:
1. Install Fedora Workstation 34.
2. Open a GNOME Wayland session
3. Open KeePassXC.

Actual results:
The application is missing icons and the mouse turns into a scrolling wheel. Additonally, the application does not close after closing the window.

Expected results:
The application looks "normal".

Additional info:
KeePassXC should be run with "-platform xcb" under wayland.

Comment 1 Germano Massullo 2021-04-29 17:24:17 UTC
Some GNOME+Wayland users have already reported some quirks, but this is the response from keepassxc upstream developers

[00:53] <droidmonkey[m]> This should be brought up with Qt
[00:53] <droidmonkey[m]> We don't control platform integration that is Qt via xcb platform or qwayland platform
[00:54] <droidmonkey[m]> I suspect that Fedora is on the bleeding edge, or stuck on a bad version, of qwayland 
[00:54] <droidmonkey[m]> Numerous reported issues with keepassxc on Fedora 33 and 34
[00:54] <droidmonkey[m]> But no other platform

On my side instead, there is nothing I can do, I can just forward this report to Qt maintainers

Comment 2 Alexandre Fernandez 2021-04-29 17:54:19 UTC
(In reply to Germano Massullo from comment #1)
> Some GNOME+Wayland users have already reported some quirks, but this is the
> response from keepassxc upstream developers
> 
> [00:53] <droidmonkey[m]> This should be brought up with Qt
> [00:53] <droidmonkey[m]> We don't control platform integration that is Qt
> via xcb platform or qwayland platform
> [00:54] <droidmonkey[m]> I suspect that Fedora is on the bleeding edge, or
> stuck on a bad version, of qwayland 
> [00:54] <droidmonkey[m]> Numerous reported issues with keepassxc on Fedora
> 33 and 34
> [00:54] <droidmonkey[m]> But no other platform
> 
> On my side instead, there is nothing I can do, I can just forward this
> report to Qt maintainers

Is it possible to set the command line arguments in the .desktop file at least (-platform xcb)? Or would this break things for non-wayland users?

Comment 3 Mukundan Ragavan 2021-04-29 21:53:38 UTC
yeah, adding to desktop will probably break for non-wayland users. I would prefer to not do that.

Comment 4 Christian Dersch 2021-04-29 21:57:31 UTC
(In reply to Mukundan Ragavan from comment #3)
> yeah, adding to desktop will probably break for non-wayland users. I would
> prefer to not do that.

Why do you think that? I can start keepassxc -platform xcb on X11 (KDE) too.

Comment 5 Mukundan Ragavan 2021-04-30 02:22:55 UTC
Well, I thought wrong. :)

I just tested it in Xfce and no problems using `-platform xcb`

Comment 6 Germano Massullo 2021-04-30 13:50:48 UTC
This comment clarified why we are experiencing these problems. I will release a fix soon
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/3BVLBS4B3XHJEXFVGD7RK2ZMXZG6JQZT/

Comment 7 Fedora Update System 2021-05-01 14:34:24 UTC
FEDORA-2021-bedff8f66e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bedff8f66e

Comment 8 Fedora Update System 2021-05-02 01:08:40 UTC
FEDORA-2021-bedff8f66e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-bedff8f66e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-bedff8f66e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Germano Massullo 2021-05-06 06:20:39 UTC
(In reply to Fedora Update System from comment #7)
> FEDORA-2021-bedff8f66e has been submitted as an update to Fedora 34.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-bedff8f66e

Can you please test and provide feedback? It is very important since we are discussing on the mailing list about the xcb problem and there are people that instead say that the Qt bug was already fixed like
https://bugreports.qt.io/browse/QTBUG-88293?focusedCommentId=548882&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-548882
Thank you

Comment 10 Alexandre Fernandez 2021-05-06 14:00:36 UTC
I have been using the new build of keepassxc and it works perfectly for me. It solves all the issues I have been experiencing. I am on GNOME wayland.

Comment 11 Germano Massullo 2021-05-06 21:34:51 UTC
(In reply to Alexandre Fernandez from comment #10)
> I have been using the new build of keepassxc and it works perfectly for me.
> It solves all the issues I have been experiencing. I am on GNOME wayland.

Thank you

(In reply to Germano Massullo from comment #9)
It is very important since we are
> discussing on the mailing list about the xcb problem and there are people
> that instead say that the Qt bug was already fixed like
> https://bugreports.qt.io/browse/QTBUG-88293?focusedCommentId=548882&page=com.
> atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-548882

I was wrong, that comment was not related to xcb but to another bug concerning MIME types

Comment 12 Fedora Update System 2021-05-07 01:02:44 UTC
FEDORA-2021-bedff8f66e has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.