Bug 195477 - kdegraphics: BuildRequires: imlib-devel (for kuickshow)
kdegraphics: BuildRequires: imlib-devel (for kuickshow)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 09:37 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-19 05:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-06-15 09:37:02 EDT
kuickshow needs imlib.

Now that imlib has been dropped from Core, what to do:
1.  Drop kdegraphics from Core too ( -> Extras ), see Extras review, bug #194918
, so that it can also BR: OpenEXR-devel jasper-devel to support those additional
graphics formats as well. 
2.  Keep kdegraphics in Core, omitting kuickshow.  Yuck, I'd rather not go
through the pain of making a kdegraphics-extras package.
Comment 1 Rex Dieter 2006-06-15 09:59:41 EDT
Oh, and while we're on the subject of (1), kdegraphics' kpovmodeler
BuildRequires: freeglut-devel
Comment 2 Rex Dieter 2006-06-15 10:02:59 EDT
FYI, kdegraphics review is really bug #195477 (not sure where 194918 came from).
Comment 3 Rex Dieter 2006-06-15 10:04:27 EDT
Nevermind, 194918 *was* right, but it appears to be a casualty in the recent
bugzilla/hardware crash/failures.  I'll have to resubmit it.
Comment 4 Rex Dieter 2006-06-15 10:20:52 EDT
kdegraphics Extras review update for bugzilla crash, bug #195485
Comment 5 Ngo Than 2006-06-19 05:34:57 EDT
imlib has been moved in extras now. It's the reason why we removed the BR on 
imlib in rawhide. And of course kuickshow cannot be built without this 
library.

kpovmodeler will not work correctly without Pov Ray software, which cannot be 
included in FC because of license.

I prefer the option 2. It's great if you can make the kdegraphics-extras to 
include kuickshow. Thanks

Note You need to log in before you can comment on or make changes to this bug.