Bug 1954962 - unwanted decorator shown for revisions in topology though should only be shown only for knative services
Summary: unwanted decorator shown for revisions in topology though should only be show...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.7
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.7.z
Assignee: Jaivardhan Kumar
QA Contact: Mohammed Saud
Rishu Mehra
URL:
Whiteboard:
Depends On: 1954959
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-29 07:36 UTC by Jaivardhan Kumar
Modified: 2021-07-07 19:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a decorator was shown for revisions in *Topology view* because annotations were passed to specifications of knative service along with metadata. Now the required decorators are shown for the knative service only in the *Topology view* and not with the associated revisions. (link:https://bugzilla.redhat.com/show_bug.cgi?id=1954962[BZ#1954962])
Clone Of: 1954959
Environment:
Last Closed: 2021-06-29 04:19:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8823 0 None open [release-4.7] Bug 1954962: removes extra annotations form spec template for ksvc 2021-04-29 09:57:19 UTC
Red Hat Product Errata RHBA-2021:2502 0 None None None 2021-06-29 04:20:13 UTC

Description Jaivardhan Kumar 2021-04-29 07:36:40 UTC
+++ This bug was initially created as a clone of Bug #1954959 +++

Description of problem: unwanted decorator shown for revisions in topology though should only be shown only for knative services


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Install Serverless operator and create Knative serving CR
2. create a knative service from add -> git import flow
3. wait for build to complete

Actual results: decorator for build and edit shown on revisions along with knative service


Expected results:  decorator for build and edit should be shown only on knative service


Additional info:

Comment 2 Mohammed Saud 2021-06-18 06:14:04 UTC
Verified on:
Build:   4.7.0-0.nightly-2021-06-17-224843
Browser: Firefox 89

Comment 5 errata-xmlrpc 2021-06-29 04:19:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502


Note You need to log in before you can comment on or make changes to this bug.