Bug 1955162 - kbd-legacy should be in @anaconda-tools so it is available for anaconda to install if necessary
Summary: kbd-legacy should be in @anaconda-tools so it is available for anaconda to in...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact:
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
: 1945371 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-29 14:53 UTC by Yaroslav Lifanov
Modified: 2021-05-19 09:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-05 01:18:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Yaroslav Lifanov 2021-04-29 14:53:37 UTC
Description of problem:
On boot:
[FAILED] Failed to start Setup Virtual Console.
[DEPEND] Dependency failed for dracut ask for additional cmdline parameters.


Version-Release number of selected component (if applicable):
kbd: 2.4.0-2.fc34

How reproducible:


Steps to Reproduce:
1.Install Fedora with Russian locale
2.journalctl -b | grep -i dracut

Actual results:
journalctl -b | grep -i dracut:

Mar 11 17:36:39 Orion-15 systemd[1]: dracut-cmdline-ask.service: Job dracut-cmdline-ask.service/start failed with result 'dependency'.

loadkeys ru:

loadkeys: Unable to open file: ru: No such file or directory

/etc/vconsole.conf:

KEYMAP="ru"
FONT="latarcyrheb-sun16"

Expected results:
no errors

Additional info: there no ru keymap in kbd package (only ru-cv_latin), it is in kbd-legacy package. Installation of kbd-legacy package and mkinitrd (or kernel update) solves this problem. This problem can be observed for other locales, not just Russian.

Comment 1 iolo 2021-04-29 21:04:03 UTC
I also ran into this same problem with the Finnish keymap. I use disk encryption, and a consequence of this problem is that when Plymouth asks me for the encryption password, the indicator says the keymap currently in use is the Finnish one, but in fact I need to enter the password using the US layout.

Comment 2 Vitezslav Crhonek 2021-05-03 07:11:44 UTC
Hello guys,

Anaconda is supposed to install kbd-legacy for languages that need it during OS installation.
See bug #1919483 for more information about that.

In case you've installed your OS within the time window in which kbd-legacy dependency was removed
from kbd and before Anaconda was updated, then you need to install kbd-legacy manually.

Comment 3 Yaroslav Lifanov 2021-05-03 18:37:17 UTC
I had this error after installing Fedora 34 Workstation and KDE Spin from the images from April 23, it is obvious that the fix did not get into the release version for some reason. From the anaconda repository, it is clear that the fix for this bug was not moved to the branch for Fedora 34, although the pull request comments emphasized the need for a fix for the release. Apparently, they just forgot about it.

Comment 4 iolo 2021-05-03 18:56:33 UTC
I installed Fedora 34 Workstation with the 1.2 DVD ISO, which seems to be the same as what is currently available from getfedora.org.

Comment 5 Adam Williamson 2021-05-04 06:26:33 UTC
This is strange, because we have a test that would fail if this was broken. It didn't fail:

https://openqa.fedoraproject.org/tests/868058#step/disk_guided_encrypted_postinstall/1

it passed, and there it is using the 'ru' keyboard layout during disk decryption. That test was run on the F34 release images, exactly.

That test does use the Server DVD image. I guess it's possible the live images are missing kbd-legacy.

Comment 6 Adam Williamson 2021-05-04 06:35:09 UTC
...yeah, I think that's exactly what happened, actually. Workstation image build logs for e.g. show no trace of kbd-legacy: https://koji.fedoraproject.org/koji/taskinfo?taskID=66535238

It looks like it's not actually on the Server DVD either, now I check. The Russian install test uses a remote repository, I do not recall why we have it set up that way. So if you install from a live image this won't work, and if you install from the Server DVD without explicitly adding a remote repo it may not work (I'm not 100% sure, we'd have to check).

We'd better put this in Common Bugs :/

The correct resolution here, I think, is to add kbd-legacy to the anaconda-tools group in comps.

Comment 7 Adam Williamson 2021-05-04 16:21:54 UTC
*** Bug 1955793 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2021-05-04 22:44:08 UTC
https://pagure.io/fedora-comps/pull-request/653

unfortunately there is no way we can possibly fix this for the release media :( if that PR gets merged, the semi-unofficial live respins should have it fixed, at least.

Comment 9 Kevin Fenzi 2021-05-04 23:21:10 UTC
Merged. :)

Comment 10 Adam Williamson 2021-05-05 01:18:54 UTC
OK, so I think we have to close this as there isn't really anything else we can do at this point :(

Comment 11 Zbigniew Jędrzejewski-Szmek 2021-05-19 09:36:27 UTC
*** Bug 1945371 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.