Bug 195527 - scalable PostScript fonts from ghostscript-fonts package cannot be added to font path
scalable PostScript fonts from ghostscript-fonts package cannot be added to f...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript-fonts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 11:55 EDT by Mark Alford
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.50-14.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 08:52:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Alford 2006-06-15 11:55:31 EDT
The basic problem here is: how do I make scalable Type-1 Postscript (Times,
Courier etc) available system-wide (i.e include them in the font path)?

I think these fonts are supplied by ghostscript-fonts-5.50-13.1 (residing in
/usr/share/fonts/default/ghostscript) but they can't be added to the font path
because there is no fonts.dir file:

If I type
  chkfontpath -a /usr/share/fonts/default/ghostscript
I get the error message:
  chkfontpath: error opening /usr/share/fonts/default/ghostscript/fonts.dir,
unwilling to add path

This is mysterious because if you go to sourceforge or rpmfind then you can
download ghostscript-fonts-8.11-1ht which offers the scalable PostScript fonts,
including a fonts.dir file so that they can be added to the font path and used
by everyone.

Why doesn't Fedora Core include ghostscript-fonts-8.11-1ht then?



PS: By the way, the package urw-fonts-2.3-6.1 offers a bunch of scalable fonts
(residing in /usr/share/fonts/default/Type1) which CAN be added to the font
path, but these do not include the standard PostScript "Times", "Courier", etc.
Comment 1 Alexei Podtelezhnikov 2006-06-15 12:44:08 EDT
Yeah - right! Next thing, you'll be asking for ghostscript 8.54. which is 
under GPL now! 

It is a shame that Fedora's ghostscript historically is just OLD! It is too 
much work to keep it up to date, I guess.
Comment 2 Tim Waugh 2006-06-15 13:32:07 EDT
Actually we track ESP GhostScript -- as we have been asked to many times.  We
are at the very latest version of that.
Comment 3 Mark Alford 2006-06-15 14:41:47 EDT
OK, that addresses Comment #1. But the bug that I am reporting is to do with the
way the ghostscript fonts are packaged, not to do with which version of
ghostscript is being used.
Basically I am saying: Please can you make ghostscript-fonts-5.50-13.1 be more
like urw-fonts-2.3-6.1 and include a fonts.dir file.

Note You need to log in before you can comment on or make changes to this bug.