Bug 1955634 - SELinux is preventing (direxec) from 'execute_no_trans' accesses on the file /usr/lib/systemd/system-sleep/sysstat.sleep.
Summary: SELinux is preventing (direxec) from 'execute_no_trans' accesses on the file ...
Keywords:
Status: CLOSED DUPLICATE of bug 1948070
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0e8c7c282f8280634c8406f5330...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 14:56 UTC by vincent
Modified: 2021-05-03 10:28 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 10:28:45 UTC
Type: ---


Attachments (Terms of Use)

Description vincent 2021-04-30 14:56:31 UTC
Description of problem:
After unlocking the screen
SELinux is preventing (direxec) from 'execute_no_trans' accesses on the file /usr/lib/systemd/system-sleep/sysstat.sleep.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that (direxec) should be allowed execute_no_trans access on the sysstat.sleep file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c '(direxec)' --raw | audit2allow -M my-direxec
# semodule -X 300 -i my-direxec.pp

Additional Information:
Source Context                system_u:system_r:systemd_sleep_t:s0
Target Context                system_u:object_r:bin_t:s0
Target Objects                /usr/lib/systemd/system-sleep/sysstat.sleep [ file
                              ]
Source                        (direxec)
Source Path                   (direxec)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           sysstat-12.5.3-1.fc34.x86_64
SELinux Policy RPM            selinux-policy-targeted-34.3-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.3-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.11.16-300.fc34.x86_64 #1 SMP Wed
                              Apr 21 13:18:33 UTC 2021 x86_64 x86_64
Alert Count                   8
First Seen                    2021-04-30 13:48:13 CEST
Last Seen                     2021-04-30 15:56:54 CEST
Local ID                      10c90037-2a77-496a-8e98-fb4a847f9ffa

Raw Audit Messages
type=AVC msg=audit(1619791014.575:2061): avc:  denied  { execute_no_trans } for  pid=36021 comm="(direxec)" path="/usr/lib/systemd/system-sleep/sysstat.sleep" dev="dm-0" ino=28053385 scontext=system_u:system_r:systemd_sleep_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file permissive=0


Hash: (direxec),systemd_sleep_t,bin_t,file,execute_no_trans

Version-Release number of selected component:
selinux-policy-targeted-34.3-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.11.16-300.fc34.x86_64
type:           libreport

Comment 1 John Cooper 2021-05-02 10:37:05 UTC
Similar problem has been detected:

Recent Fedora 33 to 34 upgrade. Seen after supsend and wakeup.

hashmarkername: setroubleshoot
kernel:         5.11.15-300.fc34.x86_64
package:        selinux-policy-targeted-34.3-1.fc34.noarch
reason:         SELinux is preventing (direxec) from 'execute_no_trans' accesses on the file /usr/lib/systemd/system-sleep/sysstat.sleep.
type:           libreport

Comment 2 Zdenek Pytela 2021-05-03 10:28:45 UTC

*** This bug has been marked as a duplicate of bug 1948070 ***


Note You need to log in before you can comment on or make changes to this bug.