Bug 1955784 - Unable to generate or force generate a new katello-ca-consumer-latest package using satellite-installer
Summary: Unable to generate or force generate a new katello-ca-consumer-latest package...
Keywords:
Status: ASSIGNED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.9.0
Hardware: All
OS: All
unspecified
high
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Devendra Singh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 19:04 UTC by Kaushik Sajjan Agarwal
Modified: 2021-05-17 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 6012961 0 None None None 2021-05-03 18:47:07 UTC

Description Kaushik Sajjan Agarwal 2021-04-30 19:04:01 UTC
Description of problem:

Unable to generate or force generate a new katello-ca-consumer-latest package using satellite-installer


Version-Release number of selected component (if applicable):

Satellite 6.9

How reproducible:

Always

Steps to Reproduce:
1. Remove /var/www/html/pub/katello-server-ca.crt and /var/www/html/pub/katello-rhsm-consumer from satellite server.
2. Run "satellite-installer"


Actual results:

 - No new "katello-ca-consumer-latest" package is generated as it should generate as it does for earlier versions of satellite releases.

Expected results:

 - A new version of the "katello-ca-consumer-latest" package gets generated.
Additional info:

Comment 3 Eric Helms 2021-05-05 16:53:30 UTC
The behavior:

1. Remove /var/www/html/pub/katello-server-ca.crt and /var/www/html/pub/katello-rhsm-consumer from satellite server.

causing a new katello-consumer RPM to be generated is not a feature and with changes we've made makes sense why you are not seeing a new RPM generated (because nothing changed therefore the system does not see a need to generate a new one). I would prefer to get at the heart of the issue which to me is:


What is the situation for which you need a new katello-consumer RPM generated?
What changed in the environment that should have resulted in a new katello-consumer RPM and did not? What workflow did not work correctly? (e.g. did you change some certificates?)

Comment 5 Eric Helms 2021-05-07 17:00:14 UTC
I think this should be closed as not a bug. The conditions under which a new RPM will get generated are:

 * User deletes the current bootstrap RPM from /var/www/html/pub
 * A new server CA certificate is presented to the installer
 * The FQDN of the server changes and installer ran


Note You need to log in before you can comment on or make changes to this bug.