Bug 1955821 - Cambridge Silicon Radio Bluetooth - recognizes, but does not turn on
Summary: Cambridge Silicon Radio Bluetooth - recognizes, but does not turn on
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 21:06 UTC by fastos
Modified: 2021-05-03 13:51 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 13:51:08 UTC
Type: Bug


Attachments (Terms of Use)
journalctl --no-hostname -k > dmesg.txt (90.21 KB, text/plain)
2021-04-30 21:06 UTC, fastos
no flags Details

Description fastos 2021-04-30 21:06:46 UTC
Created attachment 1777927 [details]
journalctl --no-hostname -k > dmesg.txt

Created attachment 1777927 [details]
journalctl --no-hostname -k > dmesg.txt

1. Please describe the problem:

System recognizes, but does not turn on on GNOME Settings



2. What is the Version-Release number of the kernel:

5.11.16-300.fc34.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

there are reports that say yes 
https://linux-hardware.org/?id=usb:0a12-0001


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

plug in the usb and try to enable it in GNOME Setting 

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

I try rebase to rawhide and 32. not working

kernel-5.13.0-0.rc0.20210430git8ca5297e7e38.3.fc35
kernel-5.11.17-100.fc32


6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

when I connect to USB and I try to enable 

journalctl -f
abr 30 17:28:09 localhost.localdomain systemd[1568]: Reached target Bluetooth.
abr 30 17:28:09 localhost.localdomain systemd[1]: Reached target Bluetooth.
abr 30 17:28:14 localhost.localdomain systemd[1]: systemd-rfkill.service: Deactivated successfully.
abr 30 17:28:14 localhost.localdomain audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
abr 30 17:28:22 localhost.localdomain systemd[1568]: Started Application launched by gnome-shell.
abr 30 17:28:22 localhost.localdomain systemd[1568]: Started Application launched by gnome-shell.
abr 30 17:28:22 localhost.localdomain systemd[1568]: app-glib-gnome\x2dbluetooth\x2dpanel-8353.scope: Deactivated successfully.
abr 30 17:28:22 localhost.localdomain systemd[1568]: app-gnome-gnome\x2dbluetooth\x2dpanel-8353.scope: Deactivated successfully.
abr 30 17:28:34 localhost.localdomain systemd[1568]: app-gnome-gnome\x2dbluetooth\x2dpanel-8262.scope: Deactivated successfully.
abr 30 17:28:34 localhost.localdomain systemd[1568]: app-gnome-gnome\x2dbluetooth\x2dpanel-8262.scope: Consumed 1.351s CPU time.
abr 30 17:28:45 localhost.localdomain systemd[1568]: Started Application launched by gnome-shell.



$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 015: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 003 Device 012: ID 2a7a:938f  CASUE USB KB
Bus 003 Device 011: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 006: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
Bus 003 Device 005: ID 1b3f:2008 Generalplus Technology Inc. USB Audio Device
Bus 003 Device 004: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
Bus 003 Device 003: ID 1b3f:2008 Generalplus Technology Inc. USB Audio Device
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


dmesg

[    4.361442] usb 3-6.4: Device not responding to setup address.
[    4.569317] usb 3-6.4: device not accepting address 9, error -71
[    4.634311] usb 3-6.4: new full-speed USB device number 10 using xhci_hcd
[    4.634414] usb 3-6.4: Device not responding to setup address.
[    4.745093] RPC: Registered named UNIX socket transport module.
[    4.745096] RPC: Registered udp transport module.
[    4.745097] RPC: Registered tcp transport module.
[    4.745098] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    4.841422] usb 3-6.4: Device not responding to setup address.
[    5.049303] usb 3-6.4: device not accepting address 10, error -71
[    5.049394] usb 3-6-port4: unable to enumerate USB device
[    5.238294] usb 3-6.3.2: new low-speed USB device number 11 using xhci_hcd
[    5.318721] usb 3-6.3.2: New USB device found, idVendor=046d, idProduct=c077, bcdDevice=72.00
[    5.318732] usb 3-6.3.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    5.318736] usb 3-6.3.2: Product: USB Optical Mouse
[    5.318740] usb 3-6.3.2: Manufacturer: Logitech
[    5.321861] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3/3-6.3.2/3-6.3.2:1.0/0003:046D:C077.0003/input/input16
[    5.323034] hid-generic 0003:046D:C077.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:14.0-6.3.2/input0
[    5.389304] usb 3-6.3.3: new low-speed USB device number 12 using xhci_hcd
[    5.473996] usb 3-6.3.3: New USB device found, idVendor=2a7a, idProduct=938f, bcdDevice= 0.01
[    5.474000] usb 3-6.3.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    5.474002] usb 3-6.3.3: Product: CASUE USB KB
[    5.479010] input: CASUE USB KB as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3/3-6.3.3/3-6.3.3:1.0/0003:2A7A:938F.0004/input/input17
[    5.531763] hid-generic 0003:2A7A:938F.0004: input,hidraw3: USB HID v1.10 Keyboard [CASUE USB KB] on usb-0000:00:14.0-6.3.3/input0
[    5.538153] input: CASUE USB KB Consumer Control as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3/3-6.3.3/3-6.3.3:1.1/0003:2A7A:938F.0005/input/input18
[    5.589371] input: CASUE USB KB System Control as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.3/3-6.3.3/3-6.3.3:1.1/0003:2A7A:938F.0005/input/input19
[    5.589773] hid-generic 0003:2A7A:938F.0005: input,hidraw4: USB HID v1.10 Device [CASUE USB KB] on usb-0000:00:14.0-6.3.3/input1
[    6.125765] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    6.125768] Bluetooth: BNEP filters: protocol multicast
[    6.125772] Bluetooth: BNEP socket layer initialized
[    7.451370] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
[    7.591449] r8169 0000:03:00.0 enp3s0: Link is Down
[    9.384833] rfkill: input handler disabled
[   14.717870] Generic FE-GE Realtek PHY r8169-300:00: Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!
[   14.717878] r8169 0000:03:00.0 enp3s0: Link is Up - 100Mbps/Full (downshifted) - flow control off
[   14.717889] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
[   74.442109] rfkill: input handler enabled
[   76.185662] rfkill: input handler disabled
[  250.790412] usb 3-1: USB disconnect, device number 2
[  260.966604] usb 3-7: new full-speed USB device number 14 using xhci_hcd
[  280.651951] usb 3-7: new full-speed USB device number 15 using xhci_hcd
[  280.781206] usb 3-7: New USB device found, idVendor=0a12, idProduct=0001, bcdDevice=88.91
[  280.781218] usb 3-7: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  280.781224] usb 3-7: Product: BT DONGLE10
[  280.786711] Bluetooth: hci0: CSR: Unbranded CSR clone detected; adding workarounds...
[ 1931.474181] usb 3-7: USB disconnect, device number 15
[ 1932.009909] usb 3-7: new full-speed USB device number 16 using xhci_hcd
[ 1941.484118] usb 3-7: new full-speed USB device number 17 using xhci_hcd
[ 1941.613366] usb 3-7: New USB device found, idVendor=0a12, idProduct=0001, bcdDevice=88.91
[ 1941.613380] usb 3-7: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 1941.613385] usb 3-7: Product: BT DONGLE10
[ 1941.619269] Bluetooth: hci0: CSR: Unbranded CSR clone detected; adding workarounds...




$ systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-05-02 20:01:37 -03; 40s ago
       Docs: man:bluetoothd(8)
   Main PID: 9614 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19051)
     Memory: 1.8M
        CPU: 27ms
     CGroup: /system.slice/bluetooth.service
             └─9614 /usr/libexec/bluetooth/bluetoothd

mai 02 20:01:37 localhost.localdomain systemd[1]: Starting Bluetooth service...
mai 02 20:01:37 localhost.localdomain bluetoothd[9614]: Bluetooth daemon 5.58
mai 02 20:01:37 localhost.localdomain systemd[1]: Started Bluetooth service.
mai 02 20:01:37 localhost.localdomain bluetoothd[9614]: Starting SDP server
mai 02 20:01:37 localhost.localdomain bluetoothd[9614]: Bluetooth management interface 1.19 initialized

Comment 1 Hans de Goede 2021-05-03 08:51:56 UTC
I assume that you are using some generic USB bluetooth dongle?

As the kernel says:
[ 1941.619269] Bluetooth: hci0: CSR: Unbranded CSR clone detected; adding workarounds...

What you are using does not appear to be a real Cambridge Silicon Radio BT chipset. There are many many clones which use the same USB-ids as the real thing. The kernel has a bunch of workarounds to work with those clones, but it seems that you have a new variant / version of the clones which the kernel recognizes as a clone but which does not work with the existing workarounds.

These clones typically even don't work under Windows unless used with the drivers they come with (or which are linked from their description webpage on e.g. aliexpress), rather then with the standard Windows drivers. Alo see:

https://wiki.archlinux.org/title/Bluetooth#CSR_Dongle_0a12:0001
https://bugzilla.kernel.org/show_bug.cgi?id=60824

The best advice which I can give you is to just get another dongle and check that it is advertised as actually using an "original csr8510 chip", yes you need to check for the seller advertising the thing is the real thing, sad but true.

If you want to pursue getting your dongle to work with Linux further, one of the first things to do is figure out which chip it is using.

I assume that what you have looks like this:
https://dolcevacanza.info/wp-content/uploads/2019/10/31/105-cambridge-silicon-radio-usb-bluetooth.jpg

If you look closely you will see that the plastic case consists of 2 parts, a main part and a lid of sorts. If you put a hobby-knife between the 2 and gently wiggle a bit you can separate the parts. After that you should be able to see the chip which is used. If you can let me know the markings on the chip, then we can see from there.

Comment 2 fastos 2021-05-03 13:51:08 UTC
(In reply to Hans de Goede from comment #1)
> I assume that you are using some generic USB bluetooth dongle?
> 
> As the kernel says:
> [ 1941.619269] Bluetooth: hci0: CSR: Unbranded CSR clone detected; adding
> workarounds...
> 
> What you are using does not appear to be a real Cambridge Silicon Radio BT
> chipset. There are many many clones which use the same USB-ids as the real
> thing. The kernel has a bunch of workarounds to work with those clones, but
> it seems that you have a new variant / version of the clones which the
> kernel recognizes as a clone but which does not work with the existing
> workarounds.
> 
> These clones typically even don't work under Windows unless used with the
> drivers they come with (or which are linked from their description webpage
> on e.g. aliexpress), rather then with the standard Windows drivers. Alo see:
> 
> https://wiki.archlinux.org/title/Bluetooth#CSR_Dongle_0a12:0001
> https://bugzilla.kernel.org/show_bug.cgi?id=60824
> 
> The best advice which I can give you is to just get another dongle and check
> that it is advertised as actually using an "original csr8510 chip", yes you
> need to check for the seller advertising the thing is the real thing, sad
> but true.
> 
> If you want to pursue getting your dongle to work with Linux further, one of
> the first things to do is figure out which chip it is using.
> 
> I assume that what you have looks like this:
> https://dolcevacanza.info/wp-content/uploads/2019/10/31/105-cambridge-
> silicon-radio-usb-bluetooth.jpg
> 
> If you look closely you will see that the plastic case consists of 2 parts,
> a main part and a lid of sorts. If you put a hobby-knife between the 2 and
> gently wiggle a bit you can separate the parts. After that you should be
> able to see the chip which is used. If you can let me know the markings on
> the chip, then we can see from there.

thank you very much for the explanation.

I'm going to buy another one, my intention is more for testing and sharing the bluetooth experience on Linux on my blog. You can close this report


Note You need to log in before you can comment on or make changes to this bug.