Bug 1955825 - "Switch User" functionality is missing from Kickoff and lock screen
Summary: "Switch User" functionality is missing from Kickoff and lock screen
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 22:06 UTC by Rupert Pupkin
Modified: 2021-05-08 09:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Rupert Pupkin 2021-04-30 22:06:15 UTC
Description of problem:
I have two non-admin users on my system. In the SDDM, both users are visible and I can log in as both users. But after I log in as one of the users into Plasma, the following happens: 

In Fedora 32, when I opened the application launcher, it showed an option called "Switch User" (or rather, since my localization is German, "Benutzer wechseln"). After updating to Fedora 34, this option is no longer in Kickoff. Also in Fedora 34, in the lock screen, there is no possibility to switch to another user. The only option is to enter the password for the currently logged-in user. (I am not one hundred percent sure that this option existed in Fedora 32, because I never used it.)

Version-Release number of selected component (if applicable):
plasma-desktop: 5.21.4
KDE Frameworks: 5.80.0
Qt: 5.15.2
Kernel: 5.11.16

How reproducible:
Always

Steps to Reproduce:
1. Open Kickoff
2. Optionally, choose option "lock screen" from Kickoff


Actual results:
No option "Switch user" in Kickoff.
No way to switch user in lock screen. 

Expected results:
Option "Switch user" should be visible in Kickoff.
There should be some way to switch the user in the lock screen.

Additional info:
I have tried this out both with Plasma on Wayland and with Plasma on X11, with the same result.

Comment 1 Rex Dieter 2021-05-03 13:20:46 UTC
Fast user switching has been increasingly broken over the past few 
Fedora releases, and during Fedora Linux 34 development, it reached a 
point where it caused a nearly un-fixable release blocking bug 
(bug #1929643). We have temporarily disabled the feature by default 
until upstream has resolved the issue. 
 
If you wish to enable it again (at your own risk!), you may do so by 
adding the following to "~/.config/kdeglobals": 
 
[KDE Action Restrictions] 
action/start_new_session=true 
action/switch_user=true

Comment 2 Rupert Pupkin 2021-05-03 22:10:08 UTC
Thank you very much for the information. I have successfully used the workaround. (Haven't checked if the bug still happens.)


Note You need to log in before you can comment on or make changes to this bug.