Bug 1955836 - dmsquash-live-ntfs depends on ntfs-3g which isn't available
Summary: dmsquash-live-ntfs depends on ntfs-3g which isn't available
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: dracut
Version: 9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 23:51 UTC by Brian Lane
Modified: 2021-05-04 11:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-04 11:11:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
live.log (557.52 KB, text/plain)
2021-05-03 16:21 UTC, Brian Lane
no flags Details

Description Brian Lane 2021-04-30 23:51:39 UTC
Description of problem:
While testing live media creation with livemedia-creator I found that dmsquash-live is including dmsquash-live-ntfs which depends on ntfs-3g, this causes the rebuild of the iso initrd to fail. I'm pretty sure we're not shipping ntfs support so this needs to be adjusted to remove dmsquash-live-ntfs


Version-Release number of selected component (if applicable):
dracut-live-051-1.el9.1.x86_64.rpm

How reproducible:
always

2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/modules.d/90dmsquash-live-ntfs/module-setup.sh@6(check): require_binaries ntfs-3g
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@108(require_binaries): local _module_name=90dmsquash-live-ntfs
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@109(require_binaries): local _ret=0
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@111(require_binaries): [[ ntfs-3g = \-\m ]]
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@116(require_binaries): for cmd in "$@"
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@117(require_binaries): find_binary ntfs-3g
2021-04-30 16:36:02,881 INFO: /usr/lib/dracut/dracut-init.sh@118(require_binaries): dinfo 'dracut module '\''dmsquash-live-ntfs'\'' will not be installed, because command '\''ntfs-3g'\'' could not be found!'

Comment 1 David Tardon 2021-05-03 08:41:57 UTC
dmsquash-live does not require dmsquash-live-ntfs and it never has. In fact, nothing in dracut itself does. Please attach the output of "dracut -v".

Comment 2 Brian Lane 2021-05-03 16:21:46 UTC
Created attachment 1779050 [details]
live.log

Installing dracut-live certainly is including it:

# dracut --list-modules | grep -i ntfs
(nothing listed)

# dnf install dracut-live
Installing:
 dracut-live               x86_64               051-1.el9.1                AppStream                21 k

# dracut --list-modules | grep live
dmsquash-live
dmsquash-live-ntfs
livenet


Attached is the output from:
"dracut --debug --add dmsquash-live test.img `uname -r` |& tee live.log"

Works fine without the `--add dmsquash`

Comment 3 David Tardon 2021-05-04 11:11:37 UTC
dmsquash-live is skipped in hostonly mode. Call dracut with --no-hostonly or install package dracut-nohostonly.


Note You need to log in before you can comment on or make changes to this bug.