Bug 1956064 - Fedora 34: dnf: wrong repo path for openh264
Summary: Fedora 34: dnf: wrong repo path for openh264
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 12:09 UTC by Thomas
Modified: 2021-05-14 23:45 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-04 11:38:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas 2021-05-02 12:09:57 UTC
Description of problem:

The repository path for the "Fedora 34 openh264 (From Cisco) - x86_64" repo is wrong.

dnf tries to load the XML metadata from:
https://codecs.fedoraproject.org/openh264/34/x86_64/repodata/repomd.xml

(as it was in Fedora 33)

With this path you get a 404.

But if you do a manual search on that URL, you can find a working one:
The new path seems to be:
https://codecs.fedoraproject.org/openh264/34/x86_64/os/repodata/repomd.xml

Version-Release number of selected component (if applicable):


How reproducible:
sudo dnf update

Steps to Reproduce:
1.
2.
3.

Actual results:
Fedora 34 openh264 (From Cisco) - x86_64       731  B/s | 271  B     00:00    
Errors during downloading metadata for repository 'fedora-cisco-openh264':
  - Status code: 404 for https://codecs.fedoraproject.org/openh264/34/x86_64/repodata/repomd.xml (IP: 2a05:d014:10:7803:f774:4d7c:e277:a457)
Error: Failed to download metadata for repo 'fedora-cisco-openh264': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Expected results:


Additional info:

Comment 1 Lukáš Hrázký 2021-05-03 13:33:31 UTC
Hello Thomas,

what's the content of your /etc/yum.repos.d/fedora-cisco-openh264.repo?

I'm reassigning to fedora-repos, in case you have the default configuration in the file, it is a bug, assuming you haven't changed the configuration.

Comment 2 Thomas 2021-05-04 08:09:30 UTC
Hi,

here is the content of my /etc/yum.repos.d/fedora-cisco-openh264.repo

---

[fedora-cisco-openh264]
name=Fedora $releasever openh264 (From Cisco) - $basearch
baseurl=https://codecs.fedoraproject.org/openh264/$releasever/$basearch
type=rpm
enabled=1
enabled_metadata=1
metadata_expire=14d
repo_gpgcheck=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=True

[fedora-cisco-openh264-debuginfo]
name=Fedora $releasever openh264 (From Cisco) - $basearch - Debug
baseurl=https://codecs.fedoraproject.org/openh264/$releasever/$basearch/debug/
type=rpm
enabled=0
metadata_expire=28d
repo_gpgcheck=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=True


---

Comment 3 Peter Robinson 2021-05-04 08:15:31 UTC
> baseurl=https://codecs.fedoraproject.org/openh264/$releasever/$basearch

That's incorrect, it should have a meta link like the one below, do you have a fedora-cisco-openh264.repo.rpmnew file? If so move it over the fedora-cisco-openh264.repo file
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-$releasever&arch=$basearch

Comment 4 Thomas 2021-05-04 11:19:50 UTC
Hi,

Indeed, I do have a rpmnew-file for that repository, although I am not aware of any manual changes to the "fedora-cisco-openh264.repo"-file in the past.
The same behavior I do have on another PC...

Now I have deleted the old repo-file and replaced it with the rpmnew-file.

That content looks like this:

---

[fedora-cisco-openh264]
name=Fedora $releasever openh264 (From Cisco) - $basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-$releasever&arch=$basearch
type=rpm
enabled=1
metadata_expire=14d
repo_gpgcheck=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=True

[fedora-cisco-openh264-debuginfo]
name=Fedora $releasever openh264 (From Cisco) - $basearch - Debug
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-debug-$releasever&arch=$basearch
type=rpm
enabled=0
metadata_expire=14d
repo_gpgcheck=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=True


---

After a "dnf clean all" and "dnf upgrade" all seems to work.

Thanks!

Comment 5 Mars 2021-05-14 23:23:50 UTC
Same issue. So what we need to do?
Modify manually the /etc/yum.repos.d/fedora-cisco-openh264.repo file?

Comment 6 Mars 2021-05-14 23:45:21 UTC
Okay, I see. The new fedora-cisco repo is in the /etc/yum.repos.d/ but with name: fedora-cisco-openh264.repo.rpmnew
So:

sudo bash
cd /etc/yum.repos.d/
mv fedora-cisco-openh264.repo fedora-cisco-openh264.repo.old
cp fedora-cisco-openh264.repo.rpmnew fedora-cisco-openh264.repo

And finally, refresh:

dnf check-update --refresh


Note You need to log in before you can comment on or make changes to this bug.