Bug 1956070 - "fontglide" crashed with status 1
Summary: "fontglide" crashed with status 1
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 13:18 UTC by Maksym Sanzharov
Modified: 2021-05-03 13:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 13:09:46 UTC
Type: Bug


Attachments (Terms of Use)
xscreensaver log received with "xscreensaver -v -log log.txt" (7.50 KB, text/plain)
2021-05-02 13:18 UTC, Maksym Sanzharov
no flags Details
The output of xlsfonts '*--0-*-koi8*' (4.65 KB, text/plain)
2021-05-02 17:44 UTC, Maksym Sanzharov
no flags Details

Description Maksym Sanzharov 2021-05-02 13:18:39 UTC
Created attachment 1778565 [details]
xscreensaver log received with "xscreensaver -v -log log.txt"

Description of problem:


Version-Release number of selected component (if applicable): 6.00-1.fc34


How reproducible:


Steps to Reproduce:
1. Install xorg-x11-fonts-cyrillic 
2. Start xscreensaver-demo application
3. Open Font Glide settings 
4. Open advanced parameters and enter this command line: fontglide -root -font '*--0-*-koi8*'
5. Press OK

Actual results:
I see the message: No Preview Available. By clicking "Preview" I get the message on the full screen: "fontglide" crashed with status 1


Expected results:
Font Glide starts.


Additional info:
This fontglide command line worked well in Fedora 33. I got this problem right after upgrade to Fedora 34. With default setup it does not crash, but in this case it can select fonts with which Cyrillic letters are not displayed properly.

Comment 1 Maksym Sanzharov 2021-05-02 17:31:52 UTC
The execution of a previous xscreensaver version was accidentally included to the log file. Ignore the part related to the version 5.44.

I also have installed these fonts: 
fonts-KOI8-R
fonts-KOI8-R-100dpi
fonts-KOI8-R-75dpi

It seems they should be included to the first step to reproduce too.

Comment 2 Maksym Sanzharov 2021-05-02 17:40:39 UTC
Sorry, the information about KOI8-R packages is wrong - they are not installed in my system.

Comment 3 Maksym Sanzharov 2021-05-02 17:44:43 UTC
Created attachment 1778650 [details]
The output of xlsfonts '*--0-*-koi8*'

Added the output of xlsfonts.

Comment 4 Mamoru TASAKA 2021-05-03 13:09:46 UTC
xscreensaver 6 changed fonts handling a lot. xscreensaver 6 now uses Xft (X freetype) internally as much as possible.

fontglide also changed internal a lot for font handling, now uses Xft by default.
"-font" argument is still using core font, but because of this, "-font" usage is sort-of-deprecated and
now no longer searches core font by "XListFonts", but checks the exact pattern given by "-font" argument.

i.e. for example the following works:

$ PATH=/usr/libexec/xscreensaver:$PATH /usr/libexec/xscreensaver/fontglide -font '-*-*-*-o-*-*-*-400-*-*-*-*-koi8-*'

... but (as far as I am correct) actualy the above no longer uses "multiple" fonts.
and $ fontglide --font '*--0-*-koi8*' no longer works.


You may ask the upstream to restore xscreensaver 5 fontglide behavior for "-font" option, however
as explained above, now I guess -font option is a-sort-of-deprecated, for downstream bug
I close this as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.