Bug 1956073 - pipewire fails to start when bluetooth service is off
Summary: pipewire fails to start when bluetooth service is off
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 34
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 14:25 UTC by Dustin Kut Moy Cheung
Modified: 2021-05-03 16:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Dustin Kut Moy Cheung 2021-05-02 14:25:40 UTC
Description of problem:

I usually disable the bluetooth service on my laptop since I don't use bluetooth. I recently upgraded from Fedora 33 to 34 and noticed my audio wasn't working anymore.

```
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Sun 2021-05-02 10:15:19 EDT; 33s ago
TriggeredBy: ● pipewire.socket
   Main PID: 4157 (pipewire)
      Tasks: 3 (limit: 38218)
     Memory: 2.3M
        CPU: 99ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─4157 /usr/bin/pipewire

May 02 10:15:19 touni3 systemd[4142]: Started Multimedia Service.
May 02 10:15:22 touni3 pipewire-media-session[4174]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner
May 02 10:15:44 touni3 systemd-coredump[5369]: [🡕] Process 4174 (pipewire-media-) of user 1000 dumped core.
                                               
                                               Stack trace of thread 4174:
                                               #0  0x00007fd9cde9ca2b handle_timer_event (libspa-dbus.so + 0x1a2b)
                                               #1  0x00007fd9bffd0143 source_timer_func (libspa-support.so + 0x6143)
                                               #2  0x00007fd9bffd239b loop_iterate (libspa-support.so + 0x839b)
                                               #3  0x00007fd9cde1ed7b pw_main_loop_run (libpipewire-0.3.so.0 + 0x45d7b)
                                               #4  0x000055b34d587bf6 main (pipewire-media-session + 0xebf6)
                                               #5  0x00007fd9cd9f8b75 __libc_start_main (libc.so.6 + 0x27b75)
                                               #6  0x000055b34d58821e _start (pipewire-media-session + 0xf21e)
                                               
                                               Stack trace of thread 4176:
                                               #0  0x00007fd9cdad19ee epoll_wait (libc.so.6 + 0x1009ee)
                                               #1  0x00007fd9bffdb898 impl_pollfd_wait (libspa-support.so + 0x11898)
                                               #2  0x00007fd9bffd2304 loop_iterate (libspa-support.so + 0x8304)
                                               #3  0x00007fd9cde06e73 do_loop (libpipewire-0.3.so.0 + 0x2de73)
                                               #4  0x00007fd9cdba9299 start_thread (libpthread.so.0 + 0x9299)
                                               #5  0x00007fd9cdad16a3 __clone (libc.so.6 + 0x1006a3)

```

No sound output can be selected and playing any Youtube video on Firefox hangs.

Starting the bluetooth service again, and then restarting the pipewire and pipewire-pulse service at the user level resolve this.


Version-Release number of selected component (if applicable):
- Fedora 34 with all packages updated
- pipewire0.2-libs-0.2.7-5.fc34.x86_64
- pipewire-libs-0.3.26-4.fc34.x86_64
- pipewire-0.3.26-4.fc34.x86_64
- pipewire-alsa-0.3.26-4.fc34.x86_64
- pipewire-gstreamer-0.3.26-4.fc34.x86_64
- pipewire-jack-audio-connection-kit-0.3.26-4.fc34.x86_64
- pipewire-utils-0.3.26-4.fc34.x86_64
- pipewire-pulseaudio-0.3.26-4.fc34.x86_64

- Lenovo Thinkpad T490s


How reproducible: Always


Steps to Reproduce:
1. Disable bluetooth.service.
2. Restart pipewire.service
3. Watch audio output interface disappear

Actual results: Sound doesn't work anymore


Expected results: Sound works


Additional info:

pulseaudio worked for me with bluetooth service disabled. I'd like the same behaviour on pipewire.

As an aside, pipewire works beautifully with my bluetooth earbuds. Great job! :)

Comment 1 Lyosha Alexeev 2021-05-03 14:19:53 UTC
Can reproduce, but I think this has been fixed upstream: https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1114.

Comment 2 Matthias Runge 2021-05-03 16:05:21 UTC
This is a recent change, it worked for me with disconnected bluetooth in 0.3.25.


Note You need to log in before you can comment on or make changes to this bug.