Bug 1956076 - [abrt] totem: luaD_throw(): totem killed by SIGABRT
Summary: [abrt] totem: luaD_throw(): totem killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grilo-plugins
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ed07b1e042290797ceca65dd5e5...
: 1955951 1955991 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 14:49 UTC by François Perriot
Modified: 2021-05-06 01:01 UTC (History)
16 users (show)

Fixed In Version: grilo-plugins-0.3.13-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-06 01:01:02 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (90.38 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: core_backtrace (34.18 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: cpuinfo (2.56 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: dso_list (596 bytes, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: environ (1.17 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: limits (1.29 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: maps (3.93 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: mountinfo (3.06 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: open_fds (1.66 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: proc_pid_status (1.38 KB, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details
File: var_log_messages (126 bytes, text/plain)
2021-05-02 14:49 UTC, François Perriot
no flags Details

Description François Perriot 2021-05-02 14:49:11 UTC
Description of problem:
Opening Totem, it crashes

Version-Release number of selected component:
totem-1:3.38.0-5.fc34

Additional info:
reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Totem@0.service
cmdline:        /usr/bin/totem --gapplication-service
crash_function: luaD_throw
executable:     /usr/bin/totem
journald_cursor: s=993bf6b5f2be4f19a6197d5cf137ee26;i=59618;b=aa1af54d170240dab36db4dbcbdfdb5c;m=4f6a2f0b;t=5c15673a36e84;x=1e484160af1440c0
kernel:         5.11.17-300.fc34.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 François Perriot 2021-05-02 14:49:15 UTC
Created attachment 1778568 [details]
File: backtrace

Comment 2 François Perriot 2021-05-02 14:49:17 UTC
Created attachment 1778569 [details]
File: core_backtrace

Comment 3 François Perriot 2021-05-02 14:49:19 UTC
Created attachment 1778570 [details]
File: cpuinfo

Comment 4 François Perriot 2021-05-02 14:49:21 UTC
Created attachment 1778571 [details]
File: dso_list

Comment 5 François Perriot 2021-05-02 14:49:22 UTC
Created attachment 1778572 [details]
File: environ

Comment 6 François Perriot 2021-05-02 14:49:24 UTC
Created attachment 1778573 [details]
File: limits

Comment 7 François Perriot 2021-05-02 14:49:25 UTC
Created attachment 1778574 [details]
File: maps

Comment 8 François Perriot 2021-05-02 14:49:28 UTC
Created attachment 1778575 [details]
File: mountinfo

Comment 9 François Perriot 2021-05-02 14:49:29 UTC
Created attachment 1778576 [details]
File: open_fds

Comment 10 François Perriot 2021-05-02 14:49:32 UTC
Created attachment 1778577 [details]
File: proc_pid_status

Comment 11 François Perriot 2021-05-02 14:49:34 UTC
Created attachment 1778578 [details]
File: var_log_messages

Comment 12 Couret Charles-Antoine 2021-05-03 08:50:42 UTC
Similar problem has been detected:

Start totem only (from terminal or Nautilus)

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Totem@2.service
cmdline:        /usr/bin/totem --gapplication-service
crash_function: luaD_throw
executable:     /usr/bin/totem
journald_cursor: s=b7d839f8004c402c91c2b2a2341e737d;i=29e1;b=bb09b46d16e54b2b9e6bfe2c2e73aca6;m=776c8bb72;t=5c131f324e466;x=a4f6771c58e84980
kernel:         5.11.16-300.fc34.x86_64
package:        totem-1:3.38.0-5.fc34
reason:         totem killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 kartochka378 2021-05-03 15:02:21 UTC
Similar problem has been detected:

Totem just stop working, cannot see any video, only alternative video players work (vlc, mpv, firefox/chrome, any other than totem in right-click  open-with menu in nautilus)

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Totem@0.service
cmdline:        /usr/bin/totem --gapplication-service
crash_function: luaD_throw
executable:     /usr/bin/totem
journald_cursor: s=1117a15bb29b4e7c8d2c0b01a97ef1e9;i=739c9a;b=7bd3db3caad74030addc518c1feec8eb;m=4591deda7;t=5c11dab3e87fc;x=7f49c596803ade82
kernel:         5.11.17-300.fc34.x86_64
package:        totem-1:3.38.0-5.fc34
reason:         totem killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Adam Williamson 2021-05-03 23:04:44 UTC
I think we may be seeing this in Rawhide. Are affected folks using updates-testing? Do you have lua-5.4.3-1.fc34 installed?

Comment 15 Adam Williamson 2021-05-03 23:07:46 UTC
Yeah, it looks to me like the lua update caused it. If I downgrade lua to 5.4.2-2.fc34, totem runs fine. I've yanked the lua update from F34 for now. Spot, can you look into it? Thanks.

Comment 16 Bastien Nocera 2021-05-04 10:44:16 UTC
It's a bug in grilo-plugins:
https://gitlab.gnome.org/GNOME/grilo-plugins/-/merge_requests/108

Comment 17 Bastien Nocera 2021-05-04 10:48:02 UTC
*** Bug 1955951 has been marked as a duplicate of this bug. ***

Comment 18 Bastien Nocera 2021-05-04 10:48:07 UTC
*** Bug 1955991 has been marked as a duplicate of this bug. ***

Comment 19 Victor Toso 2021-05-04 10:49:51 UTC
I'll backport the fix mentioned in comment #16

Comment 20 Victor Toso 2021-05-04 10:54:29 UTC
(In reply to Victor Toso from comment #19)
> I'll backport the fix mentioned in comment #16

Build is on the making by Bastien
https://src.fedoraproject.org/rpms/grilo-plugins/c/bc37337cc406b7f69ff37688c53ba9611467aefc?branch=rawhide

Comment 21 Fedora Update System 2021-05-04 11:23:17 UTC
FEDORA-2021-277d4f7496 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-277d4f7496

Comment 22 Tom "spot" Callaway 2021-05-04 15:27:06 UTC
The same lua update that triggered this bug is in testing for f33, please build this fix for F33 too.

Comment 23 Adam Williamson 2021-05-04 15:28:51 UTC
Thanks, but in future please don't submit a separate update :/ It would have been much more convenient to just add the grilo-plugins build to the lua update. That way they would be "internally consistent" and could be pushed together.

Now, to avoid breaking totem in stable, we have to manually remember we cannot push the lua update until the grilo-plugins update is pushed.

Permissions can be an issue, but there are plenty of provenpackagers who can help to edit updates if necessary (e.g. me).

I'll see if we can fix this up somehow. At worst I can just do a bump-n-rebuild of grilo-plugins.

Comment 24 Fedora Update System 2021-05-04 16:36:55 UTC
FEDORA-2021-52f259786a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-52f259786a

Comment 25 Fedora Update System 2021-05-04 16:37:01 UTC
FEDORA-2021-52f259786a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-52f259786a

Comment 26 Adam Williamson 2021-05-04 16:37:52 UTC
I built the fix for F33 and edited it into the F33 update. For F34 I did a no-change bump-n-rebuild of grilo-plugins and edited it into the lua update; the other grilo-plugins update is now obsoleted.

Comment 27 Fedora Update System 2021-05-05 01:49:47 UTC
FEDORA-2021-52f259786a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-52f259786a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-52f259786a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 28 Bastien Nocera 2021-05-05 09:13:21 UTC
(In reply to Adam Williamson from comment #23)
> Thanks, but in future please don't submit a separate update :/ It would have
> been much more convenient to just add the grilo-plugins build to the lua
> update. That way they would be "internally consistent" and could be pushed
> together.
> 
> Now, to avoid breaking totem in stable, we have to manually remember we
> cannot push the lua update until the grilo-plugins update is pushed.
> 
> Permissions can be an issue, but there are plenty of provenpackagers who can
> help to edit updates if necessary (e.g. me).
> 
> I'll see if we can fix this up somehow. At worst I can just do a
> bump-n-rebuild of grilo-plugins.

It's a bug in grilo-plugins, which I fixed. It just so happens that the new lua
version shows the bug more prominently, but it's a bug whether or not lua gets
updated.

Is there a bug filed about the need to dance around the update tool to group
builds like you did, doing new builds when they're clearly unneeded?

Comment 29 Adam Williamson 2021-05-05 18:33:18 UTC
"It's a bug in grilo-plugins, which I fixed. It just so happens that the new lua version shows the bug more prominently, but it's a bug whether or not lua gets updated."

Sure, but the worst scenario is the lua update getting pushed stable before the grilo-plugins update, which would cause Totem to crash on startup for everyone who installed the update. As long as they're separate updates that is possible (and likely, since the lua update was submitted first and probably people don't know that grilo-plugins is an important package, or what it does, and so they're unlikely to karma it). If they're bundled together it is impossible.

"Is there a bug filed about the need to dance around the update tool to group builds like you did, doing new builds when they're clearly unneeded?"

It's been a known limitation approximately forever, I don't remember offhand if a bug is filed but lots of people definitely know about it. It's somewhat hard to fix, I think, because the problem is we don't really want to allow updates to be deleted entirely, which is the easiest way to "fix" this. If an update was created we want it to remain in existence at some level.

What would probably be needed is a new permanent state for updates called 'archived' or something, where their existence is recorded but they are not pushed to any repository and cannot be pushed to any repository (and the status cannot be changed short of someone going and editing the database). And then Bodhi would need to allow builds from updates in that state to be added to other updates.

Comment 30 Fedora Update System 2021-05-06 01:01:02 UTC
FEDORA-2021-52f259786a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.