Bug 1956148 - gnome-shell-extension-system-monitor-applet preferences bug: Error: No property border_width on GtkFrame
Summary: gnome-shell-extension-system-monitor-applet preferences bug: Error: No prope...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-system-monitor-applet
Version: 34
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: nicolas.vieville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 03:00 UTC by william.garber
Modified: 2021-05-17 03:10 UTC (History)
3 users (show)

Fixed In Version: gnome-shell-extension-system-monitor-applet-38-12.20210507gitbc38ccf.fc34 gnome-shell-extension-system-monitor-applet-38-12.20210507gitbc38ccf.fc32 gnome-shell-extension-system-monitor-applet-38-12.20210507gitbc38ccf.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-12 05:43:47 UTC
Type: Bug


Attachments (Terms of Use)
fix preferences william.garber@att.net (17.01 KB, text/plain)
2021-05-09 23:49 UTC, william.garber
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github paradoxxxzero gnome-shell-system-monitor-applet issues 672 0 None open Add support for GNOME 40 and an updated version to https://extensions.gnome.org/extension/120/system-monitor/ 2021-05-03 07:09:59 UTC
Github paradoxxxzero gnome-shell-system-monitor-applet pull 678 0 None open update prefs to support gnome 40 2021-05-03 07:09:59 UTC

Internal Links: 1957479

Description william.garber 2021-05-03 03:00:21 UTC
Description of problem:

can not set preferences for gnome-shell-extension-system-monitor-applet

Version-Release number of selected component (if applicable):

gnome-shell-extension-system-monitor-applet-38-11.20210320git0b42126.fc34.noarch

How reproducible:
always

Steps to Reproduce:
1. click on "preferences"

Actual results:

Error: No property border_width on GtkFrame

Stack trace:
  _init/Gtk.Widget.prototype._init@resource:///org/gnome/gjs/modules/core/overrides/Gtk.js:45:40
  SystemMonitor@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:141:22
  SystemMonitor_App/<@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:295:38
  SystemMonitor_App@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:294:23
  buildPrefsWidget@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:367:18
  _init@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:209:40
  OpenExtensionPrefsAsync/<@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:122:28
  asyncCallback@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:115:22
  run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:177:20
  main@resource:///org/gnome/Shell/Extensions/js/main.js:19:13
  run@resource:///org/gnome/gjs/modules/script/package.js:206:19
  start@resource:///org/gnome/gjs/modules/script/package.js:190:8
  @/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17
  
Expected results:

set preferences dialog box


Additional info:

Comment 1 nicolas.vieville 2021-05-03 07:10:02 UTC
Hello,

Thanks for reporting this issue.

This bug has been reported upstream, and is in the process to be addressed. 
Affected bug reports have been added to this one.

As a partial workaround, and in order to allow this gnome-shell extension 
to be displayed in gnome-shell 40.0, one can edit (make a copy before editing) 
the /usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/metadata.json 
file and replace the line:

"shell-version": ["3.26", "3.28", "3.30", "3.32", "3.34", "3.36"],

by the line:

"shell-version": ["3.26", "3.28", "3.30", "3.32", "3.34", "3.36", "40.0"],

Adding "40.0" to this line doesn't fix the crash when clicking on the 
Preferences button but allow the extension to be displayed and work.

I will release the package as soon as the patch is verified and 
available upstream.

Feel free to make any comment about these subjects.

Cordially,


-- 
NVieville

Comment 2 william.garber 2021-05-03 21:19:36 UTC
wonderful extension much loved;
above original posting error message is obtained after adding "40.0" to versions
as described and then attempting to set preferences;

Comment 3 Fedora Update System 2021-05-08 13:48:53 UTC
FEDORA-2021-365a85beed has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-365a85beed

Comment 4 Fedora Update System 2021-05-08 13:58:34 UTC
FEDORA-2021-f49fd9bb19 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f49fd9bb19

Comment 5 Fedora Update System 2021-05-08 14:04:26 UTC
FEDORA-2021-a170cf0d9f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a170cf0d9f

Comment 6 Fedora Update System 2021-05-08 14:16:31 UTC
FEDORA-EPEL-2021-069a2a7a2e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-069a2a7a2e

Comment 7 Fedora Update System 2021-05-08 14:23:06 UTC
FEDORA-EPEL-2021-1b798a3a31 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-1b798a3a31

Comment 8 Fedora Update System 2021-05-09 02:08:06 UTC
FEDORA-2021-f49fd9bb19 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f49fd9bb19`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f49fd9bb19

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-05-09 02:20:14 UTC
FEDORA-2021-365a85beed has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-365a85beed`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-365a85beed

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-05-09 02:30:20 UTC
FEDORA-EPEL-2021-069a2a7a2e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-069a2a7a2e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-05-09 02:36:06 UTC
FEDORA-EPEL-2021-1b798a3a31 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-1b798a3a31

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-05-09 02:36:48 UTC
FEDORA-2021-a170cf0d9f has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a170cf0d9f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a170cf0d9f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 william.garber 2021-05-09 03:57:19 UTC
disabled all extensions.
uninstalled panel applet
reinstalled panel applet
enabled extensions.
original bug still present.

Comment 14 nicolas.vieville 2021-05-09 06:37:16 UTC
(In reply to william.garber from comment #13)

Hello,

Thanks for the feedback. Really appreciated.

To be sure : did you reinstall the gnome-shell-extension-system-monitor-applet 
from the testing repository as suggested in comment #9 ?

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-365a85beed

The error "No property border_width on GtkFrame" should be addressed upstream, 
but maybe there still some call to this method. Could you please provide the error 
message actually hitting you (line numbers in the message could give us some great
indications) ?

I wonder if you could please provide more information about your setup.
Is you desktop a gnome session ?
Does it use Wayland ? 
Is there any special graphic device driver loaded (NVidia for example) ?

Feel free to comment about these subjects and to provide any information you think
useful.

Cordially,


-- 
NVieville

Comment 15 Markus Teuber 2021-05-09 10:17:06 UTC
Where could i find this error messages, so that i can check if they come to me too?
I installed the package and i see nothing special. It seems to work ok. I am using the nvidia-driver from rpmfusion (and then Xorg).
I used the extension on Fedora 33 and this package works exact as it does with Gnome 3.38 from Fedora 33.

Comment 16 william.garber 2021-05-09 23:43:46 UTC
gnome 4
fedora 34
gnome classic desktop environment
wayland
(perhaps gnome classic is not supposed to be used on wayland !!!!!)

the main body of the app works but the preferences do not.

to get error message:
right click on applet
select preferences at bottom.

as in original error posting you get a dialog box with this error:

Stack trace:
  _init/Gtk.Widget.prototype._init@resource:///org/gnome/gjs/modules/core/overrides/Gtk.js:45:40
  SystemMonitor@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:141:22
  SystemMonitor_App/<@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:295:38
  SystemMonitor_App@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:294:23
  buildPrefsWidget@/usr/share/gnome-shell/extensions/system-monitor@paradoxxx.zero.gmail.com/prefs.js:367:18
  _init@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:209:40
  OpenExtensionPrefsAsync/<@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:122:28
  asyncCallback@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:115:22
  run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:177:20
  main@resource:///org/gnome/Shell/Extensions/js/main.js:19:13
  run@resource:///org/gnome/gjs/modules/script/package.js:206:19
  start@resource:///org/gnome/gjs/modules/script/package.js:190:8
  @/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17
  

I fixed it by rewriting the code for 
prefs.js

attached.

it works somewhat now.

Comment 17 william.garber 2021-05-09 23:49:48 UTC
Created attachment 1781459 [details]
fix preferences william.garber@att.net

fix for preferences for gnome 40.

rest of applet was working already.

Comment 18 william.garber 2021-05-10 00:16:45 UTC
sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-365a85beed gnome-shell-extension-system-monitor-applet

this time I applied your command correctly (first time I forgot the trailing  "gnome-shell-extension-system-monitor-applet"
which did not make sense)

my program is slightly different from yours but I expect yours is better 
so in any case you might be interested in my fixes.

regards.

Comment 19 william.garber 2021-05-10 00:21:06 UTC
i meant to say both your fix and my fix seem to be working now.
i am sure you are much more familiar with it though :-)

Comment 20 nicolas.vieville 2021-05-10 06:36:27 UTC
Hello,

Thanks for providing the information about your setup. As you noticed it, 
nothing special about it. It should work correctly. I've asked because 
sometimes setups are quite special kind of combinations that are difficult 
to fix.

Thank you very much for your rewriting of the prefs.js file.
As I'm not the developer of the upstream project, I only open issues or, 
if possible, submit patches or fixes to the github project. My role here
is limited to packaging the software for Fedora.

The fixes proposed in the new Fedora package, but not the 2 ones from pull
request 678 (link below the description of the bug), are already integrated 
upstream.

Glad to see you get this gnome-shell extension to work, even with the new 
Fedora package.

Feel free to make any comment about these subject.

Regards,


-- 
NVieville

Comment 21 Fedora Update System 2021-05-12 05:43:47 UTC
FEDORA-2021-365a85beed has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2021-05-17 02:45:11 UTC
FEDORA-2021-a170cf0d9f has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2021-05-17 03:10:00 UTC
FEDORA-2021-f49fd9bb19 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.