Bug 1956191 - GUI completely broken
Summary: GUI completely broken
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkwave
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 07:40 UTC by Thomas Sailer
Modified: 2021-05-13 19:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
main window (33.92 KB, image/png)
2021-05-03 07:44 UTC, Thomas Sailer
no flags Details

Description Thomas Sailer 2021-05-03 07:40:34 UTC
Description of problem:
The gtkwave gui is completely broken, only the "SST" box is shown, but neither the signal list, nor the waveforms, nor the menu is shown

Version-Release number of selected component (if applicable):
3.3.108-2

How reproducible:
always

Steps to Reproduce:
1. gtkwave xx.vcd
2. add any signal from the SST box to the viewer

Actual results:
mostly grey window

Expected results:
selected waveforms visible

Additional info:
3.3.109 is broken too, I downgraded to the f33 version, 3.3.107, which works on f34 too

Comment 1 Thomas Sailer 2021-05-03 07:44:31 UTC
Created attachment 1778845 [details]
main window

It's not a wayland vs. x11 backend thing, the window looks the same. Also notice that the titlebar isn't even rendered

Comment 2 Palle Ravn 2021-05-13 19:17:47 UTC
I can verify the same behavior. As stated on https://github.com/gtkwave/gtkwave/issues/62 it works when building locally with --enable-gtk3, I have not tested any other options.


Note You need to log in before you can comment on or make changes to this bug.