Bug 1956191 - GUI completely broken
Summary: GUI completely broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkwave
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1963323 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 07:40 UTC by Thomas Sailer
Modified: 2021-05-29 01:04 UTC (History)
3 users (show)

Fixed In Version: gtkwave-3.3.108-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-29 01:04:40 UTC
Type: Bug


Attachments (Terms of Use)
main window (33.92 KB, image/png)
2021-05-03 07:44 UTC, Thomas Sailer
no flags Details

Description Thomas Sailer 2021-05-03 07:40:34 UTC
Description of problem:
The gtkwave gui is completely broken, only the "SST" box is shown, but neither the signal list, nor the waveforms, nor the menu is shown

Version-Release number of selected component (if applicable):
3.3.108-2

How reproducible:
always

Steps to Reproduce:
1. gtkwave xx.vcd
2. add any signal from the SST box to the viewer

Actual results:
mostly grey window

Expected results:
selected waveforms visible

Additional info:
3.3.109 is broken too, I downgraded to the f33 version, 3.3.107, which works on f34 too

Comment 1 Thomas Sailer 2021-05-03 07:44:31 UTC
Created attachment 1778845 [details]
main window

It's not a wayland vs. x11 backend thing, the window looks the same. Also notice that the titlebar isn't even rendered

Comment 2 Palle Ravn 2021-05-13 19:17:47 UTC
I can verify the same behavior. As stated on https://github.com/gtkwave/gtkwave/issues/62 it works when building locally with --enable-gtk3, I have not tested any other options.

Comment 3 Paul Howarth 2021-05-19 13:08:52 UTC
Could anyone try this scratch build for Fedora 34? If everyone's happy with it I'll do a proper update.
https://koji.fedoraproject.org/koji/taskinfo?taskID=68261762

Comment 4 Thomas Sailer 2021-05-19 18:10:21 UTC
Works for me, thanks!

Comment 5 Fedora Update System 2021-05-20 08:23:52 UTC
FEDORA-2021-2b4f053d12 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-2b4f053d12

Comment 6 Fedora Update System 2021-05-21 03:40:57 UTC
FEDORA-2021-2b4f053d12 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-2b4f053d12`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2b4f053d12

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Paul Howarth 2021-05-22 12:22:17 UTC
*** Bug 1963323 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2021-05-29 01:04:40 UTC
FEDORA-2021-2b4f053d12 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.