Bug 195621 - Patch turns off *all* debugging info with no way to turn it back on
Patch turns off *all* debugging info with no way to turn it back on
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 18:15 EDT by Joe Shaw
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.6-1.fc5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 05:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Shaw 2006-06-15 18:15:32 EDT
There is a patch in the FC5 RPM, named "beagle-0.2.1-spew.patch" which hardcodes
the debug level of Beagle:

--- beagle-0.2.1/beagled/BeagleDaemon.cs.spew   2006-02-24 01:26:56.000000000 -0500
+++ beagle-0.2.1/beagled/BeagleDaemon.cs        2006-02-24 01:28:44.000000000 -0500
@@ -377,7 +377,7 @@
                                        // FIXME: We always turn on full
debugging output!  We are still
                                        // debugging this code, after all...
                                        //arg_debug ? LogLevel.Debug :
LogLevel.Warn,
-                                       LogLevel.Debug,
+                                       LogLevel.Error,
                                        arg_fg);

I can understand dialing the otherwise very verbose output down, but why not
uncomment the line immediately above this one?  As a result, it is basically
impossible to debug any runtime issues users encounter because the log level
cannot be changed in the direction of verbosity. (See
http://bugzilla.gnome.org/show_bug.cgi?id=335819 for an irritating
back-and-forth.)  Please fix this for the next release.
Comment 1 Joe Shaw 2006-06-15 18:18:03 EDT
Seems to have been applied to fix bug 182660, which (ironically) just suppressed
real error messages/bugs.
Comment 2 Ray Strode [halfline] 2006-06-15 19:24:51 EDT
So i had a look at fixing this tonight, but our build system is having a hissy fit
Comment 3 Alexander Larsson 2006-06-21 05:52:16 EDT
This is now released as 0.2.6-1.fc5.2

Note You need to log in before you can comment on or make changes to this bug.