Bug 1956238 - Shared disk will be completely lost on Detaching Storage Domain
Summary: Shared disk will be completely lost on Detaching Storage Domain
Keywords:
Status: CLOSED DUPLICATE of bug 1922977
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.4.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 09:32 UTC by Steffen Froemer
Modified: 2021-05-17 06:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-04 05:33:35 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing VM disks and shared disk in Storage domain before detaching SD (74.78 KB, image/png)
2021-05-03 09:32 UTC, Steffen Froemer
no flags Details
VM import dialog showing missing shared disk after attaching the SD to DC (60.75 KB, image/png)
2021-05-03 09:37 UTC, Steffen Froemer
no flags Details

Description Steffen Froemer 2021-05-03 09:32:56 UTC
Created attachment 1778875 [details]
Screenshot showing VM disks and shared disk in Storage domain before detaching SD

Description of problem:
When VMs in a DATA Storage Domain does consume a shared disk, this disk will be lost, as soon the Storage Domain got detached from the DataCenter

Version-Release number of selected component (if applicable):
ovirt-engine-4.4.4.7-0.2.el8ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. create two VMs
2. create a shared disk and attach to both VMs
3. (optional) Move all Disks to another SD, which can be detached (following doc [1]) 
4. Put SD into Maintenance and Detach it from DataCenter
5. Attach SD to the DC again
6. Import VMs

Actual results:
shared disk is missing

Expected results:
Shared disk should stay and included during import of VM

Additional info:



[1]: https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3/html/virtual_machine_management_guide/sect-exporting_and_importing_virtual_machines_and_templates#proc_Exporting_individual_virtual_machines_to_a_data_domain_vm_guide_administrative_tasks

Comment 2 Steffen Froemer 2021-05-03 09:37:40 UTC
Created attachment 1778887 [details]
VM import dialog showing missing shared disk after attaching the SD to DC

Comment 4 Eyal Shenitzky 2021-05-04 05:33:35 UTC
Hi Steffen,

This is a duplication of bug 1922977, please update the case.

*** This bug has been marked as a duplicate of bug 1922977 ***


Note You need to log in before you can comment on or make changes to this bug.