Bug 1956242 - Winecfg fails with "Failed to open RpcSs service"
Summary: Winecfg fails with "Failed to open RpcSs service"
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 09:48 UTC by Ruediger Landmann
Modified: 2021-05-12 23:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-12 23:04:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Ruediger Landmann 2021-05-03 09:48:15 UTC
Description of problem:
After installing wine on Fedora 34, winecfg fails to start.

Version-Release number of selected component (if applicable):
wine-6.7 (Staging)

How reproducible:
100%

Steps to Reproduce:
1. run winecfg


Actual results:

$ winecfg
002c:fixme:winediag:LdrInitializeThunk wine-staging  is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:err:ole:start_rpcss Failed to open RpcSs service
wine: could not load kernel32.dll, status c0000135
$ 0040:err:ole:start_rpcss Failed to open RpcSs service

Expected results:
Winecfg should run

Comment 1 Michael Cronenworth 2021-05-03 16:39:36 UTC
I cannot reproduce this.

Do you also see this with a fresh wine prefix?

WINEPREFIX=~/fresh winecfg

Comment 2 Ruediger Landmann 2021-05-03 23:47:59 UTC
Yes, I get similar with a fresh prefix: 

$ WINEPREFIX=~/.newprefix winecfg
wine: created the configuration directory '/home/rlandmann/.newprefix'
002c:fixme:winediag:LdrInitializeThunk wine-staging  is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0048:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0048:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0050:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0050:err:ole:start_rpcss Failed to open RpcSs service
0040:fixme:winspool:AddPrinterW DocumentPropertiesW on printer L"FUJI_XEROX_FUJI_XEROX_DocuPrint_P255_dw" fails
0040:fixme:file:NtLockFile I/O completion on lock not implemented yet
0040:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0024:err:environ:run_wineboot boot event wait timed out
wine: could not load kernel32.dll, status c0000135
[rlandmann@localhost ~]$

The only difference is that the Wine window with the message "The Wine configuration in /home/rlandmann/.newprefix is being updated , please wait" is displayed (and doesn't go away even after the above error. 

And even after the above error, "pgrep wine" shows two processes running.

Comment 3 Ruediger Landmann 2021-05-05 08:07:43 UTC
Looks like this same problem hit a bunch of Arch Linux users a few months ago: 

https://www.reddit.com/r/archlinux/comments/k0b5kr/wine_no_longer_working/

https://bbs.archlinux.org/viewtopic.php?pid=1939568#p1939568

https://forum.winehq.org/viewtopic.php?t=34852&p=131323

Like the reporter in the second link, my system also has inbuilt Intel graphics on the mainboard, plus an nVidia graphics card.

Comment 4 Ruediger Landmann 2021-05-05 08:12:26 UTC
And here on openSUSE with nvidia drivers... 

https://forums.developer.nvidia.com/t/opensuse-tumbleweed-and-460-32-03-causes-issues-to-start-wine/165951

Comment 5 Ruediger Landmann 2021-05-05 10:19:11 UTC
So I tried what the openSUSE user reported in the nvidia forum above, and removed the proprietary nvidia driver and its kernel module

$ lspci -k | grep -A 2 VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 85e7
        Kernel modules: nouveau

But it didn't help:

$ WINEPREFIX=~/.newprefix4 winecfg         
wine: created the configuration directory '/home/rlandmann/.newprefix4'
002c:fixme:winediag:LdrInitializeThunk wine-staging  is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
004c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
004c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
004c:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
004c:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
004c:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0050:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0050:err:ole:start_rpcss Failed to open RpcSs service
0040:fixme:winspool:AddPrinterW DocumentPropertiesW on printer L"FUJI_XEROX_FUJI_XEROX_DocuPrint_P255_dw" fails
0040:fixme:winspool:AddPrinterW DocumentPropertiesW on printer L"FX_DocuPrint_P265_dw" fails
0040:fixme:file:NtLockFile I/O completion on lock not implemented yet
0040:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0024:err:environ:run_wineboot boot event wait timed out
wine: could not load kernel32.dll, status c0000135

Comment 6 Ruediger Landmann 2021-05-10 00:05:53 UTC
So over the weekend I did a fresh install of F34, with the same result (my system previously had been upgraded from F32). 

Also tried with the nouveau driver as well as with the proprietary nvidia driver

And finally have upgraded to the latest (test) kernel (5.11.19-300) in case forcing the kernel modules for the drivers to regenerate helped.

Comment 7 Timothy Redaelli 2021-05-11 15:25:00 UTC
I have the same (or a problem with the same behavior) and I bisected this to this commit:

commit 10dde32dc6c530d755f68a6edfb50d21c6edd2a8 (HEAD, refs/bisect/bad)
Author: Zebediah Figura <z.figura12@gmail.com>
Date:   Thu Feb 11 16:18:57 2021 -0600

    winegstreamer: Move GStreamer library initialization to __wine_init_unix_lib().
    
    Signed-off-by: Zebediah Figura <z.figura12@gmail.com>
    Signed-off-by: Alexandre Julliard <julliard@winehq.org>

since it's something about gstreamer I first tried to build wine without gstreamer (--without-gstreamer) and it worked then I tried to disable winegstreamer at runtime and it worked to:

rm -rf ~/.wine ; WINEDLLOVERRIDES="winegstreamer=" winecfg

Can you confirm it's the same problem?

Comment 8 Ruediger Landmann 2021-05-12 23:04:44 UTC
Update: so after my last reboot, WINE is now suddenly working correctly. 

I later rectified a "critical" error in the output below ("wine:8609") by creating a symlink to /usr/lib64/libpython3.9.so.1.0 but this hadn't stopped WINE from launching anyway. 

For anyone else hitting this:

My system has onboard Intel graphics (i915) plus an nvidia graphics card (GeForce GT 710) 
The things that changed between WINE not working and WINE working included:
* Fresh install of F34 (previous had been an upgrade from an F32 system where WINE had been working)
* Replace the nouveau driver with the proprietary nvidia driver (xorg-x11-drv-nvidia.x86_64 3:465.27-1.fc34)
* Upgrade the kernel (didn't work with 5.11.18-300, works with 5.11.19-300, but I can see both kmod-nvidia-5.11.18-300.fc34.x86_64.x86_64 and kmod-nvidia-5.11.19-300.fc34.x86_64.x86_64 currently installed, so the system had created and successfully installed the kmod for the previous kernel...) 
* Multiple reboots 
* Updates of multiple packages in my daily "dnf upgrade"; but I didn't see anything in there that was obviously (to me) WINE or graphics-related

I don't know what combination of these things finally fixed the issue.

 

----

WINEPREFIX=~/.newprefix10 winecfg
wine: created the configuration directory '/home/rlandmann/.newprefix10'
002c:fixme:winediag:LdrInitializeThunk wine-staging  is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
002c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0048:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0048:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0050:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:start_rpcss Failed to open RpcSs service
0040:fixme:winspool:AddPrinterW DocumentPropertiesW on printer L"FX_DocuPrint_P265_dw" fails
0040:fixme:file:NtLockFile I/O completion on lock not implemented yet
0040:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0040:err:mscoree:LoadLibraryShim error reading registry key for installroot
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0064:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
006c:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0040:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)

** (wine:8609): CRITICAL **: 10:12:18.253: Couldn't g_module_open libpython. Reason: /usr/lib64/libpython3.9.so: cannot open shared object file: No such file or directory
failed to open /usr/lib64/dri/hybrid_drv_video.so
0074:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0074:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0094:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
0098:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0098:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00a0:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00a0:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00a8:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00a8:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00cc:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
00c8:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00c8:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
wine: configuration in L"/home/rlandmann/.newprefix10" has been updated.
00ec:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00ec:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0024:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
0024:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00f4:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00f4:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00fc:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.
00fc:fixme:font:get_name_record_codepage encoding 20 not handled, platform 1.

Comment 9 Ruediger Landmann 2021-05-12 23:07:02 UTC
(In reply to Timothy Redaelli from comment #7)

> since it's something about gstreamer I first tried to build wine without
> gstreamer (--without-gstreamer) and it worked then I tried to disable
> winegstreamer at runtime and it worked to:
> 
> rm -rf ~/.wine ; WINEDLLOVERRIDES="winegstreamer=" winecfg
> 
> Can you confirm it's the same problem?

Sorry Timothy! My WINE suddenly started working so I can't compare this. But if it breaks again, I will come back and try your approach.


Note You need to log in before you can comment on or make changes to this bug.