Bug 1956264 - [MTV][Warm][API <> UI] Precopies are not reflected in UI when the cutover is set on the Migration CR
Summary: [MTV][Warm][API <> UI] Precopies are not reflected in UI when the cutover is ...
Keywords:
Status: VERIFIED
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: General
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.0.0
Assignee: Fabien Dupont
QA Contact: Maayan Hadasi
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 10:36 UTC by Maayan Hadasi
Modified: 2021-05-12 14:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)
cutover_set_on_Plan_CR (40.74 KB, image/png)
2021-05-03 13:01 UTC, Maayan Hadasi
no flags Details
cutover_set_on_Migration_CR (42.22 KB, image/png)
2021-05-03 13:01 UTC, Maayan Hadasi
no flags Details

Description Maayan Hadasi 2021-05-03 10:36:45 UTC
Description of problem:
When the cutover value is set on the Migration CR, the precopies are not shown in UI

In the UI the warm migration plan starts immediately with "Transfer disk" step


Version-Release number of selected component (if applicable):
MTV 2.0.0-21


How reproducible:
100%


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fabien Dupont 2021-05-03 12:17:45 UTC
I'm not sure I understand what the problem is. What would you expect that doesn't happen?

Comment 2 Maayan Hadasi 2021-05-03 13:00:31 UTC
Hi @fdupont@redhat.com,

I expect that a prcopy will be executed every X minutes
I changed the interval time between precopies to be 8 minutes. Now, if the cutover value is set on Plan CR (future value), I see by watching the DataVolume that every 8 minuets it gets into "ImportInProgress", meaning that a disk copy is taken. Between the copies the DataVolume phase is "paused". At the cutover time the DataVolume phase is again "ImportInProgress" and after it "succeeded".
If the cutover value is set on Migration CR (future value), first the DataVolume phase is "ImportInProgress", after one copy it gets into "paused" and stay paused till the cutover time. At the cutover time it becomes "ImportInProgress" and "succeeded". Without more precopies

I will add screenshots of UI for both cases, both display migration plan in state "paused" and before cutover time

HIH

Comment 3 Maayan Hadasi 2021-05-03 13:01:05 UTC
Created attachment 1778954 [details]
cutover_set_on_Plan_CR

Comment 4 Maayan Hadasi 2021-05-03 13:01:50 UTC
Created attachment 1778955 [details]
cutover_set_on_Migration_CR

Comment 5 Maayan Hadasi 2021-05-04 13:06:45 UTC
The issue was tested again with mtv-operator 2.0.0-4 https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1594105
the precopies actually are taken every X minutes, but they are not reflected in UI

Comment 6 Fabien Dupont 2021-05-06 10:18:08 UTC
@mturley@redhat.com, what is the UI looking at to reflect the precopy iterations? The Migration or the Plan CR?

@slucidi@redhat.com, where is the precopy iterations status written? The Migration or the Plan CR?

I would expect it to be on the Migration CR, since it represents the execution of a plan, but I may miss something.

Comment 7 Fabien Dupont 2021-05-06 12:14:57 UTC
Can you please try to reproduce with build 2.0.0-8 / iib:72981. It might be fixed.

Comment 8 Maayan Hadasi 2021-05-06 12:58:15 UTC
Verified as fixed. Thanks
mtv-operator-bundle-container-2.0.0-8 iib:72981

Comment 9 Mike Turley 2021-05-06 15:04:26 UTC
I know it's verified, but for posterity I'll answer the above questions anyway:

> what is the UI looking at to reflect the precopy iterations? The Migration or the Plan CR?

The UI looks at the plan CR which has a whole `warm` object conveniently summarized in the status for me. I'm not looking at the Migration or the DataVolume.

> where is the precopy iterations status written? The Migration or the Plan CR? I would expect it to be on the Migration CR, since it represents the execution of a plan, but I may miss something.

All the status data for the migration is actually written to both the Migration CR and also denormalized in the status section of the Plan CR for convenience. Most of the UI just reads from the plan CR and treats the Migration CR as write-only (with the current exception of canceled VM ids).


Note You need to log in before you can comment on or make changes to this bug.