Bug 1956327 - gnome-software gets stuck or fails trying to initiate Fedora upgrade
Summary: gnome-software gets stuck or fails trying to initiate Fedora upgrade
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 13:38 UTC by Basic Six
Modified: 2021-05-07 13:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 16:06:05 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (266.98 KB, image/png)
2021-05-03 13:38 UTC, Basic Six
no flags Details
screenshot (84.29 KB, image/png)
2021-05-03 13:38 UTC, Basic Six
no flags Details

Description Basic Six 2021-05-03 13:38:08 UTC
Description of problem:

Unfortunately, gnome-software isn't always able to initiate a system upgrade to the next release (see those bugs: Bug 1370596, Bug 1442812, Bug 1535744).

It's now failing in different ways:
1) It get's stuck after clicking Download, no progress even after a day and no feedback what's happening or which process timed out and what to do about it.

2) "could not do untrusted question as no klass support"
As a user, I don't know what "do untrusted question" is supposed to tell me and even if I knew what "klass support" is, I wouldn't know what to do about it without any reference to the official documentation which should have a page describing this error and steps to fix it.

3) "Failed to download gpg key for repo 'updates-modular': Curl error (37)"
I don't even know how something like this could happen. Is this a known bug?



Version-Release number of selected component (if applicable):

F31++



How reproducible:

I don't know. Different symptoms now - but this gui tool has failed many times in the past, see referenced bugs above.



Steps to Reproduce:
1.
2.
3.



Actual results:

See attached screenshot.



Expected results:

The system update/upgrade tool is an essential core part of the Fedora system. At least from the perspective of a user who relies on the system. An essential core part shouldn't fail without a good reason and if it does fail, it should link the user to the official documentation. What is an end user supposed to do in this situation?



Additional info:

See attached screenshot(s). Also, referenced bugs: Bug 1370596, Bug 1442812, Bug 1535744

Comment 1 Basic Six 2021-05-03 13:38:36 UTC
Created attachment 1778990 [details]
screenshot

Comment 2 Basic Six 2021-05-03 13:38:53 UTC
Created attachment 1778991 [details]
screenshot

Comment 3 Milan Crha 2021-05-03 16:06:05 UTC
Thanks for a bug report.

ad 1) it's waiting for PackageKit, I guess. I've been forced to click "Download" twice to get past it, in Fedora 33. I do not think this is [1], because I see the download progress.

ad 2) I agree, it is a very cryptic message. It is filled upstream as [2].

ad 3) I do not know. The curl command means it could not talk to the server. 

As this is not Fedora specific, it'll be better to handle this upstream.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/13
[2] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/603

Comment 4 Basic Six 2021-05-04 12:00:44 UTC
Thanks for the comment and the links. I agree that the bug(s) should be solved upstream, maybe we should mention this bug report there, or at least the fact that this currently affects Fedora users if we close this report before the problem is fixed (the second issue is 2 years old, does not look like it's a priority).

But I believe that Fedora should at least have some sort of documentation even if none of the bugs is fixed by the Fedora devs. This is why I've reopened the issue, feel free to close it if you think I'm wrong. The least they could do is add some minimal documentation with a reference to those open (upstream) bugs so that the user has at least a chance of finding out what's happening - because...

Regular users install updates and run dist upgrades if they get a graphical notification, using the graphical update tool which is gnome-software in this case. It fails for various reasons and leaves the user alone with a cryptic error message (or sometimes nothing as in the first case, no clicking twice didn't help). If this was some optional, third-party tool then ok, I wouldn't mind if it's a bit buggy. But we're talking about the official update tool of the Fedora operating system, which has to work otherwise the user can't keep the system up to date as required. I understand that it might not be feasible to show a link to the bug report whenever something goes wrong - how about a link to the official documentation if something goes wrong, anything at all? I'd rather have a generic pointer to the official docs rather than a dead window when I'm using a *core* component of the operating system because a core component shouldn't just fail randomly, leaving the user alone like this.

Comment 5 Milan Crha 2021-05-04 15:21:52 UTC
The curl error looks like a problem with a local file, most likely not being installed. Curl can report more issues. I do not think the error comes from the gnome-software, it's most likely from the PackageKit daemon.

The "klass no support" needs fixing upstream. You are right it doesn't look like a priority bug.

The thing is the errors can mean different things. Catching all of the possible errors and report detailed description for each is close to impossible. It's due to all the plugins being involved. I'm not sure where the link to some FAQ might be, I doubt the message box supports any links, but I can be wrong. This might need a designed voice, but, more importantly, carry a custom patch in Fedora changing some such fundamental thing and keep it working is unbearable. The maintenance burden would be too high. The best is to fix this upstream (and avoid bug duplication), which is the reason why I closed this as upstream.

Comment 6 Basic Six 2021-05-06 11:07:02 UTC
I do understand that it's close to impossible to catch or recognize *all* errors and have an faq link for each of them (or an error code which could be found in the documentation like in some commercial software). I'm not asking for that.
But not providing any help whatsoever since this extreme approach isn't realistic isn't right either, I believe. I would prefer to at least have a link to the official documentation to give the user something to work on. It looks really unprofessional if the official system update tool fails without giving the user any hint where to go to find out more. I think it's not right to say "we can't identify every possible bug and mention it in the docs so we're not even trying to reference the documentation at all".

All software has bugs because software is made by humans and that's okay. Even commercial software fails but if it's an essential tool (like in this case), there's always a help section or link. And if there's an upstream bug affecting an essential core tool of the distribution, there's usually a downstream bug to track the progress. I mean we are talking about the system update tool, not paint!

In the meantime, I've searched for an official documentation and it seems there's already a page for system upgrades.
https://duckduckgo.com/?q=fedora+upgrade+documentation&t=h_&ia=web
https://docs.fedoraproject.org/en-US/quick-docs/upgrading/

Well, I'd say that tiny paragraph could easily be extended or there could be a link to another page with "notes before upgrading": 1. backup; 2. regular update ...

"The best is to fix this upstream" - again, I agree with you - but that's not all. It's one of the most important tools and the user doesn't care about upstream bugs; what if it's not fixed properly and Fedora doesn't track the progress until another disgruntled Fedora user opens a bug report saying the release upgrade isn't working again? Now, the oldest gnome-software bug I referenced is from five years ago and I feel like this upgrade process has failed at least every other time, for different reasons. Some of those issues could be described in the official documentation.

As for the curl error which I've seen on multiple Fedora computers recently, in one case it was apparently gone after manually updating with dnf but I'm really not sure what it was. Other computers will never be updated manually like this because their users don't feel comfortable with the command line.

Comment 7 Basic Six 2021-05-07 13:52:43 UTC
Here's a real life example showing why a link to the documentation could be useful.

If the Fedora team would patch gnome-software to show something like this on the "Updates" page:

It's recommended to read the release notes and known issues before upgrading. For this and more, visit the update documentation:
https://docs.fedoraproject.org/en-US/quick-docs/upgrading/

Then, whenever a MATE user tries to upgrade and fails because the "Install" button is dead as described in Bug 1535744, they would first wonder why nothing happens and then go to the linked documentation. And there, it should say something like this:

Known issue: Upgrade doesn't start when clicking Install
Details: After downloading the upgrade and clicking Install, you are presented with a list of packages to be replaced (like "kernel") and then, you are asked for the root password. After typing in your password, nothing happens and the upgrade tool doesn't show any progress.
Solution: If the Install button isn't functional, you have to manually reboot your computer. The upgrade process should then start while the computer is booting up, which may take more than an hour. Nothing is upgraded before the computer is restarted.

Also, while you're at it, I'd recommend adding a link to the release notes and maybe something like "you should have backups" at the top of the page, instead of just a screenshot of the button people are supposed to click.


Note You need to log in before you can comment on or make changes to this bug.