Bug 1956501 - Error when building package with mock that requires java-11-openjdk
Summary: Error when building package with mock that requires java-11-openjdk
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: java-11-openjdk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 19:35 UTC by Nicolas De Amicis
Modified: 2021-05-08 19:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Nicolas De Amicis 2021-05-03 19:35:14 UTC
Description of problem:
Build a package with mock (like fedpkg mockbuild)

Version-Release number of selected component (if applicable):
java-11-openjdk-devel-1:11.0.11.0.9-2.fc35.x86_64

How reproducible:
always

Steps to Reproduce:
1. fedpkg clone forks/deamn/rpms/hawtjni
2. cd hawtjni
3. fedpkg mockbuild

Actual results:
 Installing       : java-11-openjdk-devel-1:11.0.11.0.9-2.fc35.x86_64                                                      115/165 
Error unpacking rpm package java-11-openjdk-devel-1:11.0.11.0.9-2.fc35.x86_64
  Installing       : javapackages-local-5.3.0-15.fc34.noarch                                                                116/165 
error: unpacking of archive failed on file /usr/lib/jvm/java-11-openjdk-11.0.11.0.9-2.fc35.x86_64/bin/jaotc;60904dc1: cpio: open
error: java-11-openjdk-devel-1:11.0.11.0.9-2.fc35.x86_64: install failed

Expected results:


Additional info:

Comment 1 Jerry James 2021-05-06 14:59:48 UTC
I hit the same problem.  After reading through the comments in bug 1954998, I ran "mock -r fedora-rawhide-x86_64 --scrub=all" and then tried my build again, and it worked that time.  Can you give that a try, Nicolas?

Comment 2 Nicolas De Amicis 2021-05-06 18:51:24 UTC
Thanks Jerry, it worked also for me now. But this problem is also on koji, this build (https://koji.fedoraproject.org/koji/taskinfo?taskID=66842772) was failed for the same reason.

Comment 3 Robert-André Mauchin 🐧 2021-05-08 19:33:38 UTC
Even with scruaaing my chroot, I still have this problem.


Note You need to log in before you can comment on or make changes to this bug.