Bug 1956514 - All windows disappear
Summary: All windows disappear
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 20:12 UTC by Creme Brulee
Modified: 2021-05-03 23:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
an extract from journalctl when the bug occurs (14.75 KB, text/plain)
2021-05-03 21:17 UTC, Creme Brulee
no flags Details

Description Creme Brulee 2021-05-03 20:12:57 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always
100% of cases

Steps to Reproduce:
press the winkey (super)
or
move the mouse cursor to the upper-left corner

Actual results:
All windows of running applications disappear for good.
You cannot switch to them with Alt-Tab, for example
I can observe a grey background, a system panel on top and an application panel on bottom. But clicking on them has no effect. Clicking on "show applications" has no effect either

Expected results:
miniature windows are to be shown. Windows are selectable. Alt-tab should continue working.

Additional info:
This bug lasts at least from Fedora 30.
But it used to be sporadic, not it's always reproducible on my machine

Video card ATI Radeon 9600, video driver: amdgpu.

Comment 1 Creme Brulee 2021-05-03 20:16:17 UTC
My previous bug report in Fedora 30
https://bugzilla.redhat.com/show_bug.cgi?id=1707158

Comment 2 Creme Brulee 2021-05-03 21:17:36 UTC
Created attachment 1779131 [details]
an extract from journalctl when the bug occurs

Comment 3 Creme Brulee 2021-05-03 21:25:21 UTC
Mystery solved!

The faulty applications are GNOME Shell (mutter?) and mpv.

GNOME windows disappear because mpv pushes a mangled title
$ wmctrl -l
0x04200002  0                   N/A ����������� ���� - mpv

relevant lines in journalctl (see the attached log):
gnome-shell[26159]: Invalid UTF-8 string passed to pango_layout_set_text()
gnome-shell[26159]: JS ERROR: TypeError: app is null
   _init@resource:///org/gnome/shell/ui/windowAttentionHandler.js:63:9
   _onWindowDemandsAttention@resource:///org/gnome/shell/ui/windowAttentionHandler.js:37:22

mpv takes a title from metadata of a video file.
So in my case if I run mpv with the --metadata-codepage=cp1251 option, everything works great: the title is correctly displayed and windows don't disappear.

From this it follows that
1) mpv should validate a string before making it a title
2) mutter should be protected against a mangled string (show an empty title for example)

Comment 4 Creme Brulee 2021-05-03 23:39:31 UTC
I filed bug reports upstream
https://github.com/mpv-player/mpv/issues/8812
https://gitlab.gnome.org/GNOME/mutter/-/issues/1794


Note You need to log in before you can comment on or make changes to this bug.