Bug 1956555 - opm alpha validate does not show failure status [NEEDINFO]
Summary: opm alpha validate does not show failure status
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.8
Hardware: All
OS: All
low
low
Target Milestone: ---
: 4.8-premerge
Assignee: Kevin Rizza
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 22:10 UTC by Bruno Andrade
Modified: 2021-05-04 16:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-04 16:08:56 UTC
Target Upstream Version:
ankithom: needinfo? (bandrade)


Attachments (Terms of Use)

Description Bruno Andrade 2021-05-03 22:10:27 UTC
Description of problem:

Given an invalid declarative config, the validate command does not show any messages for failure status

validDeclCfg
├── cockroachdb.json
└── etcd.json

opm alpha validate validPackages  


0 directories, 2 files

Version-Release number of selected component (if applicable):
opm version                     
Version: version.Version{OpmVersion:"v1.17.0-26-g7102c558", GitCommit:"7102c558", BuildDate:"2021-05-03T19:49:28Z", GoOs:"linux", GoArch:"amd64"}

How reproducible:
Always

Comment 1 Ankita Thomas 2021-05-04 14:25:51 UTC
./bin/opm alpha validate ./pkg/registry/testdata/validDeclCfg/
ERRO[0000] 1 error occurred:
	* invalid package "etcd": 1 error occurred:
	* default channel must be set

Looks like that was run with validPackages instead of validDeclCfg. Can you see if switching the directories helps?

Comment 2 Ankita Thomas 2021-05-04 16:08:56 UTC
We discussed this among the team, looks like the validate command isn't at a state where it's ready for testing yet. We don't want to open bugs for the alpha sub-commands just yet, those are still being iterated on.

Closing this out.


Note You need to log in before you can comment on or make changes to this bug.