Bug 1956566 - livemedia-creator fails with Fedora 34 ISOs: Invalid APM signature
Summary: livemedia-creator fails with Fedora 34 ISOs: Invalid APM signature
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pycdlib
Version: 34
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Chris Lalancette
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 22:52 UTC by Larry O'Leary
Modified: 2021-05-05 17:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
program.log generated from livemedia-creator (432 bytes, text/plain)
2021-05-04 16:52 UTC, Larry O'Leary
no flags Details
livemedia.log from livemedia-creator (2.36 KB, text/plain)
2021-05-04 16:53 UTC, Larry O'Leary
no flags Details

Description Larry O'Leary 2021-05-03 22:52:04 UTC
Description of problem:
Unfortunately I am not certain what is actually failing as I am not able to find any details about what is happening or where the error is actually originating.

When attempting to build live media using livemedia-creator I receive the error: "Problem reading label from /home/me/ks/Fedora-Server-netinst-x86_64-34-1.2.iso: Invalid APM signature"

I have attempted this with the Everything ISO with identical results. 

Version-Release number of selected component (if applicable):
Name         : lorax
Version      : 34.9
Release      : 5.fc34
Architecture : x86_64


How reproducible:
Always

Steps to Reproduce:
1. sudo livemedia-creator --make-iso --iso=Fedora-Server-netinst-x86_64-34-1.2.iso --ks=/usr/share/spin-kickstarts/fedora-live-workstation.ks

Actual results:
livemedia-creator terminates early with a final message of "'NoneType' object is not iterable". Note that this appears to be due to "Problem reading label from /home/me/ks/Fedora-Server-netinst-x86_64-34-1.2.iso: Invalid APM signature"

Expected results:
Live media ISO is created.

Additional info:
Here is the output of the command:

2021-05-03 18:44:34,276: livemedia-creator v34.9-1
2021-05-03 18:44:34,276: selinux is enabled and in Permissive mode
/usr/lib/python3.9/site-packages/pykickstart/commands/partition.py:448: KickstartParseWarning: A partition with the mountpoint / has already been defined.
  warnings.warn(_("A partition with the mountpoint %s has already been defined.") % pd.mountpoint, KickstartParseWarning)
2021-05-03 18:44:34,337: disk_img = /var/tmp/lmc-disk-d5ogag__.img
2021-05-03 18:44:34,337: Using disk size of 6658MiB
2021-05-03 18:44:34,337: install_log = /home/me/ks/virt-install.log
2021-05-03 18:44:34,343: Problem reading label from /home/me/ks/Fedora-Server-netinst-x86_64-34-1.2.iso: Invalid APM signature
2021-05-03 18:44:34,378: unmounting the iso
2021-05-03 18:44:34,382: 'NoneType' object is not iterable

Comment 1 Brian Lane 2021-05-04 15:38:04 UTC
Have you confirmed that the checksum of the iso matches what is expected? eg. https://dl.fedoraproject.org/pub/fedora/linux/releases/34/Server/x86_64/iso/Fedora-Server-34-1.2-x86_64-CHECKSUM

I've never seen 'APM signature' mentioned anywhere, and web searches aren't helping...

Can you attach the program.log file? It may have more details about what failed. Also check the system's logs with journalctl -e right after it fails to see if anything is logged.

I suspect it's just a corrupt iso file.

Comment 2 Larry O'Leary 2021-05-04 16:52:26 UTC
Created attachment 1779440 [details]
program.log generated from livemedia-creator

Comment 3 Larry O'Leary 2021-05-04 16:53:31 UTC
Created attachment 1779442 [details]
livemedia.log from livemedia-creator

The main contents of this file is already in comment #0

Comment 4 Larry O'Leary 2021-05-04 16:59:39 UTC
I have tried multiple ISOs and verified their checksums. I have also tried this on Fedora 33 and Fedora 34. I have also verified that the ISOs are mountable and bootable. This error only seems to be an issue when running livemedia-creator. I have also tried from two different machines so the problem seems consistent.

These specific logs were generated in my attempt to use mock but I have also tried without mock and using the Fedora 34 workstation kickstart file directly with identical results.

Comment 5 Larry O'Leary 2021-05-04 17:12:51 UTC
No error or warnings from journal during execution. Here are all three correlated logs. Note the livemedia-creator error was captured at 2021-05-04 12:03:44,979:

journalctl:
```
May 04 12:03:43 loleary userhelper[389849]: running '/usr/libexec/mock/mock -r fedora-34-x86_64-qemu --isolation=simple --chroot --enable-network cd /ks && livemedia-creator --ks /ks/flat-"loleary.ks" --iso="Fedora-Everything-netinst-x86_64-34-1.2.iso" --resultdir /data/lmc/"fedora-34-x86_64-qemu-loleary-RedHat-Live" --project "loleary - Fedora 34" --make-iso --iso-only --volid "Fedora-34-loleary" --iso-name "Fedora-34-loleary.iso" --releasever "34" --macboot --logfile livemedia.log' with root privileges on behalf of 'loleary'
May 04 12:03:44 loleary kernel: loop0: detected capacity change from 0 to 1325056
May 04 12:03:44 loleary kernel: ISO 9660 Extensions: Microsoft Joliet Level 3
May 04 12:03:44 loleary kernel: ISO 9660 Extensions: Microsoft Joliet Level 3
May 04 12:03:44 loleary kernel: ISO 9660 Extensions: RRIP_1991A
May 04 12:03:45 loleary systemd[9556]: var-lib-mock-fedora\x2d34\x2dx86_64-root-var-tmp-lorax.imgutils.3tqirjs5.mount: Succeeded.
May 04 12:03:45 loleary systemd[1]: var-lib-mock-fedora\x2d34\x2dx86_64-root-var-tmp-lorax.imgutils.3tqirjs5.mount: Succeeded.
May 04 12:03:45 loleary systemd[9556]: var-lib-mock-fedora\x2d34\x2dx86_64\x2dbootstrap-root-var-lib-mock-fedora\x2d34\x2dx86_64-root.mount: Succeeded.
```

program.log
```
2021-05-04 12:03:44,952 INFO: Running... mount -o loop /ks/Fedora-Everything-netinst-x86_64-34-1.2.iso /var/tmp/lorax.imgutils.3tqirjs5
2021-05-04 12:03:44,973 INFO: mount: /var/tmp/lorax.imgutils.3tqirjs5: WARNING: source write-protected, mounted read-only.
2021-05-04 12:03:44,974 DEBUG: Return code: 0
2021-05-04 12:03:45,122 INFO: Running... umount /var/tmp/lorax.imgutils.3tqirjs5
2021-05-04 12:03:45,145 DEBUG: Return code: 0
```

livemedia.log
```
2021-05-04 12:03:44,859 DEBUG livemedia-creator: Namespace(make_iso=True, make_disk=False, make_fsimage=False, make_appliance=False, make_ami=False, make_tar=False, make_tar_disk=False, make_pxe_live=False, make_ostree_live=False, make_oci=False, make_vagrant=False, iso='/ks/Fedora-Everything-netinst-x86_64-34-1.2.iso', iso_only=True, iso_name='Fedora-34-loleary.iso', ks=['/ks/flat-loleary.ks'], image_only=False, no_virt=False, proxy=None, anaconda_args=None, armplatform=None, location=None, logfile='/ks/livemedia.log', lorax_templates=None, tmp='/var/tmp', result_dir='/data/lmc/fedora-34-x86_64-qemu-loleary-RedHat-Live', domacboot=True, extra_boot_args='', disk_image=None, keep_image=False, fs_image=None, image_name=None, tar_disk_name=None, fs_label='Anaconda', image_size_align=0, image_type=None, qemu_args=[], qcow2=False, compression='xz', compress_args=[], app_name=None, app_template=None, app_file='appliance.xml', ram=2048, vcpus=None, vnc=None, arch=None, kernel_args=None, ovmf_path='/usr/share/edk2/ovmf/', virt_uefi=False, no_kvm=False, with_rng='/dev/random', dracut_conf=None, dracut_args=None, live_rootfs_size=0, live_rootfs_keep_size=False, oci_config=None, oci_runtime=None, vagrant_metadata=None, vagrantfile=None, project='loleary - Fedora 34', releasever='34', volid='Fedora-34-loleary', squashfs_only=False, timeout=None)
2021-05-04 12:03:44,859 INFO livemedia-creator: livemedia-creator v34.9-1
2021-05-04 12:03:44,859 INFO pylorax: selinux is Disabled
2021-05-04 12:03:44,952 INFO pylorax: disk_img = /data/lmc/fedora-34-x86_64-qemu-loleary-RedHat-Live/lmc-disk-fva_n4q8.img
2021-05-04 12:03:44,952 INFO pylorax: Using disk size of 16386MiB
2021-05-04 12:03:44,952 INFO pylorax: install_log = /ks/virt-install.log
2021-05-04 12:03:44,952 DEBUG pylorax.imgutils: make tmp mountdir /var/tmp/lorax.imgutils.3tqirjs5
2021-05-04 12:03:44,979 ERROR livemedia-creator: Problem reading label from /ks/Fedora-Everything-netinst-x86_64-34-1.2.iso: Invalid APM signature
2021-05-04 12:03:45,055 DEBUG pylorax.imgutils: find /var/tmp/lmc-ksdir-roc9nn0f -print0 |cpio --null --quiet -H newc -o | xz -T8 --check=crc32 -9 > /var/tmp/lmc-ks-0eficdl7.img
2021-05-04 12:03:45,122 INFO pylorax: unmounting the iso
2021-05-04 12:03:45,145 DEBUG pylorax.imgutils: remove tmp mountdir /var/tmp/lorax.imgutils.3tqirjs5
2021-05-04 12:03:45,145 ERROR livemedia-creator: 'NoneType' object is not iterable
```

Comment 6 Brian Lane 2021-05-04 22:14:53 UTC
I am unable to reproduce this with Fedora 33 and either the F34 or F33 isos, I am also unable to find any reference to what APM signature is.
Is there something special about your system?

Comment 7 Brian Lane 2021-05-05 17:03:47 UTC
Ok, I've figured this out. It's a bug in pycdlib that has been fixed in git and needs to be ported to the Fedora package.

https://github.com/clalancette/pycdlib/commit/6f0f7b67835eeb26ed3b045035f9b182d3fa08b0


Note You need to log in before you can comment on or make changes to this bug.