Bug 195657 - i386: Switch Memory Layout from DISCONTIG to SPARSEMEM
i386: Switch Memory Layout from DISCONTIG to SPARSEMEM
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On: 195391
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 09:18 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 09:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-06-16 09:18:58 EDT
+++ This bug was initially created as a clone of Bug #195391 +++

Description of problem:

It's time that we make the switch.  According to upstream reports SPARSEMEM will
eventually replace DISCONTIG.  However, testing of platforms has become a 
blocker for this... let's switch Fedora over and see what happens.  

I've tested on various x86_64 platforms (a couple of Dells, a few HPs, an IBM
box) and haven't seen any issues.

-- Additional comment from prarit@redhat.com on 2006-06-14 19:01 EST --
Created an attachment (id=130943)
Patch to switch to SPARSEMEM
Comment 1 Dave Jones 2006-07-11 01:36:16 EDT
x86-64 is now done (for the last week or so), nothing bad seems to have happened
so far.   i386 lacks this (or discontigmem) due to the absense of CONFIG_NUMA.

I'm not convinced that setting NUMA on i386 is a good idea.
In fact, from what I understand so far, it strikes me as a bad idea.

http://www.x86-64.org/lists/discuss/msg09335.html
Comment 2 Prarit Bhargava 2006-07-11 09:54:08 EDT
I think we can drop this.  The underlying issue behind switching to SPARSE is
memory hotplug which appears to only effect ia64, x86_64, and ppc/64.

P.

Note You need to log in before you can comment on or make changes to this bug.