Bug 1956648 - scribus can not be find in terminal
Summary: scribus can not be find in terminal
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 34
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-04 07:23 UTC by Lars Martin hambro
Modified: 2021-05-05 09:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-05 09:34:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Lars Martin hambro 2021-05-04 07:23:03 UTC
Description of problem:
sudo dnf install Scribus
Last metadata expiration check: 0:04:07 ago on ti. 04. mai 2021 kl. 09.03 +0200.
No match for argument: Scribus
  * Maybe you meant: scribus
Feil: Unable to find a match: Scribus
[larsmartinhambro@localhost ~]$ sudo dnf install Scribus
Last metadata expiration check: 0:04:15 ago on ti. 04. mai 2021 kl. 09.03 +0200.
No match for argument: Scribus
  * Maybe you meant: scribus
Feil: Unable to find a match: Scribus
[larsmartinhambro@localhost ~]$ sudo dnf search Scribus
Last metadata expiration check: 0:05:12 ago on ti. 04. mai 2021 kl. 09.03 +0200.
============================ Name Matched: Scribus =============================
scribus.x86_64 : Desktop Publishing application written in Qt
scribus-generator.noarch : Open source high-quality PDF template and mail-merge
                         : alternative
[larsmartinhambro@localhost ~]$ sudo dnf install Scribus.x86_64
Last metadata expiration check: 0:05:26 ago on ti. 04. mai 2021 kl. 09.03 +0200.
No match for argument: Scribus.x86_64
  * Maybe you meant: scribus
Feil: Unable to find a match: Scribus.x86_64
[larsmartinhambro@localhost ~]$ Scribus.x86_64
bash: Scribus.x86_64: command not found...
[larsmartinhambro@localhost ~]$ sudo dnf install scribus-1.5.6.1-5.fc34
Last metadata expiration check: 0:06:44 ago on ti. 04. mai 2021 kl. 09.03 +0200.
No match for argument: scribus-1.5.6.1-5.fc34
Feil: Unable to find a match: scribus-1.5.6.1-5.fc34

https://koji.fedoraproject.org/koji/buildinfo?buildID=1671313
need to download from this an install it manualy.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Panu Matilainen 2021-05-04 12:05:55 UTC
> No match for argument: Scribus
>  * Maybe you meant: scribus

Comment 2 Lars Martin hambro 2021-05-04 13:32:34 UTC
So easy why did i get:
scribus
QSocketNotifier: Can only be used with threads started with QThread
sizeof(TrkHeader)=1000
ReaderWriterTF::writeObject
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found
qt.gui.icc: Unsupported ICC profile class 70727472
QPngHandler: Failed to parse ICC profile
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()

Package scribus-1.5.6.1-6.fc34.x86_64 

https://www.scribus.net/scribus-1-5-7-released/

Its possible to upgrade this packages?
Because is look poor to open files from adobe indesign or illustrator.

its look like Document Viewer 40.1 did better job?

Comment 3 Marek Blaha 2021-05-05 09:34:47 UTC
The thing is that `dnf search` command (and a few others) is case insensitive. On the other hand `dnf install` is case sensitive and requires correct upper/lower case letters in the package name. Hence the hint `Maybe you meant: scribus`.
So to install the package, use "sudo dnf install scribus".

As far as upgrade of the package or its capabilities are concerned - you need to ask scribus package authors / maintainers.


Note You need to log in before you can comment on or make changes to this bug.