Bug 195669 - adminserver setup unable to find Apache modules
adminserver setup unable to find Apache modules
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks: 203999
  Show dependency treegraph
 
Reported: 2006-06-16 10:09 EDT by Rob Crittenden
Modified: 2015-01-04 18:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 20:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2006-06-16 10:09:04 EDT
Description of problem:

With FDS 1.0.2 (and likely all versions) on Ubuntu Dapper Drake the adminserver
setup program is unable to find the Apache modules.

-------

From the fedora-directory-users mailing list:

Running it interactively (on Debian and Ubuntu) and then choosing the '2 -
Typical' install mode) one comes to the point the installer tries to locate the
Apache modules, then it returns:

Unable to locate Apache modules in
/modules
.
Press any key to continue. 

In fact, the Apache modules are here on the system:

root@helix:/opt/fedora-ds/setup# ls -lsa /usr/lib/apache2/
total 28
 4 drwxr-xr-x  3 root root     4096 2006-06-15 11:05 .
 8 drwxr-xr-x 38 root root     8192 2006-06-15 12:02 ..
 4 drwxr-xr-x  2 root root     4096 2006-06-15 11:05 modules

However if one adds 'ApacheRoot=   /usr/lib/apache2' to the [admin] section of
an install.inf and one runs a silent install afterwards, there seems to be no
problem.

-------

Now the setup program runs httpd -V in and uses the value of HTTPD_ROOT to
determine where the modules are. This doesn't work on Debian systems,
apparently. The output on Dapper is:

root@helix:/opt/fedora-ds# httpd -V
Server version: Apache/2.0.55
Server built:   May 29 2006 01:44:04
Server's Module Magic Number: 20020903:11
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/worker"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT=""
 -D SUEXEC_BIN="/usr/lib/apache2/suexec2"
 -D DEFAULT_PIDLOG="/var/run/apache2.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
 -D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"
Comment 1 Rich Megginson 2006-06-20 17:30:48 EDT
Looks like we need to change setup to get the SERVER_CONFIG_FILE and parse it to
determine the server root and modules directory.
Comment 2 Rich Megginson 2008-07-14 20:15:14 EDT
This is vastly different now in Fedora DS 1.1 and later.

Note You need to log in before you can comment on or make changes to this bug.