Bug 1956840 - [ceph-ansible] cephadm-adopt - Enable pool application on nfs-ganesha pool in the playbook
Summary: [ceph-ansible] cephadm-adopt - Enable pool application on nfs-ganesha pool in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 5.0z1
Assignee: Dimitri Savineau
QA Contact: Ameena Suhani S H
Ranjini M N
URL:
Whiteboard:
Depends On:
Blocks: 1959686
TreeView+ depends on / blocked
 
Reported: 2021-05-04 14:16 UTC by Vasishta
Modified: 2021-11-02 16:39 UTC (History)
13 users (show)

Fixed In Version: ceph-ansible-6.0.13-1.el8cp
Doc Type: Bug Fix
Doc Text:
.The `cephadm-adopt` playbook now enables the pool application on the pool when creating a new `nfs-ganesha` pool Previously, when the `cephadm-adopt` playbook created a new `nfs-ganesha` pool, it did not enable the pool application on the pool. This resulted in a warning that one pool did not have the pool application enabled. With this update, the `cephadm-adopt` playbook sets the pool application on the created pool, and a warning after the adoption no longer occurs.
Clone Of:
Environment:
Last Closed: 2021-11-02 16:38:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 6688 0 None open cephadm-adopt: set application on ganesha pool (backport #6687) 2021-07-09 21:38:13 UTC
Red Hat Issue Tracker RHCEPH-90 0 None None None 2021-09-01 03:23:54 UTC
Red Hat Product Errata RHBA-2021:4105 0 None None None 2021-11-02 16:39:08 UTC

Description Vasishta 2021-05-04 14:16:30 UTC
Description of problem:
cephadma-adopt playbook creates a new pool [1]. After cephadm-adopt exits successfully, cluster warns users saying 1 pool(s) do not have an application enabled

Version-Release number of selected component (if applicable):
ceph-ansible-6.0.5-1.el8cp.noarch.rpm  

How reproducible:
Always (2/2)

Steps to Reproduce:
1. Configure a RHCS 4.x cluster with nfs-ganesha 
2. Upgdate cluster to 5.x
3. run cephadm-adopt and check ceph health detail

Actual results:
[WRN] POOL_APP_NOT_ENABLED: 1 pool(s) do not have an application enabled
    application not enabled on pool 'nfs-ganesha'
    use 'ceph osd pool application enable <pool-name> <app-name>', where <app-name> is 'cephfs', 'rbd', 'rgw', or freeform for custom applications.


Expected results:
Warning to user can be avoided

Additional info:
[1] https://github.com/ceph/ceph-ansible/pull/6487

Comment 14 errata-xmlrpc 2021-11-02 16:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 5.0 Bug Fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4105


Note You need to log in before you can comment on or make changes to this bug.